------- Additional Comments From [hidden email] 2005-05-31 17:43 -------
(In reply to comment #18)
> (In reply to comment #17)
> PS: and this code would remain the same whatever future changes are made to
> createLogClass or handleFlawedDiscovery...
You're right. I was resisting the approach of returning after the call to
createLogClass() because I generally don't like a bunch of return statements in
a method. But I realize now I was thinking in terms of returning after _every_
call to createLogClass(), which would add a bunch of returns. This is not
necessary and not what you're suggesting; adding a return for the one special
case of specifiedLogClassName makes sense and clarifies the code.