[EMAIL] Problem resolving pom to the jar

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[EMAIL] Problem resolving pom to the jar

Greg Pagendam-Turner
Guys,

I'm trying to find out why maven is not downloading the jar file for
commons-email

In my pom.xml I have

<repository>
<id>org.apache.commons</id>
<url>http://repo1.maven.org/maven2</url>
</repository>
and
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-email</artifactId>
<version>1.2</version>
<type>pom</type>
</dependency>

But only the pom and sha1 files are downloaded.

I get commons-email-1.2.pom and commons-email-1.2.pom.sha1

I'd appreciate any clues on why the commons-email-1.2.jar is not
downloaded when I run a mvn package.

Regards,

Greg.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

kkk
Reply | Threaded
Open this post in threaded view
|

Re: [EMAIL] Problem resolving pom to the jar

kkk
2010/5/13 Greg Pagendam-Turner <[hidden email]>

> Guys,
>
> I'm trying to find out why maven is not downloading the jar file for
> commons-email
>
> In my pom.xml I have
>
> <repository>
> <id>org.apache.commons</id>
> <url>http://repo1.maven.org/maven2</url>
> </repository>
> and
> <dependency>
> <groupId>org.apache.commons</groupId>
> <artifactId>commons-email</artifactId>
> <version>1.2</version>
> <type>pom</type>
> </dependency>
>


Remove the type tag:

----------
<dependency>
<groupId>org.apache.commons</groupId>
<artifactId>commons-email</artifactId>
<version>1.2</version>
</dependency>

-----------

> But only the pom and sha1 files are downloaded.
>
> I get commons-email-1.2.pom and commons-email-1.2.pom.sha1
>
> I'd appreciate any clues on why the commons-email-1.2.jar is not downloaded
> when I run a mvn package.
>
> Regards,
>
> Greg.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [EMAIL] Problem resolving pom to the jar

Greg Pagendam-Turner
That solved the problem. Thank you.



On 13/05/2010 3:53 PM, maven apache wrote:

> 2010/5/13 Greg Pagendam-Turner<[hidden email]>
>
>    
>> Guys,
>>
>> I'm trying to find out why maven is not downloading the jar file for
>> commons-email
>>
>> In my pom.xml I have
>>
>> <repository>
>> <id>org.apache.commons</id>
>> <url>http://repo1.maven.org/maven2</url>
>> </repository>
>> and
>> <dependency>
>> <groupId>org.apache.commons</groupId>
>> <artifactId>commons-email</artifactId>
>> <version>1.2</version>
>> <type>pom</type>
>> </dependency>
>>
>>      
>
> Remove the type tag:
>
> ----------
> <dependency>
> <groupId>org.apache.commons</groupId>
> <artifactId>commons-email</artifactId>
> <version>1.2</version>
> </dependency>
>
> -----------
>
>    
>> But only the pom and sha1 files are downloaded.
>>
>> I get commons-email-1.2.pom and commons-email-1.2.pom.sha1
>>
>> I'd appreciate any clues on why the commons-email-1.2.jar is not downloaded
>> when I run a mvn package.
>>
>> Regards,
>>
>> Greg.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>>      
>    


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]