[GitHub] acoburn commented on issue #53: COMMONSRDF-80: Bumping Jena version 3.5.0 => 3.9.0

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] acoburn commented on issue #53: COMMONSRDF-80: Bumping Jena version 3.5.0 => 3.9.0

GitBox
acoburn commented on issue #53: COMMONSRDF-80: Bumping Jena version 3.5.0 => 3.9.0
URL: https://github.com/apache/commons-rdf/pull/53#issuecomment-451458390
 
 
   I believe that only `jena-arq` is necessary for `commons-rdf-jena`; as @stain indicates, `apache-jena-libs` may bring in more transitive dependencies than a user really needs.
   
   FWIW, I have been using `commons-rdf-jena` in an OSGi context for some time, but I don't rely on maven's dependency resolution for OSGi deployment. Since OSGi package resolution works at the bundle level (rather than based on declared dependencies in a POM file), I simply use the Jena-provided `jena-osgi-features` for deployment of Jena-related bundles in Karaf. At the same time, for non-OSGi contexts, my build configuration excludes the `jena-osgi` dependency from `commons-rdf-jena` and replaces it with `jena-arq`, which leads to somewhat more complexity than is really needed.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]