[GitHub] aremily commented on issue #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2 and 1.0.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] aremily commented on issue #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2 and 1.0.1

GitBox
aremily commented on issue #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2 and 1.0.1
URL: https://github.com/apache/commons-crypto/pull/92#issuecomment-462010162
 
 
   It does.  Thank you.  I ran the build successfully with 1.1.0 on Mac OSX
   and 1.0.2 on Ubuntu 16.04, but when I pushed to GitHub Travis fails testing
   because of a system crash that I can't reproduce.  Not sure how to
   proceed.  Can you have a look?  I think it's what you're looking for in
   terms of support to 1.0.2 and 1.1.0.
   
   On Thu, Feb 7, 2019 at 1:58 PM Marcelo Vanzin <[hidden email]>
   wrote:
   
   > If I understand context->encrypt correctly, it just tracks whether the
   > context is being used for encryption or decryption, right?
   >
   > If that's the case, you could stash that information in the
   > EVP_CTX_Wrapper created by the commons-crypto library. Set it in
   > Java_org_apache_commons_crypto_cipher_OpenSslNative_init, and change some
   > internal functions to take the wrapper instead of the OpenSSL context
   > directly.
   >
   > Does that solve your problem?
   >
   > —
   > You are receiving this because you authored the thread.
   > Reply to this email directly, view it on GitHub
   > <https://github.com/apache/commons-crypto/pull/92#issuecomment-461553133>,
   > or mute the thread
   > <https://github.com/notifications/unsubscribe-auth/AGg8fr1e5_YTvVHqfkjxdnTXzjUtJFutks5vLHdHgaJpZM4ZgACn>
   > .
   >
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]