[GitHub] aremily opened a new pull request #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[GitHub] aremily opened a new pull request #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2

GitBox
aremily opened a new pull request #92: OpenSSL 1.1.0 updates with backward compatibility for OpenSSL 1.0.2
URL: https://github.com/apache/commons-crypto/pull/92
 
 
   Commons Crypto Dev Team,
   
   Please consider this submission for incorporation into the master.  I believe it meets the criteria that Marcelo specified via the mailing list, in that it supports both 1.1.0 and 1.0.2 with one jar file.  See the relevant thread at the url:
   
   http://mail-archives.apache.org/mod_mbox/commons-dev/201811.mbox/browser
   
   I made every effort to keep changes minimally invasive and to keep the the underlying OpenSSL library version transparent to the Java developer.  The JNA package dynamically determines whether the underlying OpenSSL library is 1.0.2 or 1.1.0; the Java developer needn't provide versioning information in any config file.  The JNI libraries, however, must be compiled against the specific version of OpenSSL being used, but once that is done there is no change to the Java API or requirement to provide version information as a config parameter.
   
   This branch has been tested with Oracle Java 8 by running "mvn clean test" against the following platforms and versions of OpenSSL:
   
   Ubuntu 16.04 and OpenSSL 1.0.2n
   Ubuntu 18.04 and OpenSSL 1.1.0i
   Mac High Sierra and OpenSSL 1.1.0i
   
   I look forward to your feedback.
   
   Alex

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


With regards,
Apache Git Services

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]