HELP: jsvc on Linux(Ubuntu/Kububtu)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

HELP: jsvc on Linux(Ubuntu/Kububtu)

MC Moisei-2
I'm having a big issues with jsvc starting Tomcat. I follow the example
that comes in the tomcat 5.5.9.
All seems to be fine but I get this return code of 1 and complains anout
DaemonLoaded. It's not the regular class not found exception but rather
a bried info.

Okay here's what I did
- created a user tomcat
- untared the tomcat 5.5.9 under /home/tomcat/jakarta-tomcat5.5.9
-from the bin folder I've untar the jsvs-src.tar file and then compiled it
-I copied the resulted binary under /home/tomcat/jakarta-tomcat5.5.9/bin
-I called it accordingly with the Tomcat5.sh
-set the CATALINA_HOME to point to /home/tomcat/jakarta-tomcat5.5.9/
-set the JAVA_HOME to jdk1.4.2_08

I'm very sure the commons-daemon.jar is in the classpath, also added to
classpath the bootstrap.jar, tools.jar. All paths look alright.

Also I've added the -verbose and -debug options but couldn't find
anything. Everything seems to be just fine till it returns with 1.

Anyone seen this thing before. It consumed a lot of hours today.

My best,
MC





---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: HELP: jsvc on Linux

MC Moisei-2
I've passed over the return code of 1 - seems that the rights were not
okay. And package was not visible.

After fixing that I start getting a 4 as below..
jsvc.exec error: Cannot open PID file /var/run/jsvc.pid, PID is 9005
jsvc.exec error: syscall failed in set_caps
jsvc.exec error: Service exit with a return value of 4

Okay. Here is what I did. I found that there is a bug in the native code
and I did comment in jsvc-unix.c where return 4 is thrown. Then I've
recompiled.
I also find that mx4j.jar is not distributed with Tomcat and jsvc/tomcat
would crash trying to find javax.management.* classes.
Once I put the jar in place I no longer had problems.

The strange part that I cannot figure it out is that when I use root to
launch the script seems that the pid is created and the tomcat service
is running on 8080 but when I try to get there using the browser it's
clocking forever-ever. Using stop option the process is killed and right
away I get a popup in the browser saying that I was disconnected.

I know that this is a access problem, what do I have to have it working ?

TIA,
MC






MC Moisei wrote:

> I'm having a big issues with jsvc starting Tomcat. I follow the
> example that comes in the tomcat 5.5.9.
> All seems to be fine but I get this return code of 1 and complains
> anout DaemonLoaded. It's not the regular class not found exception but
> rather a bried info.
>
> Okay here's what I did
> - created a user tomcat
> - untared the tomcat 5.5.9 under /home/tomcat/jakarta-tomcat5.5.9
> -from the bin folder I've untar the jsvs-src.tar file and then
> compiled it
> -I copied the resulted binary under /home/tomcat/jakarta-tomcat5.5.9/bin
> -I called it accordingly with the Tomcat5.sh
> -set the CATALINA_HOME to point to /home/tomcat/jakarta-tomcat5.5.9/
> -set the JAVA_HOME to jdk1.4.2_08
>
> I'm very sure the commons-daemon.jar is in the classpath, also added
> to classpath the bootstrap.jar, tools.jar. All paths look alright.
>
> Also I've added the -verbose and -debug options but couldn't find
> anything. Everything seems to be just fine till it returns with 1.
>
> Anyone seen this thing before. It consumed a lot of hours today.
>
> My best,
> MC
>
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]