Maven artifacts for commons.io 2.5 corrupt

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Maven artifacts for commons.io 2.5 corrupt

P Holder
I don't know if anyone else has reported this, as I am not on any of
the mail lists, but I didn't want to leave it unreported.

Yesterday I added commons.io 2.5 to my project, and was getting class
loading errors.  I looked at the downloaded jar, and there were a lot
of 0 byte class files in it.  I switched to 2.4 and it worked fine.

Paul

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Maven artifacts for commons.io 2.5 corrupt

sebb-2-2
A quick jar listing looks OK to me.

Have you checked the hash to make sure the jar was downloaded OK?

Which classes are empty?


On 24 August 2016 at 19:37, P Holder <[hidden email]> wrote:

> I don't know if anyone else has reported this, as I am not on any of
> the mail lists, but I didn't want to leave it unreported.
>
> Yesterday I added commons.io 2.5 to my project, and was getting class
> loading errors.  I looked at the downloaded jar, and there were a lot
> of 0 byte class files in it.  I switched to 2.4 and it worked fine.
>
> Paul
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Maven artifacts for commons.io 2.5 corrupt

jochen-2
And, in particular: Where, and what, did you download? Jar file from a
Maven repositoiry? Which repo?


On Wed, Aug 24, 2016 at 9:51 PM, sebb <[hidden email]> wrote:

> A quick jar listing looks OK to me.
>
> Have you checked the hash to make sure the jar was downloaded OK?
>
> Which classes are empty?
>
>
> On 24 August 2016 at 19:37, P Holder <[hidden email]> wrote:
>> I don't know if anyone else has reported this, as I am not on any of
>> the mail lists, but I didn't want to leave it unreported.
>>
>> Yesterday I added commons.io 2.5 to my project, and was getting class
>> loading errors.  I looked at the downloaded jar, and there were a lot
>> of 0 byte class files in it.  I switched to 2.4 and it worked fine.
>>
>> Paul
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>



--
The next time you hear: "Don't reinvent the wheel!"

http://www.keystonedevelopment.co.uk/wp-content/uploads/2014/10/evolution-of-the-wheel-300x85.jpg

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]