Re: [CLI] IBiblio versus Apache Website

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

Re: [CLI] IBiblio versus Apache Website

Brian K. Wallace
Hash: SHA1

Grant Ingersoll wrote:
| I am having a weird discrepancy in CLI that is causing a bug in my
| code.
| I am in the process of converting my projects to Maven.  In doing so, I
| specified my commons-cli dependency as:
| <dependency>
|             <groupId>commons-cli</groupId>
|             <artifactId>commons-cli</artifactId>
|             <version>1.0</version>
|         </dependency>
| Everything downloaded from IBiblio
| ( fine, or so I thought.
| Upon doing so, though, tests that ran fine before now don't work.
| Before switching to Maven, I was building against a version of CLI I
| downloaded from the Apache mirrors
| (
| After pulling my hair out for I while (and debugging to isolate it in
| CLI), I tried switching my CLI implementation from the Maven version to
| the Apache download and it all worked again.  The bug seems to have to
| do w/ an option where hasArgs is true
| Upon further inspection of the Jars, which both claim to be 1.0, I
| noticed that the IBiblio one is 32k while the Apache one is 30k.  The
| 30k one works, the 32k one does not.
| Does anyone know why they are out of synch and how to remedy this?  I
| _believe_ I can extract my code to reproduce the bug if the IBiblio one
| in fact is the correct one.
| Thanks,
| Grant
| ---------------------------------------------------------------------
| To unsubscribe, e-mail: [hidden email]
| For additional commands, e-mail: [hidden email]
There has been a thread ongoing about CLI 1.0 that appears to be in the
process of getting fixed as 1.0.1.


Version: GnuPG v1.2.5 (MingW32)


To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]