Re: svn commit: r1799599 - /commons/proper/configuration/trunk/pom.xml

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r1799599 - /commons/proper/configuration/trunk/pom.xml

garydgregory
But why use an older version of Jackson? ;-)

Gary

On Thu, Jun 22, 2017 at 10:40 AM, <[hidden email]> wrote:

> Author: oheger
> Date: Thu Jun 22 17:40:53 2017
> New Revision: 1799599
>
> URL: http://svn.apache.org/viewvc?rev=1799599&view=rev
> Log:
> Updated dependency to jackson-databind.
>
> Also moved new dependencies out of the section for test
> dependencies.
>
> Modified:
>     commons/proper/configuration/trunk/pom.xml
>
> Modified: commons/proper/configuration/trunk/pom.xml
> URL: http://svn.apache.org/viewvc/commons/proper/configuration/
> trunk/pom.xml?rev=1799599&r1=1799598&r2=1799599&view=diff
> ============================================================
> ==================
> --- commons/proper/configuration/trunk/pom.xml (original)
> +++ commons/proper/configuration/trunk/pom.xml Thu Jun 22 17:40:53 2017
> @@ -360,6 +360,20 @@
>        <scope>provided</scope>
>      </dependency>
>
> +    <dependency>
> +      <groupId>org.yaml</groupId>
> +      <artifactId>snakeyaml</artifactId>
> +      <version>1.18</version>
> +      <optional>true</optional>
> +    </dependency>
> +
> +    <dependency>
> +      <groupId>com.fasterxml.jackson.core</groupId>
> +      <artifactId>jackson-databind</artifactId>
> +      <version>2.5.3</version>
> +      <optional>true</optional>
> +    </dependency>
> +
>      <!-- Needed for testing -->
>
>      <dependency>
> @@ -469,22 +483,6 @@
>        <version>${slf4j.version}</version>
>        <scope>test</scope>
>      </dependency>
> -
> -
> -    <dependency>
> -      <groupId>org.yaml</groupId>
> -      <artifactId>snakeyaml</artifactId>
> -      <version>1.18</version>
> -      <optional>true</optional>
> -    </dependency>
> -
> -
> -    <dependency>
> -      <groupId>com.fasterxml.jackson.core</groupId>
> -      <artifactId>jackson-databind</artifactId>
> -      <version>2.5.3</version>
> -      <optional>true</optional>
> -    </dependency>
>    </dependencies>
>
>    <properties>
>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: svn commit: r1799599 - /commons/proper/configuration/trunk/pom.xml

Oliver Heger-3


Am 22.06.2017 um 21:36 schrieb Gary Gregory:
> But why use an older version of Jackson? ;-)

This was the version that was referenced by the patch. I did not check
against the most recent version. Maybe the original author can answer this?

Oliver

>
> Gary
>
> On Thu, Jun 22, 2017 at 10:40 AM, <[hidden email]> wrote:
>
>> Author: oheger
>> Date: Thu Jun 22 17:40:53 2017
>> New Revision: 1799599
>>
>> URL: http://svn.apache.org/viewvc?rev=1799599&view=rev
>> Log:
>> Updated dependency to jackson-databind.
>>
>> Also moved new dependencies out of the section for test
>> dependencies.
>>
>> Modified:
>>     commons/proper/configuration/trunk/pom.xml
>>
>> Modified: commons/proper/configuration/trunk/pom.xml
>> URL: http://svn.apache.org/viewvc/commons/proper/configuration/
>> trunk/pom.xml?rev=1799599&r1=1799598&r2=1799599&view=diff
>> ============================================================
>> ==================
>> --- commons/proper/configuration/trunk/pom.xml (original)
>> +++ commons/proper/configuration/trunk/pom.xml Thu Jun 22 17:40:53 2017
>> @@ -360,6 +360,20 @@
>>        <scope>provided</scope>
>>      </dependency>
>>
>> +    <dependency>
>> +      <groupId>org.yaml</groupId>
>> +      <artifactId>snakeyaml</artifactId>
>> +      <version>1.18</version>
>> +      <optional>true</optional>
>> +    </dependency>
>> +
>> +    <dependency>
>> +      <groupId>com.fasterxml.jackson.core</groupId>
>> +      <artifactId>jackson-databind</artifactId>
>> +      <version>2.5.3</version>
>> +      <optional>true</optional>
>> +    </dependency>
>> +
>>      <!-- Needed for testing -->
>>
>>      <dependency>
>> @@ -469,22 +483,6 @@
>>        <version>${slf4j.version}</version>
>>        <scope>test</scope>
>>      </dependency>
>> -
>> -
>> -    <dependency>
>> -      <groupId>org.yaml</groupId>
>> -      <artifactId>snakeyaml</artifactId>
>> -      <version>1.18</version>
>> -      <optional>true</optional>
>> -    </dependency>
>> -
>> -
>> -    <dependency>
>> -      <groupId>com.fasterxml.jackson.core</groupId>
>> -      <artifactId>jackson-databind</artifactId>
>> -      <version>2.5.3</version>
>> -      <optional>true</optional>
>> -    </dependency>
>>    </dependencies>
>>
>>    <properties>
>>
>>
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]