[Text] Any reason to not upgrade to lang 3.5

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

[Text] Any reason to not upgrade to lang 3.5

Rob Tompkins
Hi,

I was looking through the pom and notice that [lang] is a dependency of [text], and the pom references [lang, 3.4]. Does anyone have any problems with upgrading to 3.5? The only thing that seems at all concerning is the comment in the code stating:

        <!-- if upgrading, be sure to check shaded jar relocations! -->

the meaning of which isn’t entirely clear to me. The only thing that I can think of is that the package names could change, as in standard commons practice, between major version releases. Am I interpreting that correctly? Any issues with just moving up in version?

Cheers,
-Rob
Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

garydgregory
Update away. I'm not sure why shading is in the picture though.

Gary

On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]> wrote:

> Hi,
>
> I was looking through the pom and notice that [lang] is a dependency of
> [text], and the pom references [lang, 3.4]. Does anyone have any problems
> with upgrading to 3.5? The only thing that seems at all concerning is the
> comment in the code stating:
>
>         <!-- if upgrading, be sure to check shaded jar relocations! -->
>
> the meaning of which isn’t entirely clear to me. The only thing that I can
> think of is that the package names could change, as in standard commons
> practice, between major version releases. Am I interpreting that correctly?
> Any issues with just moving up in version?
>
> Cheers,
> -Rob




--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<https://www.amazon.com/gp/product/1617290459/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>

<http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1617290459>
JUnit in Action, Second Edition
<https://www.amazon.com/gp/product/1935182021/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22>

<http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182021>
Spring Batch in Action
<https://www.amazon.com/gp/product/1935182951/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
<http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182951>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

Bruno P. Kinoshita-3
+1 to update away

I think it could be a mistake while creating the initial project structure. Don't remember why there would be a dependency between [text] and [lang].


>________________________________
> From: Gary Gregory <[hidden email]>
>To: Commons Developers List <[hidden email]>
>Sent: Tuesday, 8 November 2016 3:53 PM
>Subject: Re: [Text] Any reason to not upgrade to lang 3.5
>
>
>Update away. I'm not sure why shading is in the picture though.
>
>Gary
>
>
>On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]> wrote:
>
>> Hi,
>>
>> I was looking through the pom and notice that [lang] is a dependency of
>> [text], and the pom references [lang, 3.4]. Does anyone have any problems
>> with upgrading to 3.5? The only thing that seems at all concerning is the
>> comment in the code stating:
>>
>>         <!-- if upgrading, be sure to check shaded jar relocations! -->
>>
>> the meaning of which isn’t entirely clear to me. The only thing that I can
>> think of is that the package names could change, as in standard commons
>> practice, between major version releases. Am I interpreting that correctly?
>> Any issues with just moving up in version?
>>
>> Cheers,
>> -Rob
>
>
>
>
>--
>E-Mail: [hidden email] | [hidden email]
>Java Persistence with Hibernate, Second Edition
><https://www.amazon.com/gp/product/1617290459/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>
>
><http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1617290459>
>JUnit in Action, Second Edition
><https://www.amazon.com/gp/product/1935182021/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22>
>
><http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182021>
>Spring Batch in Action
><https://www.amazon.com/gp/product/1935182951/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
><http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182951>
>Blog: http://garygregory.wordpress.com
>Home: http://garygregory.com/
>Tweet! http://twitter.com/GaryGregory
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

Rob Tompkins

> On Nov 7, 2016, at 10:23 PM, Bruno P. Kinoshita <[hidden email]> wrote:
>
> +1 to update away
>
> I think it could be a mistake while creating the initial project structure. Don't remember why there would be a dependency between [text] and [lang].

Do you want to attempt a removal of the dependency on [lang]?

-Rob

>
>
>> ________________________________
>> From: Gary Gregory <[hidden email]>
>> To: Commons Developers List <[hidden email]>
>> Sent: Tuesday, 8 November 2016 3:53 PM
>> Subject: Re: [Text] Any reason to not upgrade to lang 3.5
>>
>>
>> Update away. I'm not sure why shading is in the picture though.
>>
>> Gary
>>
>>
>> On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]> wrote:
>>
>>> Hi,
>>>
>>> I was looking through the pom and notice that [lang] is a dependency of
>>> [text], and the pom references [lang, 3.4]. Does anyone have any problems
>>> with upgrading to 3.5? The only thing that seems at all concerning is the
>>> comment in the code stating:
>>>
>>>        <!-- if upgrading, be sure to check shaded jar relocations! -->
>>>
>>> the meaning of which isn’t entirely clear to me. The only thing that I can
>>> think of is that the package names could change, as in standard commons
>>> practice, between major version releases. Am I interpreting that correctly?
>>> Any issues with just moving up in version?
>>>
>>> Cheers,
>>> -Rob
>>
>>
>>
>>
>> --
>> E-Mail: [hidden email] | [hidden email]
>> Java Persistence with Hibernate, Second Edition
>> <https://www.amazon.com/gp/product/1617290459/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>
>>
>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1617290459>
>> JUnit in Action, Second Edition
>> <https://www.amazon.com/gp/product/1935182021/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22>
>>
>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182021>
>> Spring Batch in Action
>> <https://www.amazon.com/gp/product/1935182951/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182951>
>> Blog: http://garygregory.wordpress.com
>> Home: http://garygregory.com/
>> Tweet! http://twitter.com/GaryGregory
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

Rob Tompkins

> On Nov 8, 2016, at 9:38 AM, Rob Tompkins <[hidden email]> wrote:
>
>
>> On Nov 7, 2016, at 10:23 PM, Bruno P. Kinoshita <[hidden email]> wrote:
>>
>> +1 to update away
>>
>> I think it could be a mistake while creating the initial project structure. Don't remember why there would be a dependency between [text] and [lang].
>
> Do you want to attempt a removal of the dependency on [lang]?

It looks like the main dependency is based upon StringUtils. Any thoughts on how we tackle that class from [lang]? I would think that we might minimally pull over the code that causes our dependency on [lang], and maybe some of the more complex methods?

-Rob

>
> -Rob
>
>>
>>
>>> ________________________________
>>> From: Gary Gregory <[hidden email]>
>>> To: Commons Developers List <[hidden email]>
>>> Sent: Tuesday, 8 November 2016 3:53 PM
>>> Subject: Re: [Text] Any reason to not upgrade to lang 3.5
>>>
>>>
>>> Update away. I'm not sure why shading is in the picture though.
>>>
>>> Gary
>>>
>>>
>>> On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]> wrote:
>>>
>>>> Hi,
>>>>
>>>> I was looking through the pom and notice that [lang] is a dependency of
>>>> [text], and the pom references [lang, 3.4]. Does anyone have any problems
>>>> with upgrading to 3.5? The only thing that seems at all concerning is the
>>>> comment in the code stating:
>>>>
>>>>       <!-- if upgrading, be sure to check shaded jar relocations! -->
>>>>
>>>> the meaning of which isn’t entirely clear to me. The only thing that I can
>>>> think of is that the package names could change, as in standard commons
>>>> practice, between major version releases. Am I interpreting that correctly?
>>>> Any issues with just moving up in version?
>>>>
>>>> Cheers,
>>>> -Rob
>>>
>>>
>>>
>>>
>>> --
>>> E-Mail: [hidden email] | [hidden email]
>>> Java Persistence with Hibernate, Second Edition
>>> <https://www.amazon.com/gp/product/1617290459/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>
>>>
>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1617290459>
>>> JUnit in Action, Second Edition
>>> <https://www.amazon.com/gp/product/1935182021/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22>
>>>
>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182021>
>>> Spring Batch in Action
>>> <https://www.amazon.com/gp/product/1935182951/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182951>
>>> Blog: http://garygregory.wordpress.com
>>> Home: http://garygregory.com/
>>> Tweet! http://twitter.com/GaryGregory
>>>
>>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

Jörg Schaible-5
Rob Tompkins wrote:

>
>
>> On Nov 8, 2016, at 9:38 AM, Rob Tompkins <[hidden email]> wrote:
>>
>>
>>> On Nov 7, 2016, at 10:23 PM, Bruno P. Kinoshita
>>> <[hidden email]> wrote:
>>>
>>> +1 to update away
>>>
>>> I think it could be a mistake while creating the initial project
>>> structure. Don't remember why there would be a dependency between [text]
>>> and [lang].
>>
>> Do you want to attempt a removal of the dependency on [lang]?
>
> It looks like the main dependency is based upon StringUtils. Any thoughts
> on how we tackle that class from [lang]? I would think that we might
> minimally pull over the code that causes our dependency on [lang], and
> maybe some of the more complex methods?

This is IMHO what the shade plugin already does. Just that it avoids a
rotting copy.

Cheers,
Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

garydgregory
In reply to this post by Rob Tompkins
I would be OK with a direct dependency because in my mind [text] is a
higher level component.

Gary

On Nov 8, 2016 6:38 AM, "Rob Tompkins" <[hidden email]> wrote:

>
> > On Nov 7, 2016, at 10:23 PM, Bruno P. Kinoshita <
> [hidden email]> wrote:
> >
> > +1 to update away
> >
> > I think it could be a mistake while creating the initial project
> structure. Don't remember why there would be a dependency between [text]
> and [lang].
>
> Do you want to attempt a removal of the dependency on [lang]?
>
> -Rob
>
> >
> >
> >> ________________________________
> >> From: Gary Gregory <[hidden email]>
> >> To: Commons Developers List <[hidden email]>
> >> Sent: Tuesday, 8 November 2016 3:53 PM
> >> Subject: Re: [Text] Any reason to not upgrade to lang 3.5
> >>
> >>
> >> Update away. I'm not sure why shading is in the picture though.
> >>
> >> Gary
> >>
> >>
> >> On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]>
> wrote:
> >>
> >>> Hi,
> >>>
> >>> I was looking through the pom and notice that [lang] is a dependency of
> >>> [text], and the pom references [lang, 3.4]. Does anyone have any
> problems
> >>> with upgrading to 3.5? The only thing that seems at all concerning is
> the
> >>> comment in the code stating:
> >>>
> >>>        <!-- if upgrading, be sure to check shaded jar relocations! -->
> >>>
> >>> the meaning of which isn’t entirely clear to me. The only thing that I
> can
> >>> think of is that the package names could change, as in standard commons
> >>> practice, between major version releases. Am I interpreting that
> correctly?
> >>> Any issues with just moving up in version?
> >>>
> >>> Cheers,
> >>> -Rob
> >>
> >>
> >>
> >>
> >> --
> >> E-Mail: [hidden email] | [hidden email]
> >> Java Persistence with Hibernate, Second Edition
> >> <https://www.amazon.com/gp/product/1617290459/ref=as_li_
> tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&
> linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>
> >>
> >> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=
> 1617290459>
> >> JUnit in Action, Second Edition
> >> <https://www.amazon.com/gp/product/1935182021/ref=as_li_
> tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&
> linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22
> >
> >>
> >> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=
> 1935182021>
> >> Spring Batch in Action
> >> <https://www.amazon.com/gp/product/1935182951/ref=as_li_
> tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&
> linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%
> 7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
> >> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=
> 1935182951>
> >> Blog: http://garygregory.wordpress.com
> >> Home: http://garygregory.com/
> >> Tweet! http://twitter.com/GaryGregory
> >>
> >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [Text] Any reason to not upgrade to lang 3.5

Bruno P. Kinoshita-3
In reply to this post by Rob Tompkins
Yesterday I had a look while fixing Checkstyle and PMD issues, and noticed the StringUtils in HumanNameParser.

+ to remove and use a simple if null or empty string.

Cheers
Bruno


>________________________________
> From: Rob Tompkins <[hidden email]>
>To: Commons Developers List <[hidden email]>; Bruno P. Kinoshita <[hidden email]>
>Sent: Wednesday, 9 November 2016 3:41 AM
>Subject: Re: [Text] Any reason to not upgrade to lang 3.5
>
>
>
>> On Nov 8, 2016, at 9:38 AM, Rob Tompkins <[hidden email]> wrote:
>>
>>
>>> On Nov 7, 2016, at 10:23 PM, Bruno P. Kinoshita <[hidden email]> wrote:
>>>
>>> +1 to update away
>>>
>>> I think it could be a mistake while creating the initial project structure. Don't remember why there would be a dependency between [text] and [lang].
>>
>> Do you want to attempt a removal of the dependency on [lang]?
>
>It looks like the main dependency is based upon StringUtils. Any thoughts on how we tackle that class from [lang]? I would think that we might minimally pull over the code that causes our dependency on [lang], and maybe some of the more complex methods?
>
>
>-Rob
>
>>
>> -Rob
>>
>>>
>>>
>>>> ________________________________
>>>> From: Gary Gregory <[hidden email]>
>>>> To: Commons Developers List <[hidden email]>
>>>> Sent: Tuesday, 8 November 2016 3:53 PM
>>>> Subject: Re: [Text] Any reason to not upgrade to lang 3.5
>>>>
>>>>
>>>> Update away. I'm not sure why shading is in the picture though.
>>>>
>>>> Gary
>>>>
>>>>
>>>> On Mon, Nov 7, 2016 at 6:18 PM, Rob Tompkins <[hidden email]> wrote:
>>>>
>>>>> Hi,
>>>>>
>>>>> I was looking through the pom and notice that [lang] is a dependency of
>>>>> [text], and the pom references [lang, 3.4]. Does anyone have any problems
>>>>> with upgrading to 3.5? The only thing that seems at all concerning is the
>>>>> comment in the code stating:
>>>>>
>>>>>       <!-- if upgrading, be sure to check shaded jar relocations! -->
>>>>>
>>>>> the meaning of which isn’t entirely clear to me. The only thing that I can
>>>>> think of is that the package names could change, as in standard commons
>>>>> practice, between major version releases. Am I interpreting that correctly?
>>>>> Any issues with just moving up in version?
>>>>>
>>>>> Cheers,
>>>>> -Rob
>>>>
>>>>
>>>>
>>>>
>>>> --
>>>> E-Mail: [hidden email] | [hidden email]
>>>> Java Persistence with Hibernate, Second Edition
>>>> <https://www.amazon.com/gp/product/1617290459/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1617290459&linkCode=as2&tag=garygregory-20&linkId=cadb800f39946ec62ea2b1af9fe6a2b8>
>>>>
>>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1617290459>
>>>> JUnit in Action, Second Edition
>>>> <https://www.amazon.com/gp/product/1935182021/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182021&linkCode=as2&tag=garygregory-20&linkId=31ecd1f6b6d1eaf8886ac902a24de418%22>
>>>>
>>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182021>
>>>> Spring Batch in Action
>>>> <https://www.amazon.com/gp/product/1935182951/ref=as_li_tl?ie=UTF8&camp=1789&creative=9325&creativeASIN=1935182951&linkCode=%7B%7BlinkCode%7D%7D&tag=garygregory-20&linkId=%7B%7Blink_id%7D%7D%22%3ESpring+Batch+in+Action>
>>>> <http:////ir-na.amazon-adsystem.com/e/ir?t=garygregory-20&l=am2&o=1&a=1935182951>
>>>> Blog: http://garygregory.wordpress.com
>>>> Home: http://garygregory.com/
>>>> Tweet! http://twitter.com/GaryGregory
>>>>
>>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: [hidden email]
>>> For additional commands, e-mail: [hidden email]
>>>
>>
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]