[VFS] Webdav failure on Java 14

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[VFS] Webdav failure on Java 14

garydgregory
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] Webdav failure on Java 14

Bernd Eckenfels
Hi Gary, just to state the obvious, it seems to be 15-ea which fails, not 14.

 have you been able to reproduce it locally (currently have no good access to a machine to reproduce it), yet?

Gruss
Bernd
--
http://bernd.eckenfels.net
________________________________
Von: Gary Gregory <[hidden email]>
Gesendet: Donnerstag, Dezember 19, 2019 3:16 PM
An: Commons Developers List
Betreff: [VFS] Webdav failure on Java 14

Looking for help to resolve this failure:

https://travis-ci.org/apache/commons-vfs/jobs/627014664?utm_medium=notification&utm_source=email


Thank you,
Gary
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] Webdav failure on Java 14

Julian Reschke
In reply to this post by garydgregory
On 19.12.2019 15:16, Gary Gregory wrote:
> Looking for help to resolve this failure:
>
> https://travis-ci.org/apache/commons-vfs/jobs/627014664?utm_medium=notification&utm_source=email

This seems to use Jackrabbit 1, which won't work with Java 14.

Best regards, Julian

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VFS] Webdav failure on Java 14

Bruno P. Kinoshita-3
In reply to this post by garydgregory
 No idea what's causing that issue. I reproduced it locally with Maven in the command line, but couldn't debug it due to an old Eclipse version.
In case it helps, when I run Webdav4ProviderTestCase locally, I get two test errors. When I run in the command line, I get a single one, exactly the same as in Travis.
The eclipse errors with stack trace and a screen shot: https://gist.github.com/kinow/601469e3b7ee614a392628966d53e829

Hope that helpsBruno



    On Friday, 20 December 2019, 3:16:17 am NZDT, Gary Gregory <[hidden email]> wrote:  
 
 Looking for help to resolve this failure:

https://travis-ci.org/apache/commons-vfs/jobs/627014664?utm_medium=notification&utm_source=email


Thank you,
Gary