[VFS] trunk build failing in travis

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

[VFS] trunk build failing in travis

Otto Fowler
I have forked VFS and tried to build it in my personal travis, and it is
failing.

https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824

It also fails testing locally as well.
Is this expected?  I can’t get the the apache/commons-vfs travis site to
check if it is building there.


ottO
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Otto Fowler
It is also failed on github


On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
wrote:

I have forked VFS and tried to build it in my personal travis, and it is
failing.

https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824

It also fails testing locally as well.
Is this expected?  I can’t get the the apache/commons-vfs travis site to
check if it is building there.


ottO
Reply | Threaded
Open this post in threaded view
|

[VFS] commons-parent 43 breaks VFS build : (was) trunk build failing in travis

Otto Fowler
So,

It looks like upgrading the parent pom from #42 to #43 broke the build.
This can be seen
in the travis build history, and I have checked that mvn clean verify works
with 42 and fails with 43.



On February 15, 2018 at 12:07:45, Otto Fowler ([hidden email])
wrote:

It is also failed on github


On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
wrote:

I have forked VFS and tried to build it in my personal travis, and it is
failing.

https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824

It also fails testing locally as well.
Is this expected?  I can’t get the the apache/commons-vfs travis site to
check if it is building there.


ottO
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Bernd Eckenfels
In reply to this post by Otto Fowler
Hello Otto,

can confirm that on my local Windows builds the latest parent makes the package Goal fail (w/ a crashing jvm when starting surefire).

When reverting the parent surefire is not started and the build suceeds. Error Messages are however different from your Travis logs.

Setting the old surefire Version (and the new parent) works for me:

<commons.surefire.version>2.19.1</commons.surefire.version> <!—2.20.1 fails -->

Should we revert the parent Version or add the property (for now)?

Gruss
Bernd
--
http://bernd.eckenfels.net

Von: Otto Fowler
Gesendet: Donnerstag, 15. Februar 2018 18:07
An: Commons Developers List
Betreff: Re: [VFS] trunk build failing in travis

It is also failed on github


On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
wrote:

I have forked VFS and tried to build it in my personal travis, and it is
failing.

https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824

It also fails testing locally as well.
Is this expected?  I can’t get the the apache/commons-vfs travis site to
check if it is building there.


ottO

Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

garydgregory
On Thu, Feb 15, 2018 at 6:42 PM, Bernd Eckenfels <[hidden email]>
wrote:

> Hello Otto,
>
> can confirm that on my local Windows builds the latest parent makes the
> package Goal fail (w/ a crashing jvm when starting surefire).
>
> When reverting the parent surefire is not started and the build suceeds.
> Error Messages are however different from your Travis logs.
>
> Setting the old surefire Version (and the new parent) works for me:
>
> <commons.surefire.version>2.19.1</commons.surefire.version> <!—2.20.1
> fails -->
>
> Should we revert the parent Version or add the property (for now)?
>

-1 to revert the parent
+1 to adjusting the VFS POM

Gary


>
> Gruss
> Bernd
> --
> http://bernd.eckenfels.net
>
> Von: Otto Fowler
> Gesendet: Donnerstag, 15. Februar 2018 18:07
> An: Commons Developers List
> Betreff: Re: [VFS] trunk build failing in travis
>
> It is also failed on github
>
>
> On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
> wrote:
>
> I have forked VFS and tried to build it in my personal travis, and it is
> failing.
>
> https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824
>
> It also fails testing locally as well.
> Is this expected?  I can’t get the the apache/commons-vfs travis site to
> check if it is building there.
>
>
> ottO
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Bernd Eckenfels
Hello,

I have accidentially pushed the changes in SVN on the 2.2 branch. Is there a way to revert the last two commits, maybe with tag copy or something? I am not too familiar. Can you help me to undo this?

I would then commit them on trunk, again.

You said „adjust pom“, did you mean the Version downgrade?

Gruss
Bernd
--
http://bernd.eckenfels.net

Von: Gary Gregory
Gesendet: Freitag, 16. Februar 2018 02:57
An: Commons Developers List
Betreff: Re: [VFS] trunk build failing in travis

On Thu, Feb 15, 2018 at 6:42 PM, Bernd Eckenfels <[hidden email]>
wrote:

> Hello Otto,
>
> can confirm that on my local Windows builds the latest parent makes the
> package Goal fail (w/ a crashing jvm when starting surefire).
>
> When reverting the parent surefire is not started and the build suceeds.
> Error Messages are however different from your Travis logs.
>
> Setting the old surefire Version (and the new parent) works for me:
>
> <commons.surefire.version>2.19.1</commons.surefire.version> <!—2.20.1
> fails -->
>
> Should we revert the parent Version or add the property (for now)?
>

-1 to revert the parent
+1 to adjusting the VFS POM

Gary


>
> Gruss
> Bernd
> --
> http://bernd.eckenfels.net
>
> Von: Otto Fowler
> Gesendet: Donnerstag, 15. Februar 2018 18:07
> An: Commons Developers List
> Betreff: Re: [VFS] trunk build failing in travis
>
> It is also failed on github
>
>
> On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
> wrote:
>
> I have forked VFS and tried to build it in my personal travis, and it is
> failing.
>
> https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824
>
> It also fails testing locally as well.
> Is this expected?  I can’t get the the apache/commons-vfs travis site to
> check if it is building there.
>
>
> ottO
>
>

Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Bernd Eckenfels
In reply to this post by Bernd Eckenfels
Hello,

I digged a bit deeper, and on my Windows System surefire 1.20.1 is failing because of this new „ping“ behavior:

http://maven.apache.org/surefire/maven-surefire-plugin/examples/shutdown.html

Looks like a bug that surefire is not falling back when wmic is not found (or better search for it), however after I fixed my PATH to include c:\Windows\System32\wbem the new surefire also works. -> the downgrade is wrong.

Since I commited on the wrong tag again, can somebody rename it and copy the Revision 1811361 from rc2 again?


Gruss
Bernd

Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Otto Fowler
Any ideas on this?

Even with the old pom, I’m seeing failures I cannot explain.  I have a
couple of PR’s I think I’d like to submit, but building seems a bit of mess.



On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email])
wrote:

Hello,

I digged a bit deeper, and on my Windows System surefire 1.20.1 is failing
because of this new „ping“ behavior:

http://maven.apache.org/surefire/maven-surefire-plugin/examples/shutdown.html

Looks like a bug that surefire is not falling back when wmic is not found
(or better search for it), however after I fixed my PATH to include
c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
wrong.

Since I commited on the wrong tag again, can somebody rename it and copy
the Revision 1811361 from rc2 again?


Gruss
Bernd
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

garydgregory
Make sure you have the latest from trunk. The build works for me locally
using 'mvn clean package' using Oracle Java 7 and 8:

Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
2017-10-18T01:58:13-06:00)
Maven home: C:\Java\apache-maven-3.5.2\bin\..
Java version: 1.8.0_162, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_162\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

and

Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
2017-10-18T01:58:13-06:00)
Maven home: C:\Java\apache-maven-3.5.2\bin\..
Java version: 1.7.0_80, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.7.0_80\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"

Gary


On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]>
wrote:

> Any ideas on this?
>
> Even with the old pom, I’m seeing failures I cannot explain.  I have a
> couple of PR’s I think I’d like to submit, but building seems a bit of
> mess.
>
>
>
> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email])
> wrote:
>
> Hello,
>
> I digged a bit deeper, and on my Windows System surefire 1.20.1 is failing
> because of this new „ping“ behavior:
>
> http://maven.apache.org/surefire/maven-surefire-
> plugin/examples/shutdown.html
>
> Looks like a bug that surefire is not falling back when wmic is not found
> (or better search for it), however after I fixed my PATH to include
> c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
> wrong.
>
> Since I commited on the wrong tag again, can somebody rename it and copy
> the Revision 1811361 from rc2 again?
>
>
> Gruss
> Bernd
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

garydgregory
Note that the Travis build is now green:
https://travis-ci.org/apache/commons-vfs/

Gary

On Fri, Feb 16, 2018 at 11:34 AM, Gary Gregory <[hidden email]>
wrote:

> Make sure you have the latest from trunk. The build works for me locally
> using 'mvn clean package' using Oracle Java 7 and 8:
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.8.0_162\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"
>
> and
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.7.0_80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
>
> Gary
>
>
> On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]>
> wrote:
>
>> Any ideas on this?
>>
>> Even with the old pom, I’m seeing failures I cannot explain.  I have a
>> couple of PR’s I think I’d like to submit, but building seems a bit of
>> mess.
>>
>>
>>
>> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email]
>> )
>> wrote:
>>
>> Hello,
>>
>> I digged a bit deeper, and on my Windows System surefire 1.20.1 is failing
>> because of this new „ping“ behavior:
>>
>> http://maven.apache.org/surefire/maven-surefire-plugin/
>> examples/shutdown.html
>>
>> Looks like a bug that surefire is not falling back when wmic is not found
>> (or better search for it), however after I fixed my PATH to include
>> c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
>> wrong.
>>
>> Since I commited on the wrong tag again, can somebody rename it and copy
>> the Revision 1811361 from rc2 again?
>>
>>
>> Gruss
>> Bernd
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Otto Fowler
That did the trick.  Thank you. I’m going to submit pr’s for VFS-398 and
VFS-614 soon.



On February 16, 2018 at 13:54:53, Gary Gregory ([hidden email])
wrote:

Note that the Travis build is now green:
https://travis-ci.org/apache/commons-vfs/

Gary

On Fri, Feb 16, 2018 at 11:34 AM, Gary Gregory <[hidden email]>
wrote:

> Make sure you have the latest from trunk. The build works for me locally
> using 'mvn clean package' using Oracle Java 7 and 8:
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.8.0_162\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"
>
> and
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.7.0_80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
>
> Gary
>
>
> On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]>
> wrote:
>
>> Any ideas on this?
>>
>> Even with the old pom, I’m seeing failures I cannot explain. I have a
>> couple of PR’s I think I’d like to submit, but building seems a bit of
>> mess.
>>
>>
>>
>> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email]
>> )
>> wrote:
>>
>> Hello,
>>
>> I digged a bit deeper, and on my Windows System surefire 1.20.1 is
failing
>> because of this new „ping“ behavior:
>>
>> http://maven.apache.org/surefire/maven-surefire-plugin/
>> examples/shutdown.html
>>
>> Looks like a bug that surefire is not falling back when wmic is not
found
>> (or better search for it), however after I fixed my PATH to include
>> c:\Windows\System32\wbem the new surefire also works. -> the downgrade
is

>> wrong.
>>
>> Since I commited on the wrong tag again, can somebody rename it and copy
>> the Revision 1811361 from rc2 again?
>>
>>
>> Gruss
>> Bernd
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Bernd Eckenfels
There is something fishy going on with the way testdatan and Testsuites are generated. It results in a lot of NPEs because the setConfig is not properly called. One of the causes seem to be on the fly compilation by concurrent IDEs, sometimes it is caused by not found test data (which makes the setUp fail but not be logged cleanly). It’s a bit annoying, sorry. I suspect that maven clean in the toplevel project cures some of them — sometimes.

Gruss
Bernd
--
http://bernd.eckenfels.net
________________________________
From: Otto Fowler <[hidden email]>
Sent: Friday, February 16, 2018 8:18:44 PM
To: Gary Gregory; Commons Developers List
Cc: Bernd Eckenfels
Subject: Re: [VFS] trunk build failing in travis

That did the trick.  Thank you. I’m going to submit pr’s for VFS-398 and VFS-614 soon.




On February 16, 2018 at 13:54:53, Gary Gregory ([hidden email]<mailto:[hidden email]>) wrote:

Note that the Travis build is now green:
https://travis-ci.org/apache/commons-vfs/

Gary

On Fri, Feb 16, 2018 at 11:34 AM, Gary Gregory <[hidden email]<mailto:[hidden email]>>
wrote:

> Make sure you have the latest from trunk. The build works for me locally
> using 'mvn clean package' using Oracle Java 7 and 8:
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.8.0_162\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"
>
> and
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.7.0_80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
>
> Gary
>
>
> On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]<mailto:[hidden email]>>
> wrote:
>
>> Any ideas on this?
>>
>> Even with the old pom, I’m seeing failures I cannot explain. I have a
>> couple of PR’s I think I’d like to submit, but building seems a bit of
>> mess.
>>
>>
>>
>> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email]<mailto:[hidden email]>
>> )
>> wrote:
>>
>> Hello,
>>
>> I digged a bit deeper, and on my Windows System surefire 1.20.1 is failing
>> because of this new „ping“ behavior:
>>
>> http://maven.apache.org/surefire/maven-surefire-plugin/
>> examples/shutdown.html
>>
>> Looks like a bug that surefire is not falling back when wmic is not found
>> (or better search for it), however after I fixed my PATH to include
>> c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
>> wrong.
>>
>> Since I commited on the wrong tag again, can somebody rename it and copy
>> the Revision 1811361 from rc2 again?
>>
>>
>> Gruss
>> Bernd
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Otto Fowler
https://travis-ci.org/ottobackwards/commons-vfs/builds/342485419

So this builds locally with mvn clean package, but fails in travis, anyone
familiar?


On February 16, 2018 at 14:23:31, Bernd Eckenfels ([hidden email])
wrote:

There is something fishy going on with the way testdatan and Testsuites are
generated. It results in a lot of NPEs because the setConfig is not
properly called. One of the causes seem to be on the fly compilation by
concurrent IDEs, sometimes it is caused by not found test data (which makes
the setUp fail but not be logged cleanly). It’s a bit annoying, sorry. I
suspect that maven clean in the toplevel project cures some of them —
sometimes.

Gruss
Bernd
--
http://bernd.eckenfels.net
------------------------------
*From:* Otto Fowler <[hidden email]>
*Sent:* Friday, February 16, 2018 8:18:44 PM
*To:* Gary Gregory; Commons Developers List
*Cc:* Bernd Eckenfels
*Subject:* Re: [VFS] trunk build failing in travis

That did the trick.  Thank you. I’m going to submit pr’s for VFS-398 and
VFS-614 soon.



On February 16, 2018 at 13:54:53, Gary Gregory ([hidden email])
wrote:

Note that the Travis build is now green:
https://travis-ci.org/apache/commons-vfs/

Gary

On Fri, Feb 16, 2018 at 11:34 AM, Gary Gregory <[hidden email]>
wrote:

> Make sure you have the latest from trunk. The build works for me locally
> using 'mvn clean package' using Oracle Java 7 and 8:
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.8.0_162\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"
>
> and
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.7.0_80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
>
> Gary
>
>
> On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]>
> wrote:
>
>> Any ideas on this?
>>
>> Even with the old pom, I’m seeing failures I cannot explain. I have a
>> couple of PR’s I think I’d like to submit, but building seems a bit of
>> mess.
>>
>>
>>
>> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email]
>> )
>> wrote:
>>
>> Hello,
>>
>> I digged a bit deeper, and on my Windows System surefire 1.20.1 is
failing

>> because of this new „ping“ behavior:
>>
>> http://maven.apache.org/surefire/maven-surefire-plugin/
>> examples/shutdown.html
>>
>> Looks like a bug that surefire is not falling back when wmic is not found
>> (or better search for it), however after I fixed my PATH to include
>> c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
>> wrong.
>>
>> Since I commited on the wrong tag again, can somebody rename it and copy
>> the Revision 1811361 from rc2 again?
>>
>>
>> Gruss
>> Bernd
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Otto Fowler
And only fails java8, which is what i’m using local


On February 16, 2018 at 14:26:10, Otto Fowler ([hidden email])
wrote:

https://travis-ci.org/ottobackwards/commons-vfs/builds/342485419

So this builds locally with mvn clean package, but fails in travis, anyone
familiar?


On February 16, 2018 at 14:23:31, Bernd Eckenfels ([hidden email])
wrote:

There is something fishy going on with the way testdatan and Testsuites are
generated. It results in a lot of NPEs because the setConfig is not
properly called. One of the causes seem to be on the fly compilation by
concurrent IDEs, sometimes it is caused by not found test data (which makes
the setUp fail but not be logged cleanly). It’s a bit annoying, sorry. I
suspect that maven clean in the toplevel project cures some of them —
sometimes.

Gruss
Bernd
--
http://bernd.eckenfels.net
------------------------------
*From:* Otto Fowler <[hidden email]>
*Sent:* Friday, February 16, 2018 8:18:44 PM
*To:* Gary Gregory; Commons Developers List
*Cc:* Bernd Eckenfels
*Subject:* Re: [VFS] trunk build failing in travis

That did the trick.  Thank you. I’m going to submit pr’s for VFS-398 and
VFS-614 soon.



On February 16, 2018 at 13:54:53, Gary Gregory ([hidden email])
wrote:

Note that the Travis build is now green:
https://travis-ci.org/apache/commons-vfs/

Gary

On Fri, Feb 16, 2018 at 11:34 AM, Gary Gregory <[hidden email]>
wrote:

> Make sure you have the latest from trunk. The build works for me locally
> using 'mvn clean package' using Oracle Java 7 and 8:
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.8.0_162, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.8.0_162\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"
>
> and
>
> Apache Maven 3.5.2 (138edd61fd100ec658bfa2d307c43b76940a5d7d;
> 2017-10-18T01:58:13-06:00)
> Maven home: C:\Java\apache-maven-3.5.2\bin\..
> Java version: 1.7.0_80, vendor: Oracle Corporation
> Java home: C:\Program Files\Java\jdk1.7.0_80\jre
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
>
> Gary
>
>
> On Fri, Feb 16, 2018 at 11:04 AM, Otto Fowler <[hidden email]>
> wrote:
>
>> Any ideas on this?
>>
>> Even with the old pom, I’m seeing failures I cannot explain. I have a
>> couple of PR’s I think I’d like to submit, but building seems a bit of
>> mess.
>>
>>
>>
>> On February 15, 2018 at 22:03:06, Bernd Eckenfels ([hidden email]
>> )
>> wrote:
>>
>> Hello,
>>
>> I digged a bit deeper, and on my Windows System surefire 1.20.1 is
failing

>> because of this new „ping“ behavior:
>>
>> http://maven.apache.org/surefire/maven-surefire-plugin/
>> examples/shutdown.html
>>
>> Looks like a bug that surefire is not falling back when wmic is not found
>> (or better search for it), however after I fixed my PATH to include
>> c:\Windows\System32\wbem the new surefire also works. -> the downgrade is
>> wrong.
>>
>> Since I commited on the wrong tag again, can somebody rename it and copy
>> the Revision 1811361 from rc2 again?
>>
>>
>> Gruss
>> Bernd
>>
>
>
Reply | Threaded
Open this post in threaded view
|

Re: [VFS] trunk build failing in travis

Bernd Eckenfels
In reply to this post by Bernd Eckenfels
Hello,

for my accidential commit I opeend a Infra Task (since I canot rename the branches)

https://issues.apache.org/jira/browse/INFRA-16054

Gruss
Bernd
--
http://bernd.eckenfels.net

Von: Bernd Eckenfels
Gesendet: Freitag, 16. Februar 2018 03:08
An: Commons Developers List
Betreff: Re: [VFS] trunk build failing in travis

Hello,

I have accidentially pushed the changes in SVN on the 2.2 branch. Is there a way to revert the last two commits, maybe with tag copy or something? I am not too familiar. Can you help me to undo this?

I would then commit them on trunk, again.

You said „adjust pom“, did you mean the Version downgrade?

Gruss
Bernd
--
http://bernd.eckenfels.net

Von: Gary Gregory
Gesendet: Freitag, 16. Februar 2018 02:57
An: Commons Developers List
Betreff: Re: [VFS] trunk build failing in travis

On Thu, Feb 15, 2018 at 6:42 PM, Bernd Eckenfels <[hidden email]>
wrote:

> Hello Otto,
>
> can confirm that on my local Windows builds the latest parent makes the
> package Goal fail (w/ a crashing jvm when starting surefire).
>
> When reverting the parent surefire is not started and the build suceeds.
> Error Messages are however different from your Travis logs.
>
> Setting the old surefire Version (and the new parent) works for me:
>
> <commons.surefire.version>2.19.1</commons.surefire.version> <!—2.20.1
> fails -->
>
> Should we revert the parent Version or add the property (for now)?
>

-1 to revert the parent
+1 to adjusting the VFS POM

Gary


>
> Gruss
> Bernd
> --
> http://bernd.eckenfels.net
>
> Von: Otto Fowler
> Gesendet: Donnerstag, 15. Februar 2018 18:07
> An: Commons Developers List
> Betreff: Re: [VFS] trunk build failing in travis
>
> It is also failed on github
>
>
> On February 15, 2018 at 11:59:22, Otto Fowler ([hidden email])
> wrote:
>
> I have forked VFS and tried to build it in my personal travis, and it is
> failing.
>
> https://travis-ci.org/ottobackwards/commons-vfs/builds/341963824
>
> It also fails testing locally as well.
> Is this expected?  I can’t get the the apache/commons-vfs travis site to
> check if it is building there.
>
>
> ottO
>
>