[VOTE] Release Apache Commons Validator 1.4.1 based on RC1

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Benedikt Ritter-4
Hello,

We have received some requests to release the fixes we habe implemented in
Commons Validator since 1.4 was released, so I would like to release
Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
7587) Maven artifacts are here:
https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
Details of changes since 1.4 are in the release notes:
https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
Note that the build doesn't work with JDK 1.9 EA, since source and target
option 1.4 have been removed in JDK 1.9. The tag is here:
http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
(svn revision 1647978) Site: no site - I'm currently having trouble to
login to people.apache.org, so I was unable to upload the site. Please
build the site yourself using mvn clean site. Clirr Report (compared to
1.1): see above RAT Report: see above KEYS:
https://www.apache.org/dist/commons/KEYS Please review the release
candidate and vote. This vote will close no sooner that 72 hours from now,
i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
because... Thanks! Benedikt


--
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Benedikt Ritter-4
Hi again,

2014-12-26 16:00 GMT+01:00 Benedikt Ritter <[hidden email]>:

>
> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site.
>

I was able to fix this problem.

Site:
   http://people.apache.org/~britter/validator-1.4.1-RC1/

Clirr Report (compared to 1.4):
  http://people.apache.org/~britter/validator-1.4.1-RC1/clirr-report.html

RAT Report:
   http://people.apache.org/~britter/validator-1.4.1-RC1/rat-report.html


> Clirr Report (compared to 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt
>
>
> --
> http://people.apache.org/~britter/
> http://www.systemoutprintln.de/
> http://twitter.com/BenediktRitter
> http://github.com/britter
>


--
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Adrian Crum-3
In reply to this post by Benedikt Ritter-4
It would be nice if the maintenance release included this fix:

https://issues.apache.org/jira/browse/VALIDATOR-307

I was planning on working on it this weekend.

Adrian Crum
Sandglass Software
www.sandglass-software.com

On 12/26/2014 3:00 PM, Benedikt Ritter wrote:

> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site. Clirr Report (compared to
> 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

garydgregory
On Fri, Dec 26, 2014 at 10:30 AM, Adrian Crum <
[hidden email]> wrote:

> It would be nice if the maintenance release included this fix:
>
> https://issues.apache.org/jira/browse/VALIDATOR-307
>
> I was planning on working on it this weekend.
>

RERO!

Gary


>
> Adrian Crum
> Sandglass Software
> www.sandglass-software.com
>
>
> On 12/26/2014 3:00 PM, Benedikt Ritter wrote:
>
>> Hello,
>>
>> We have received some requests to release the fixes we habe implemented in
>> Commons Validator since 1.4 was released, so I would like to release
>> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
>> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
>> 7587) Maven artifacts are here:
>> https://repository.apache.org/content/repositories/
>> orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
>> Details of changes since 1.4 are in the release notes:
>> https://dist.apache.org/repos/dist/dev/commons/validator/
>> RELEASE-NOTES.txt
>> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
>> Note that the build doesn't work with JDK 1.9 EA, since source and target
>> option 1.4 have been removed in JDK 1.9. The tag is here:
>> http://svn.apache.org/repos/asf/commons/proper/validator/
>> tags/VALIDATOR_1_4_1_RC1/
>> (svn revision 1647978) Site: no site - I'm currently having trouble to
>> login to people.apache.org, so I was unable to upload the site. Please
>> build the site yourself using mvn clean site. Clirr Report (compared to
>> 1.1): see above RAT Report: see above KEYS:
>> https://www.apache.org/dist/commons/KEYS Please review the release
>> candidate and vote. This vote will close no sooner that 72 hours from now,
>> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
>> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
>> because... Thanks! Benedikt
>>
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Benedikt Ritter-4
In reply to this post by Adrian Crum-3
2014-12-26 16:30 GMT+01:00 Adrian Crum <[hidden email]>:
>
> It would be nice if the maintenance release included this fix:
>
> https://issues.apache.org/jira/browse/VALIDATOR-307
>
> I was planning on working on it this weekend.
>

It is no problem to release 1.4.2 after you have implemented that fix :-)


>
> Adrian Crum
> Sandglass Software
> www.sandglass-software.com
>
>
> On 12/26/2014 3:00 PM, Benedikt Ritter wrote:
>
>> Hello,
>>
>> We have received some requests to release the fixes we habe implemented in
>> Commons Validator since 1.4 was released, so I would like to release
>> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
>> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
>> 7587) Maven artifacts are here:
>> https://repository.apache.org/content/repositories/
>> orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
>> Details of changes since 1.4 are in the release notes:
>> https://dist.apache.org/repos/dist/dev/commons/validator/
>> RELEASE-NOTES.txt
>> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
>> Note that the build doesn't work with JDK 1.9 EA, since source and target
>> option 1.4 have been removed in JDK 1.9. The tag is here:
>> http://svn.apache.org/repos/asf/commons/proper/validator/
>> tags/VALIDATOR_1_4_1_RC1/
>> (svn revision 1647978) Site: no site - I'm currently having trouble to
>> login to people.apache.org, so I was unable to upload the site. Please
>> build the site yourself using mvn clean site. Clirr Report (compared to
>> 1.1): see above RAT Report: see above KEYS:
>> https://www.apache.org/dist/commons/KEYS Please review the release
>> candidate and vote. This vote will close no sooner that 72 hours from now,
>> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
>> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
>> because... Thanks! Benedikt
>>
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

--
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Bruno P. Kinoshita
In reply to this post by Benedikt Ritter-4
Hello Benedikt!

Build looks good, all tests passed, no new issues in the project reports.

kinow@chuva:/tmp/VALIDATOR_1_4_1_RC1$ mvn clean site -e -X
Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T15:37:52-03:00)
Maven home: /opt/apache-maven-3.2.1
Java version: 1.8.0_05, vendor: Oracle Corporation
Java home: /opt/jdk1.8.0_05/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "3.13.0-36-generic", arch: "i386", family: "unix"

In the changes reports the next release description is 'Maintenance Release.', but previous releases included a major.minor version prefix - so maybe it could be '1.4 Maintenance Release.' just to keep the style used.

> [X] +1 Release these artifacts


Not binding.

Thanks!
Bruno


>________________________________
> From: Benedikt Ritter <[hidden email]>
>To: Commons Developers List <[hidden email]>
>Sent: Friday, December 26, 2014 1:00 PM
>Subject: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1
>
>
>Hello,
>
>We have received some requests to release the fixes we habe implemented in
>Commons Validator since 1.4 was released, so I would like to release
>Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
>https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
>7587) Maven artifacts are here:
>https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
>Details of changes since 1.4 are in the release notes:
>https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
>I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
>Note that the build doesn't work with JDK 1.9 EA, since source and target
>option 1.4 have been removed in JDK 1.9. The tag is here:
>http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
>(svn revision 1647978) Site: no site - I'm currently having trouble to
>login to people.apache.org, so I was unable to upload the site. Please
>build the site yourself using mvn clean site. Clirr Report (compared to
>1.1): see above RAT Report: see above KEYS:
>https://www.apache.org/dist/commons/KEYS Please review the release
>candidate and vote. This vote will close no sooner that 72 hours from now,
>i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
>but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
>because... Thanks! Benedikt
>
>
>--
>http://people.apache.org/~britter/
>http://www.systemoutprintln.de/
>http://twitter.com/BenediktRitter
>http://github.com/britter
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Phil Steitz
In reply to this post by Benedikt Ritter-4
+1
Tested build on OSX JDK 1.7.
Sigs and hashes are good.
Release notes and contents look good.

Non-blocking issues to fix in RC2 if there is one:
* Findbugs, Checkstyle and PMD all report errors, which should be
suppressed or fixed. (The Findbugs sync complaint looks legit;
others appear to be nits and should be suppressed).
* The jar manifest says built-by "bene" - this should be your ASF id.

Observations:
* The .js file looks uniformly deprecated.  Probably not good to
drop it in a maintenance release; but we should make sure to drop it
in the next major release.
* The README.md and STATUS.html files in the tag are not included in
either the source or binary distributions.  Both are out of date and
should probably be dropped from svn.

Phil

On 12/26/14 8:00 AM, Benedikt Ritter wrote:

> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site. Clirr Report (compared to
> 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Luc Maisonobe-2
In reply to this post by Benedikt Ritter-4
Le 26/12/2014 16:00, Benedikt Ritter a écrit :

> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site. Clirr Report (compared to
> 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt

+1.

I found lots of differences between the source artifacts and the tag,
but all were false positive due to date formatting in subversion (and
even RCS!) keywords. This is not a problem, just an annoyance while
checking the release.

There was an encoding problem when creating RELEASE-NOTES.txt from
changes.xml as some contributor names got mangled. The names appear to
have proper UTF-8 encoding in the xml file but were replaced by an ASCII
question mark (0x3F) in the text file (not even the unicode replacement
character 0xFFFD). This can be fixed by adding the following property in
pom.xml:

  <commons.encoding>UTF-8</commons.encoding>

and generating the announcement again. You should consider it if you
roll another RC.

best regards,
Luc

>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Benedikt Ritter-4
In reply to this post by Benedikt Ritter-4
My +1 for this release. I will take care of the problems which have been
identified so far after the release.

2014-12-26 16:00 GMT+01:00 Benedikt Ritter <[hidden email]>:

>
> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site. Clirr Report (compared to
> 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt
>
>
> --
> http://people.apache.org/~britter/
> http://www.systemoutprintln.de/
> http://twitter.com/BenediktRitter
> http://github.com/britter
>


--
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

garydgregory
In reply to this post by Bruno P. Kinoshita
- The Jira report is empty, a bummer but not a blocker.
- A lot of the "Useless parentheses." reports in PMD are valid, this is
Java, not C ;-) Should be cleaned up IMO. Not a blocker.
- Clirr is clean, good!
- RAT is clean, good!
- FindBugs reports 2 interesting issues, IDK if those were present in the
previous release.
- Code coverage is a dismal 40% in org.apache.commons.validator.util

Stioll, +1

with:

Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1;
2014-12-14T12:29:23-05:00)
Maven home: C:\Java\apache-maven-3.2.5
Java version: 1.8.0_25, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_25\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 7", version: "6.1", arch: "amd64", family: "dos"

Gary

On Fri, Dec 26, 2014 at 9:19 PM, Bruno P. Kinoshita <
[hidden email]> wrote:

> Hello Benedikt!
>
> Build looks good, all tests passed, no new issues in the project reports.
>
> kinow@chuva:/tmp/VALIDATOR_1_4_1_RC1$ mvn clean site -e -X
> Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9;
> 2014-02-14T15:37:52-03:00)
> Maven home: /opt/apache-maven-3.2.1
> Java version: 1.8.0_05, vendor: Oracle Corporation
> Java home: /opt/jdk1.8.0_05/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "3.13.0-36-generic", arch: "i386", family:
> "unix"
>
> In the changes reports the next release description is 'Maintenance
> Release.', but previous releases included a major.minor version prefix - so
> maybe it could be '1.4 Maintenance Release.' just to keep the style used.
>
> > [X] +1 Release these artifacts
>
>
> Not binding.
>
> Thanks!
> Bruno
>
>
> >________________________________
> > From: Benedikt Ritter <[hidden email]>
> >To: Commons Developers List <[hidden email]>
> >Sent: Friday, December 26, 2014 1:00 PM
> >Subject: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1
> >
> >
> >Hello,
> >
> >We have received some requests to release the fixes we habe implemented in
> >Commons Validator since 1.4 was released, so I would like to release
> >Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> >https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> >7587) Maven artifacts are here:
> >
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> >Details of changes since 1.4 are in the release notes:
> >
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> >I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> >Note that the build doesn't work with JDK 1.9 EA, since source and target
> >option 1.4 have been removed in JDK 1.9. The tag is here:
> >
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> >(svn revision 1647978) Site: no site - I'm currently having trouble to
> >login to people.apache.org, so I was unable to upload the site. Please
> >build the site yourself using mvn clean site. Clirr Report (compared to
> >1.1): see above RAT Report: see above KEYS:
> >https://www.apache.org/dist/commons/KEYS Please review the release
> >candidate and vote. This vote will close no sooner that 72 hours from now,
> >i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> >but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> >because... Thanks! Benedikt
> >
> >
> >--
> >http://people.apache.org/~britter/
> >http://www.systemoutprintln.de/
> >http://twitter.com/BenediktRitter
> >http://github.com/britter
> >
> >
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Jörg Schaible
In reply to this post by Benedikt Ritter-4
Benedikt Ritter wrote:

> Hello,
>
> We have received some requests to release the fixes we habe implemented in
> Commons Validator since 1.4 was released, so I would like to release
> Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> 7587) Maven artifacts are here:
>
https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> Details of changes since 1.4 are in the release notes:
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> Note that the build doesn't work with JDK 1.9 EA, since source and target
> option 1.4 have been removed in JDK 1.9. The tag is here:
>
http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> (svn revision 1647978) Site: no site - I'm currently having trouble to
> login to people.apache.org, so I was unable to upload the site. Please
> build the site yourself using mvn clean site. Clirr Report (compared to
> 1.1): see above RAT Report: see above KEYS:
> https://www.apache.org/dist/commons/KEYS Please review the release
> candidate and vote. This vote will close no sooner that 72 hours from now,
> i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> because... Thanks! Benedikt

-1

The release claims to be Java 1.4 compatible, but you cannot build it for
that JDK, because of commons-beanutils-1.9.x:

=================== %< ======================
$ mvn-3.0 clean package -P java-1.4  
[INFO] Scanning for projects...
[... snip ...]
[INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ commons-
validator ---
[INFO] Changes detected - recompiling the module!
[INFO] Compiling 59 source files to /home/joehni/tmp/download/commons-
validator-1.4.1-src/target/classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
access org.apache.commons.beanutils.PropertyUtils
bad class file: /home/joehni/.m2/repository/commons-beanutils/commons-
beanutils/1.9.2/commons-
beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
class file has wrong version 49.0, should be 48.0
[INFO] 1 error
[INFO] -------------------------------------------------------------
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 7.972s
[INFO] Finished at: Mon Dec 29 13:54:00 CET 2014
[INFO] Final Memory: 17M/35M
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-
plugin:3.2:compile (default-compile) on project commons-validator:
Compilation failure
[ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
access org.apache.commons.beanutils.PropertyUtils
[ERROR] bad class file: /home/joehni/.m2/repository/commons-
beanutils/commons-beanutils/1.9.2/commons-
beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
[ERROR] class file has wrong version 49.0, should be 48.0
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please
read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
=================== %< ======================

Even when you downgrade beanutils to 1.8.4, you cannot compile the tests:

=================== %< ======================
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
src/src/test/java/org/apache/commons/validator/routines/checkdigit/IBANCheckDigitTest.java:
[186,64] replace(char,char) in java.lang.String cannot be applied to
(java.lang.String,java.lang.String)
[INFO] 1 error
=================== %< ======================

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

Jörg Schaible
Jörg Schaible wrote:

[snip]

> -1
>
> The release claims to be Java 1.4 compatible, but you cannot build it for
> that JDK, because of commons-beanutils-1.9.x:
>

[snip]

Minor nit: The release notes do not mention the minimum JDK version at all.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

garydgregory
In reply to this post by Jörg Schaible
On Mon, Dec 29, 2014 at 8:02 AM, Jörg Schaible <[hidden email]>
wrote:

> Benedikt Ritter wrote:
>
> > Hello,
> >
> > We have received some requests to release the fixes we habe implemented
> in
> > Commons Validator since 1.4 was released, so I would like to release
> > Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> > https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
> > 7587) Maven artifacts are here:
> >
>
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> > Details of changes since 1.4 are in the release notes:
> >
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> > I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
> > Note that the build doesn't work with JDK 1.9 EA, since source and target
> > option 1.4 have been removed in JDK 1.9. The tag is here:
> >
>
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> > (svn revision 1647978) Site: no site - I'm currently having trouble to
> > login to people.apache.org, so I was unable to upload the site. Please
> > build the site yourself using mvn clean site. Clirr Report (compared to
> > 1.1): see above RAT Report: see above KEYS:
> > https://www.apache.org/dist/commons/KEYS Please review the release
> > candidate and vote. This vote will close no sooner that 72 hours from
> now,
> > i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
> > but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
> > because... Thanks! Benedikt
>
> -1
>

The simplest solution would be to up the platform requirement to Java 5,
right? The next question would be whether the release should still be
labeled 1.4.1 instead of 1.5.

Gary


>
> The release claims to be Java 1.4 compatible, but you cannot build it for
> that JDK, because of commons-beanutils-1.9.x:
>
> =================== %< ======================
> $ mvn-3.0 clean package -P java-1.4
> [INFO] Scanning for projects...
> [... snip ...]
> [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ commons-
> validator ---
> [INFO] Changes detected - recompiling the module!
> [INFO] Compiling 59 source files to /home/joehni/tmp/download/commons-
> validator-1.4.1-src/target/classes
> [INFO] -------------------------------------------------------------
> [ERROR] COMPILATION ERROR :
> [INFO] -------------------------------------------------------------
> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
> access org.apache.commons.beanutils.PropertyUtils
> bad class file: /home/joehni/.m2/repository/commons-beanutils/commons-
> beanutils/1.9.2/commons-
> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
> class file has wrong version 49.0, should be 48.0
> [INFO] 1 error
> [INFO] -------------------------------------------------------------
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 7.972s
> [INFO] Finished at: Mon Dec 29 13:54:00 CET 2014
> [INFO] Final Memory: 17M/35M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-
> plugin:3.2:compile (default-compile) on project commons-validator:
> Compilation failure
> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
> access org.apache.commons.beanutils.PropertyUtils
> [ERROR] bad class file: /home/joehni/.m2/repository/commons-
> beanutils/commons-beanutils/1.9.2/commons-
> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
> [ERROR] class file has wrong version 49.0, should be 48.0
> [ERROR] -> [Help 1]
> [ERROR]
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
> switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR]
> [ERROR] For more information about the errors and possible solutions,
> please
> read the following articles:
> [ERROR] [Help 1]
> http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
> =================== %< ======================
>
> Even when you downgrade beanutils to 1.8.4, you cannot compile the tests:
>
> =================== %< ======================
> [INFO] -------------------------------------------------------------
> [ERROR] COMPILATION ERROR :
> [INFO] -------------------------------------------------------------
> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
>
> src/src/test/java/org/apache/commons/validator/routines/checkdigit/IBANCheckDigitTest.java:
> [186,64] replace(char,char) in java.lang.String cannot be applied to
> (java.lang.String,java.lang.String)
> [INFO] 1 error
> =================== %< ======================
>
> - Jörg
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

sebb-2-2
On 29 December 2014 at 13:52, Gary Gregory <[hidden email]> wrote:

> On Mon, Dec 29, 2014 at 8:02 AM, Jörg Schaible <[hidden email]>
> wrote:
>
>> Benedikt Ritter wrote:
>>
>> > Hello,
>> >
>> > We have received some requests to release the fixes we habe implemented
>> in
>> > Commons Validator since 1.4 was released, so I would like to release
>> > Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
>> > https://dist.apache.org/repos/dist/dev/commons/validator/ (svn revision
>> > 7587) Maven artifacts are here:
>> >
>>
>> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
>> > Details of changes since 1.4 are in the release notes:
>> >
>> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
>> > I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven 3.2.5.
>> > Note that the build doesn't work with JDK 1.9 EA, since source and target
>> > option 1.4 have been removed in JDK 1.9. The tag is here:
>> >
>>
>> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
>> > (svn revision 1647978) Site: no site - I'm currently having trouble to
>> > login to people.apache.org, so I was unable to upload the site. Please
>> > build the site yourself using mvn clean site. Clirr Report (compared to
>> > 1.1): see above RAT Report: see above KEYS:
>> > https://www.apache.org/dist/commons/KEYS Please review the release
>> > candidate and vote. This vote will close no sooner that 72 hours from
>> now,
>> > i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0 OK,
>> > but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this release
>> > because... Thanks! Benedikt
>>
>> -1
>>
>
> The simplest solution would be to up the platform requirement to Java 5,
> right?

Not simple, because all the generics ought to be added.
This is not always an easy task.

> The next question would be whether the release should still be
> labeled 1.4.1 instead of 1.5.

Probably not, assuming that generics have been added.

> Gary
>
>
>>
>> The release claims to be Java 1.4 compatible, but you cannot build it for
>> that JDK, because of commons-beanutils-1.9.x:
>>
>> =================== %< ======================
>> $ mvn-3.0 clean package -P java-1.4
>> [INFO] Scanning for projects...
>> [... snip ...]
>> [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @ commons-
>> validator ---
>> [INFO] Changes detected - recompiling the module!
>> [INFO] Compiling 59 source files to /home/joehni/tmp/download/commons-
>> validator-1.4.1-src/target/classes
>> [INFO] -------------------------------------------------------------
>> [ERROR] COMPILATION ERROR :
>> [INFO] -------------------------------------------------------------
>> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
>> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
>> access org.apache.commons.beanutils.PropertyUtils
>> bad class file: /home/joehni/.m2/repository/commons-beanutils/commons-
>> beanutils/1.9.2/commons-
>> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
>> class file has wrong version 49.0, should be 48.0
>> [INFO] 1 error
>> [INFO] -------------------------------------------------------------
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 7.972s
>> [INFO] Finished at: Mon Dec 29 13:54:00 CET 2014
>> [INFO] Final Memory: 17M/35M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-
>> plugin:3.2:compile (default-compile) on project commons-validator:
>> Compilation failure
>> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
>> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
>> access org.apache.commons.beanutils.PropertyUtils
>> [ERROR] bad class file: /home/joehni/.m2/repository/commons-
>> beanutils/commons-beanutils/1.9.2/commons-
>> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
>> [ERROR] class file has wrong version 49.0, should be 48.0
>> [ERROR] -> [Help 1]
>> [ERROR]
>> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e
>> switch.
>> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
>> [ERROR]
>> [ERROR] For more information about the errors and possible solutions,
>> please
>> read the following articles:
>> [ERROR] [Help 1]
>> http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
>> =================== %< ======================
>>
>> Even when you downgrade beanutils to 1.8.4, you cannot compile the tests:
>>
>> =================== %< ======================
>> [INFO] -------------------------------------------------------------
>> [ERROR] COMPILATION ERROR :
>> [INFO] -------------------------------------------------------------
>> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
>>
>> src/src/test/java/org/apache/commons/validator/routines/checkdigit/IBANCheckDigitTest.java:
>> [186,64] replace(char,char) in java.lang.String cannot be applied to
>> (java.lang.String,java.lang.String)
>> [INFO] 1 error
>> =================== %< ======================
>>
>> - Jörg
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>
>
> --
> E-Mail: [hidden email] | [hidden email]
> Java Persistence with Hibernate, Second Edition
> <http://www.manning.com/bauer3/>
> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> Spring Batch in Action <http://www.manning.com/templier/>
> Blog: http://garygregory.wordpress.com
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Apache Commons Validator 1.4.1 based on RC1

garydgregory
On Mon, Dec 29, 2014 at 10:04 AM, sebb <[hidden email]> wrote:

> On 29 December 2014 at 13:52, Gary Gregory <[hidden email]> wrote:
> > On Mon, Dec 29, 2014 at 8:02 AM, Jörg Schaible <[hidden email]>
> > wrote:
> >
> >> Benedikt Ritter wrote:
> >>
> >> > Hello,
> >> >
> >> > We have received some requests to release the fixes we habe
> implemented
> >> in
> >> > Commons Validator since 1.4 was released, so I would like to release
> >> > Validator 1.4.1. Validator 1.4.1 RC1 is available for review here:
> >> > https://dist.apache.org/repos/dist/dev/commons/validator/ (svn
> revision
> >> > 7587) Maven artifacts are here:
> >> >
> >>
> >>
> https://repository.apache.org/content/repositories/orgapachecommons-1071/commons-validator/commons-validator/1.4.1/
> >> > Details of changes since 1.4 are in the release notes:
> >> >
> >>
> https://dist.apache.org/repos/dist/dev/commons/validator/RELEASE-NOTES.txt
> >> > I have tested this with JDK 1.6, 1.7, 1.8 and 1.9 EA using maven
> 3.2.5.
> >> > Note that the build doesn't work with JDK 1.9 EA, since source and
> target
> >> > option 1.4 have been removed in JDK 1.9. The tag is here:
> >> >
> >>
> >>
> http://svn.apache.org/repos/asf/commons/proper/validator/tags/VALIDATOR_1_4_1_RC1/
> >> > (svn revision 1647978) Site: no site - I'm currently having trouble to
> >> > login to people.apache.org, so I was unable to upload the site.
> Please
> >> > build the site yourself using mvn clean site. Clirr Report (compared
> to
> >> > 1.1): see above RAT Report: see above KEYS:
> >> > https://www.apache.org/dist/commons/KEYS Please review the release
> >> > candidate and vote. This vote will close no sooner that 72 hours from
> >> now,
> >> > i.e. after 2014/12/29 16:00 CET [ ] +1 Release these artifacts [ ] +0
> OK,
> >> > but... [ ] -0 OK, but really should fix... [ ] -1 I oppose this
> release
> >> > because... Thanks! Benedikt
> >>
> >> -1
> >>
> >
> > The simplest solution would be to up the platform requirement to Java 5,
> > right?
>
> Not simple, because all the generics ought to be added.
> This is not always an easy task.
>
> > The next question would be whether the release should still be
> > labeled 1.4.1 instead of 1.5.
>
> Probably not, assuming that generics have been added.
>

I tried 1.5 in Eclipse and there are generics warning but nothing seems too
bad, the usual set of collection warnings at first glance at least.

Gary


>
> > Gary
> >
> >
> >>
> >> The release claims to be Java 1.4 compatible, but you cannot build it
> for
> >> that JDK, because of commons-beanutils-1.9.x:
> >>
> >> =================== %< ======================
> >> $ mvn-3.0 clean package -P java-1.4
> >> [INFO] Scanning for projects...
> >> [... snip ...]
> >> [INFO] --- maven-compiler-plugin:3.2:compile (default-compile) @
> commons-
> >> validator ---
> >> [INFO] Changes detected - recompiling the module!
> >> [INFO] Compiling 59 source files to /home/joehni/tmp/download/commons-
> >> validator-1.4.1-src/target/classes
> >> [INFO] -------------------------------------------------------------
> >> [ERROR] COMPILATION ERROR :
> >> [INFO] -------------------------------------------------------------
> >> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
> >> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
> >> access org.apache.commons.beanutils.PropertyUtils
> >> bad class file: /home/joehni/.m2/repository/commons-beanutils/commons-
> >> beanutils/1.9.2/commons-
> >> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
> >> class file has wrong version 49.0, should be 48.0
> >> [INFO] 1 error
> >> [INFO] -------------------------------------------------------------
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] BUILD FAILURE
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] Total time: 7.972s
> >> [INFO] Finished at: Mon Dec 29 13:54:00 CET 2014
> >> [INFO] Final Memory: 17M/35M
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-
> >> plugin:3.2:compile (default-compile) on project commons-validator:
> >> Compilation failure
> >> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
> >> src/src/main/java/org/apache/commons/validator/Field.java:[31,-1] cannot
> >> access org.apache.commons.beanutils.PropertyUtils
> >> [ERROR] bad class file: /home/joehni/.m2/repository/commons-
> >> beanutils/commons-beanutils/1.9.2/commons-
> >> beanutils-1.9.2.jar(org/apache/commons/beanutils/PropertyUtils.class)
> >> [ERROR] class file has wrong version 49.0, should be 48.0
> >> [ERROR] -> [Help 1]
> >> [ERROR]
> >> [ERROR] To see the full stack trace of the errors, re-run Maven with
> the -e
> >> switch.
> >> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> >> [ERROR]
> >> [ERROR] For more information about the errors and possible solutions,
> >> please
> >> read the following articles:
> >> [ERROR] [Help 1]
> >> http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
> >> =================== %< ======================
> >>
> >> Even when you downgrade beanutils to 1.8.4, you cannot compile the
> tests:
> >>
> >> =================== %< ======================
> >> [INFO] -------------------------------------------------------------
> >> [ERROR] COMPILATION ERROR :
> >> [INFO] -------------------------------------------------------------
> >> [ERROR] /home/joehni/tmp/download/commons-validator-1.4.1-
> >>
> >>
> src/src/test/java/org/apache/commons/validator/routines/checkdigit/IBANCheckDigitTest.java:
> >> [186,64] replace(char,char) in java.lang.String cannot be applied to
> >> (java.lang.String,java.lang.String)
> >> [INFO] 1 error
> >> =================== %< ======================
> >>
> >> - Jörg
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: [hidden email]
> >> For additional commands, e-mail: [hidden email]
> >>
> >>
> >
> >
> > --
> > E-Mail: [hidden email] | [hidden email]
> > Java Persistence with Hibernate, Second Edition
> > <http://www.manning.com/bauer3/>
> > JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> > Spring Batch in Action <http://www.manning.com/templier/>
> > Blog: http://garygregory.wordpress.com
> > Home: http://garygregory.com/
> > Tweet! http://twitter.com/GaryGregory
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory