[VOTE] Release Commons Collections 4.1 Based on RC1

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

[VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
Hi all,

we have accumulated enough changes since the last 4.0 release as well as
we need to provide a fix for the known remote code exploit via java
de-serialization. Therefore, I would like to start a vote to release
Commons Collections 4.1 based on RC1.

Note:

The fix for the security related issue results in Clirr errors as unsafe
classes in the functor package do not implement the Serializable
interface anymore. This is mentioned in the release notes.


Collections 4.1 RC1 is available for review here:
    https://dist.apache.org/repos/dist/dev/commons/collections/
    (svn revision 11263)

Maven artifacts are here:


https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/

Details of changes since 4.0 are in the release notes:


https://dist.apache.org/repos/dist/dev/commons/collections/RELEASE-NOTES.txt


http://people.apache.org/builds/commons/collections/4.1/RC1/changes-report.html

The tag is here:


https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1
    (svn revision 1715703)

Site:
    http://people.apache.org/builds/commons/collections/4.1/RC1/

Clirr Report (compared to 4.0):


http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html

RAT Report:


http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html

KEYS:
    https://www.apache.org/dist/commons/KEYS

Please review the release candidate and vote.

This vote will close no sooner that 72 hours from now, i.e. after 2400
GMT 25-November 2015

  [ ] +1 Release these artifacts
  [ ] +0 OK, but...
  [ ] -0 OK, but really should fix...
  [ ] -1 I oppose this release because...

Thanks,

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Oliver Heger-3
The Maven build worked fine with Java 1.6 and 1.7 on Windows 10. With
Java 1.8 I get the following compilation error in test classes:

[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR]
/c:/data/dev/projects/OpenSource/collections/commons-collections4-4.1-src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:[242,41]
reference to forEach is ambiguous
  both method forEach(java.util.function.Consumer<? super T>) in
java.lang.Iterable and method
forEach(org.apache.commons.collections4.Closure<? super E>) in
org.apache.commons.collections4.FluentIterable match
[INFO] 1 error

Artifacts and site look good. As the compilation error is only in a test
class, this is not blocking.

+1

Oliver

Am 22.11.2015 um 23:26 schrieb Thomas Neidhart:

> Hi all,
>
> we have accumulated enough changes since the last 4.0 release as well as
> we need to provide a fix for the known remote code exploit via java
> de-serialization. Therefore, I would like to start a vote to release
> Commons Collections 4.1 based on RC1.
>
> Note:
>
> The fix for the security related issue results in Clirr errors as unsafe
> classes in the functor package do not implement the Serializable
> interface anymore. This is mentioned in the release notes.
>
>
> Collections 4.1 RC1 is available for review here:
>     https://dist.apache.org/repos/dist/dev/commons/collections/
>     (svn revision 11263)
>
> Maven artifacts are here:
>
>
> https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/
>
> Details of changes since 4.0 are in the release notes:
>
>
> https://dist.apache.org/repos/dist/dev/commons/collections/RELEASE-NOTES.txt
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/changes-report.html
>
> The tag is here:
>
>
> https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1
>     (svn revision 1715703)
>
> Site:
>     http://people.apache.org/builds/commons/collections/4.1/RC1/
>
> Clirr Report (compared to 4.0):
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html
>
> RAT Report:
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html
>
> KEYS:
>     https://www.apache.org/dist/commons/KEYS
>
> Please review the release candidate and vote.
>
> This vote will close no sooner that 72 hours from now, i.e. after 2400
> GMT 25-November 2015
>
>   [ ] +1 Release these artifacts
>   [ ] +0 OK, but...
>   [ ] -0 OK, but really should fix...
>   [ ] -1 I oppose this release because...
>
> Thanks,
>
> Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
On 11/23/2015 09:53 PM, Oliver Heger wrote:

> The Maven build worked fine with Java 1.6 and 1.7 on Windows 10. With
> Java 1.8 I get the following compilation error in test classes:
>
> [ERROR] COMPILATION ERROR :
> [INFO] -------------------------------------------------------------
> [ERROR]
> /c:/data/dev/projects/OpenSource/collections/commons-collections4-4.1-src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:[242,41]
> reference to forEach is ambiguous
>   both method forEach(java.util.function.Consumer<? super T>) in
> java.lang.Iterable and method
> forEach(org.apache.commons.collections4.Closure<? super E>) in
> org.apache.commons.collections4.FluentIterable match
> [INFO] 1 error

Hi Oliver,

thanks for the test. Actually, I did test it with JDK 1.8, but with an
earlier version and the build/test worked fine.

Using the latest JDK (1.8.0_65) showed the same error as you reported.
Additionally, the eclipse compiler (included in release Luna 4.4.1)
showed some more compile errors which are mostly related to tests that
pass null as argument.

I will fix them in trunk, but I agree that these are not critical for
the release.

> Artifacts and site look good. As the compilation error is only in a test
> class, this is not blocking.
>
> +1

Thanks,

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
In reply to this post by Thomas Neidhart
On 11/22/2015 11:26 PM, Thomas Neidhart wrote:

> Hi all,
>
> we have accumulated enough changes since the last 4.0 release as well as
> we need to provide a fix for the known remote code exploit via java
> de-serialization. Therefore, I would like to start a vote to release
> Commons Collections 4.1 based on RC1.
>
> Note:
>
> The fix for the security related issue results in Clirr errors as unsafe
> classes in the functor package do not implement the Serializable
> interface anymore. This is mentioned in the release notes.
>
>
> Collections 4.1 RC1 is available for review here:
>     https://dist.apache.org/repos/dist/dev/commons/collections/
>     (svn revision 11263)
>
> Maven artifacts are here:
>
>
> https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/
>
> Details of changes since 4.0 are in the release notes:
>
>
> https://dist.apache.org/repos/dist/dev/commons/collections/RELEASE-NOTES.txt
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/changes-report.html
>
> The tag is here:
>
>
> https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1
>     (svn revision 1715703)
>
> Site:
>     http://people.apache.org/builds/commons/collections/4.1/RC1/
>
> Clirr Report (compared to 4.0):
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html
>
> RAT Report:
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html
>
> KEYS:
>     https://www.apache.org/dist/commons/KEYS
>
> Please review the release candidate and vote.
>
> This vote will close no sooner that 72 hours from now, i.e. after 2400
> GMT 25-November 2015
>
>   [ ] +1 Release these artifacts
>   [ ] +0 OK, but...
>   [ ] -0 OK, but really should fix...
>   [ ] -1 I oppose this release because...

I would like to remind all PMC members that this is also a security
related release that several people have requested.

If someone is not happy with the release as is, please speak up and vote
so that we at least can move forward.

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Jörg Schaible
In reply to this post by Thomas Neidhart
Hi Thomas,

Thomas Neidhart wrote:

> Hi all,
>
> we have accumulated enough changes since the last 4.0 release as well as
> we need to provide a fix for the known remote code exploit via java
> de-serialization. Therefore, I would like to start a vote to release
> Commons Collections 4.1 based on RC1.
>
> Note:
>
> The fix for the security related issue results in Clirr errors as unsafe
> classes in the functor package do not implement the Serializable
> interface anymore. This is mentioned in the release notes.
>
>
> Collections 4.1 RC1 is available for review here:
>     https://dist.apache.org/repos/dist/dev/commons/collections/
>     (svn revision 11263)
>
> Maven artifacts are here:
>
>
>
https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1

>     (svn revision 1715703)
>
> Site:
>     http://people.apache.org/builds/commons/collections/4.1/RC1/
>
> Clirr Report (compared to 4.0):
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html
>
> RAT Report:
>
>
> http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html
>
> KEYS:
>     https://www.apache.org/dist/commons/KEYS
>
> Please review the release candidate and vote.
>
> This vote will close no sooner that 72 hours from now, i.e. after 2400
> GMT 25-November 2015
>
>   [ ] +1 Release these artifacts
>   [ ] +0 OK, but...
>   [ ] -0 OK, but really should fix...
>   [ ] -1 I oppose this release because...
>
> Thanks,
>
> Thomas

It fails for IBM JDK 6:

================================ %< ===================
Failed tests:
org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue(org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet)
  Run 1: PASS
  Run 2: PASS
  Run 3: PASS
  Run 4: PASS
  Run 5: PASS
  Run 6: PASS
  Run 7: PASS
  Run 8: PASS
  Run 9: PASS
  Run 10: PASS
  Run 11: PASS
  Run 12: PASS
  Run 13: PASS
  Run 14: PASS
  Run 15: PASS
  Run 16: PASS
  Run 17: PASS
  Run 18: PASS
  Run 19: PASS
  Run 20: PASS
  Run 21: PASS
  Run 22: PASS
  Run 23: PASS
  Run 24: PASS
  Run 25: PASS
  Run 26: PASS
  Run 27: PASS
  Run 28: PASS
  Run 29: PASS
  Run 30: PASS
  Run 31: PASS
  Run 32: PASS
  Run 33: PASS
  Run 34: PASS
  Run 35: PASS
  Run 36: PASS
  Run 37:
AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
expected:<true> but was:<false>
  Run 38: PASS
  Run 39: PASS
  Run 40: PASS
  Run 41: PASS
  Run 42:
AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
expected:<true> but was:<false>
  Run 43: PASS
================================ %< ===================
$ mvn-3.0 -version
Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
14:51:28+0100)
Maven home: /usr/share/maven-bin-3.0
Java version: 1.6.0, vendor: IBM Corporation
Java home: /opt/ibm-jdk-bin-1.6.0.9_p2/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
================================ %< ===================

It fails to compile with Java 8:

================================ %< ===================
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:
[242,41] reference to forEach is ambiguous
  both method forEach(java.util.function.Consumer<? super T>) in
java.lang.Iterable and method
forEach(org.apache.commons.collections4.Closure<? super E>) in
org.apache.commons.collections4.FluentIterable match
[INFO] 1 error
[INFO] -------------------------------------------------------------
================================ %< ===================
$ mvn-3.0 -version
Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
14:51:28+0100)
Maven home: /usr/share/maven-bin-3.0
Java version: 1.8.0_66, vendor: Oracle Corporation
Java home: /opt/oracle-jdk-bin-1.8.0.66/jre
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
================================ %< ===================

nor Java 9:

================================ %< ===================
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchClosure.java:
[123,48] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
E>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#1 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchClosure.java:
[124,46] incompatible types: cannot infer type-variable(s) E
    (argument mismatch; org.apache.commons.collections4.Closure<? super E>[]
cannot be converted to org.apache.commons.collections4.Closure<? super
capture#2 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/BagUtils.java:[98,47]
incompatible types: org.apache.commons.collections4.Bag<capture#3 of ?
extends E> cannot be converted to org.apache.commons.collections4.Bag<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/AnyPredicate.java:
[60,53] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
T>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#4 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/NonePredicate.java:
[55,54] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
T>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#5 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/CollectionUtils.java:
[793,63] incompatible types: java.util.Collection<capture#6 of ? extends C>
cannot be converted to java.util.Collection<C>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/CollectionUtils.java:
[1831,61] incompatible types: java.util.Collection<capture#7 of ? extends C>
cannot be converted to java.util.Collection<C>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/ListUtils.java:[394,49]
incompatible types: java.util.List<capture#8 of ? extends E> cannot be
converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchTransformer.java:
[133,48] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
I>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#9 of ? super I>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchTransformer.java:
[134,50] incompatible types: cannot infer type-variable(s) I,O
    (argument mismatch; org.apache.commons.collections4.Transformer<? super
I,? extends O>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super capture#10 of ? super
I,? extends capture#11 of ? extends O>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/iterators/IteratorIterable.java:
[115,55] incompatible types: java.util.Iterator<capture#12 of ? extends E>
cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/ChainedClosure.java:
[92,46] incompatible types: cannot infer type-variable(s) E
    (argument mismatch; org.apache.commons.collections4.Closure<? super E>[]
cannot be converted to org.apache.commons.collections4.Closure<? super
capture#13 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/ChainedTransformer.java:
[92,50] incompatible types: cannot infer type-variable(s) I,O
    (argument mismatch; org.apache.commons.collections4.Transformer<? super
T,? extends T>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super capture#14 of ? super
T,? extends capture#15 of ? extends T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/AllPredicate.java:
[64,53] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
T>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#16 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TrieUtils.java:[46,49]
incompatible types: org.apache.commons.collections4.Trie<K,capture#17 of ?
extends V> cannot be converted to org.apache.commons.collections4.Trie<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/FluentIterable.java:
[311,18] incompatible types:
org.apache.commons.collections4.FluentIterable<capture#18 of ? extends O>
cannot be converted to org.apache.commons.collections4.FluentIterable<O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[438,31] incompatible types:
org.apache.commons.collections4.iterators.BoundedIterator<capture#19 of ?
extends E> cannot be converted to
org.apache.commons.collections4.iterators.BoundedIterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[859,47] incompatible types:
org.apache.commons.collections4.iterators.PeekingIterator<capture#20 of ?
extends E> cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[875,49] incompatible types:
org.apache.commons.collections4.iterators.PushbackIterator<capture#21 of ?
extends E> cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[1083,36] incompatible types: java.util.List<capture#22 of ? extends E>
cannot be converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[1101,22] incompatible types: java.util.List<capture#23 of ? extends E>
cannot be converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/QueueUtils.java:[56,51]
incompatible types: java.util.Queue<capture#24 of ? extends E> cannot be
converted to java.util.Queue<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[187,53] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#25 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[202,34] no suitable method found for
chainedTransformer(org.apache.commons.collections4.Transformer<? super T,?
extends T>[])
    method
org.apache.commons.collections4.functors.ChainedTransformer.<T>chainedTransformer(org.apache.commons.collections4.Transformer<?
super T,? extends T>...) is not applicable
      (cannot infer type-variable(s) T
        (varargs mismatch; org.apache.commons.collections4.Transformer<?
super T,? extends T>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super T,? extends T>))
    method
org.apache.commons.collections4.functors.ChainedTransformer.<T>chainedTransformer(java.util.Collection<?
extends org.apache.commons.collections4.Transformer<? super T,? extends T>>)
is not applicable
      (cannot infer type-variable(s) T
        (argument mismatch; org.apache.commons.collections4.Transformer<?
super T,? extends T>[] cannot be converted to java.util.Collection<? extends
org.apache.commons.collections4.Transformer<? super T,? extends T>>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[235,43] incompatible types:
org.apache.commons.collections4.Transformer<capture#26 of ? extends
T,capture#26 of ? extends T> cannot be converted to
org.apache.commons.collections4.Transformer<T,T>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[299,51] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#27 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[428,45] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#28 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MapUtils.java:[1272,47]
incompatible types: java.util.Map<capture#29 of ? extends K,capture#30 of ?
extends V> cannot be converted to java.util.Map<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MapUtils.java:[1537,59]
incompatible types: java.util.SortedMap<K,capture#31 of ? extends V> cannot
be converted to java.util.SortedMap<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/OnePredicate.java:
[60,53] incompatible types: cannot infer type-variable(s) T
    (argument mismatch; org.apache.commons.collections4.Predicate<? super
T>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super capture#32 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MultiSetUtils.java:[85,57]
incompatible types: org.apache.commons.collections4.MultiSet<capture#33 of ?
extends E> cannot be converted to
org.apache.commons.collections4.MultiSet<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/multimap/TransformedMultiValuedMap.java:
[162,82] incompatible types:
org.apache.commons.collections4.FluentIterable<capture#34 of ? extends V>
cannot be converted to java.lang.Iterable<V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[225,47]
incompatible types: java.util.Set<capture#35 of ? extends E> cannot be
converted to java.util.Set<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[505,54]
incompatible types: java.util.Iterator<capture#36 of ? extends E> cannot be
converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[543,54]
incompatible types: java.util.Iterator<capture#37 of ? extends E> cannot be
converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/PredicateUtils.java:
[537,57] incompatible types:
org.apache.commons.collections4.Predicate<capture#38 of ? extends T> cannot
be converted to org.apache.commons.collections4.Predicate<T>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[428,57] incompatible types: java.util.Iterator<capture#39 of ? extends O>
cannot be converted to java.util.Iterator<O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[554,37] no suitable method found for zippingIterator(java.util.Iterator<?
extends E>[])
    method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>,java.util.Iterator<? extends E>) is not applicable
      (cannot infer type-variable(s) E
        (actual and formal argument lists differ in length))
    method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>,java.util.Iterator<? extends E>,java.util.Iterator<? extends E>)
is not applicable
      (cannot infer type-variable(s) E
        (actual and formal argument lists differ in length))
    method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>...) is not applicable
      (cannot infer type-variable(s) E
        (varargs mismatch; java.util.Iterator<? extends E>[] cannot be
converted to java.util.Iterator<? extends E>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[830,16] no suitable method found for
partition(java.lang.Iterable<capture#40 of ? extends
O>,org.apache.commons.collections4.Factory<java.util.List<O>>,org.apache.commons.collections4.Predicate<?
super O>[])
    method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>) is not
applicable
      (cannot infer type-variable(s) O
        (actual and formal argument lists differ in length))
    method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>...) is not
applicable
      (cannot infer type-variable(s) O
        (varargs mismatch;
org.apache.commons.collections4.Factory<java.util.List<O>> cannot be
converted to org.apache.commons.collections4.Predicate<? super O>))
    method
org.apache.commons.collections4.IterableUtils.<O,R>partition(java.lang.Iterable<?
extends
O>,org.apache.commons.collections4.Factory<R>,org.apache.commons.collections4.Predicate<?
super O>...) is not applicable
      (cannot infer type-variable(s) O,R
        (varargs mismatch; org.apache.commons.collections4.Predicate<? super
O>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super O>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[870,16] no suitable method found for
partition(java.lang.Iterable<capture#41 of ? extends
O>,org.apache.commons.collections4.Factory<java.util.List<O>>,org.apache.commons.collections4.Predicate<?
super O>[])
    method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>) is not
applicable
      (cannot infer type-variable(s) O
        (actual and formal argument lists differ in length))
    method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>...) is not
applicable
      (cannot infer type-variable(s) O
        (varargs mismatch;
org.apache.commons.collections4.Factory<java.util.List<O>> cannot be
converted to org.apache.commons.collections4.Predicate<? super O>))
    method
org.apache.commons.collections4.IterableUtils.<O,R>partition(java.lang.Iterable<?
extends
O>,org.apache.commons.collections4.Factory<R>,org.apache.commons.collections4.Predicate<?
super O>...) is not applicable
      (cannot infer type-variable(s) O,R
        (varargs mismatch; org.apache.commons.collections4.Predicate<? super
O>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super O>))
[INFO] 40 errors
[INFO] -------------------------------------------------------------
[INFO]
------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO]
------------------------------------------------------------------------
[INFO] Total time: 7.498s
[INFO] Finished at: Tue Nov 24 23:27:36 CET 2015
[INFO] Final Memory: 32M/209M
[INFO]
------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-
plugin:3.2:compile (default-compile) on project commons-collections4:
Compilation failure: Compilation failure:
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchClosure.java:
[123,48] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super E>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#1 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchClosure.java:
[124,46] incompatible types: cannot infer type-variable(s) E
[ERROR] (argument mismatch; org.apache.commons.collections4.Closure<? super
E>[] cannot be converted to org.apache.commons.collections4.Closure<? super
capture#2 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/BagUtils.java:[98,47]
incompatible types: org.apache.commons.collections4.Bag<capture#3 of ?
extends E> cannot be converted to org.apache.commons.collections4.Bag<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/AnyPredicate.java:
[60,53] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super T>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#4 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/NonePredicate.java:
[55,54] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super T>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#5 of ? super T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/CollectionUtils.java:
[793,63] incompatible types: java.util.Collection<capture#6 of ? extends C>
cannot be converted to java.util.Collection<C>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/CollectionUtils.java:
[1831,61] incompatible types: java.util.Collection<capture#7 of ? extends C>
cannot be converted to java.util.Collection<C>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/ListUtils.java:[394,49]
incompatible types: java.util.List<capture#8 of ? extends E> cannot be
converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchTransformer.java:
[133,48] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super I>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#9 of ? super I>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/SwitchTransformer.java:
[134,50] incompatible types: cannot infer type-variable(s) I,O
[ERROR] (argument mismatch; org.apache.commons.collections4.Transformer<?
super I,? extends O>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super capture#10 of ? super
I,? extends capture#11 of ? extends O>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/iterators/IteratorIterable.java:
[115,55] incompatible types: java.util.Iterator<capture#12 of ? extends E>
cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/ChainedClosure.java:
[92,46] incompatible types: cannot infer type-variable(s) E
[ERROR] (argument mismatch; org.apache.commons.collections4.Closure<? super
E>[] cannot be converted to org.apache.commons.collections4.Closure<? super
capture#13 of ? super E>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/ChainedTransformer.java:
[92,50] incompatible types: cannot infer type-variable(s) I,O
[ERROR] (argument mismatch; org.apache.commons.collections4.Transformer<?
super T,? extends T>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super capture#14 of ? super
T,? extends capture#15 of ? extends T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/AllPredicate.java:
[64,53] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super T>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#16 of ? super
T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TrieUtils.java:[46,49]
incompatible types: org.apache.commons.collections4.Trie<K,capture#17 of ?
extends V> cannot be converted to org.apache.commons.collections4.Trie<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/FluentIterable.java:
[311,18] incompatible types:
org.apache.commons.collections4.FluentIterable<capture#18 of ? extends O>
cannot be converted to org.apache.commons.collections4.FluentIterable<O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[438,31] incompatible types:
org.apache.commons.collections4.iterators.BoundedIterator<capture#19 of ?
extends E> cannot be converted to
org.apache.commons.collections4.iterators.BoundedIterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[859,47] incompatible types:
org.apache.commons.collections4.iterators.PeekingIterator<capture#20 of ?
extends E> cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[875,49] incompatible types:
org.apache.commons.collections4.iterators.PushbackIterator<capture#21 of ?
extends E> cannot be converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[1083,36] incompatible types: java.util.List<capture#22 of ? extends E>
cannot be converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IteratorUtils.java:
[1101,22] incompatible types: java.util.List<capture#23 of ? extends E>
cannot be converted to java.util.List<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/QueueUtils.java:[56,51]
incompatible types: java.util.Queue<capture#24 of ? extends E> cannot be
converted to java.util.Queue<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[187,53] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#25 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[202,34] no suitable method found for
chainedTransformer(org.apache.commons.collections4.Transformer<? super T,?
extends T>[])
[ERROR] method
org.apache.commons.collections4.functors.ChainedTransformer.<T>chainedTransformer(org.apache.commons.collections4.Transformer<?
super T,? extends T>...) is not applicable
[ERROR] (cannot infer type-variable(s) T
[ERROR] (varargs mismatch; org.apache.commons.collections4.Transformer<?
super T,? extends T>[] cannot be converted to
org.apache.commons.collections4.Transformer<? super T,? extends T>))
[ERROR] method
org.apache.commons.collections4.functors.ChainedTransformer.<T>chainedTransformer(java.util.Collection<?
extends org.apache.commons.collections4.Transformer<? super T,? extends T>>)
is not applicable
[ERROR] (cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Transformer<?
super T,? extends T>[] cannot be converted to java.util.Collection<? extends
org.apache.commons.collections4.Transformer<? super T,? extends T>>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[235,43] incompatible types:
org.apache.commons.collections4.Transformer<capture#26 of ? extends
T,capture#26 of ? extends T> cannot be converted to
org.apache.commons.collections4.Transformer<T,T>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[299,51] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#27 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/TransformerUtils.java:
[428,45] incompatible types: no instance(s) of type variable(s) I exist so
that org.apache.commons.collections4.Transformer<I,capture#28 of ? extends
O> conforms to org.apache.commons.collections4.Transformer<I,O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MapUtils.java:[1272,47]
incompatible types: java.util.Map<capture#29 of ? extends K,capture#30 of ?
extends V> cannot be converted to java.util.Map<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MapUtils.java:[1537,59]
incompatible types: java.util.SortedMap<K,capture#31 of ? extends V> cannot
be converted to java.util.SortedMap<K,V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/functors/OnePredicate.java:
[60,53] incompatible types: cannot infer type-variable(s) T
[ERROR] (argument mismatch; org.apache.commons.collections4.Predicate<?
super T>[] cannot be converted to
org.apache.commons.collections4.Predicate<? super capture#32 of ? super
T>[])
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/MultiSetUtils.java:[85,57]
incompatible types: org.apache.commons.collections4.MultiSet<capture#33 of ?
extends E> cannot be converted to
org.apache.commons.collections4.MultiSet<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/multimap/TransformedMultiValuedMap.java:
[162,82] incompatible types:
org.apache.commons.collections4.FluentIterable<capture#34 of ? extends V>
cannot be converted to java.lang.Iterable<V>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[225,47]
incompatible types: java.util.Set<capture#35 of ? extends E> cannot be
converted to java.util.Set<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[505,54]
incompatible types: java.util.Iterator<capture#36 of ? extends E> cannot be
converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/SetUtils.java:[543,54]
incompatible types: java.util.Iterator<capture#37 of ? extends E> cannot be
converted to java.util.Iterator<E>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/PredicateUtils.java:
[537,57] incompatible types:
org.apache.commons.collections4.Predicate<capture#38 of ? extends T> cannot
be converted to org.apache.commons.collections4.Predicate<T>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[428,57] incompatible types: java.util.Iterator<capture#39 of ? extends O>
cannot be converted to java.util.Iterator<O>
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[554,37] no suitable method found for zippingIterator(java.util.Iterator<?
extends E>[])
[ERROR] method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>,java.util.Iterator<? extends E>) is not applicable
[ERROR] (cannot infer type-variable(s) E
[ERROR] (actual and formal argument lists differ in length))
[ERROR] method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>,java.util.Iterator<? extends E>,java.util.Iterator<? extends E>)
is not applicable
[ERROR] (cannot infer type-variable(s) E
[ERROR] (actual and formal argument lists differ in length))
[ERROR] method
org.apache.commons.collections4.IteratorUtils.<E>zippingIterator(java.util.Iterator<?
extends E>...) is not applicable
[ERROR] (cannot infer type-variable(s) E
[ERROR] (varargs mismatch; java.util.Iterator<? extends E>[] cannot be
converted to java.util.Iterator<? extends E>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[830,16] no suitable method found for
partition(java.lang.Iterable<capture#40 of ? extends
O>,org.apache.commons.collections4.Factory<java.util.List<O>>,org.apache.commons.collections4.Predicate<?
super O>[])
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>) is not
applicable
[ERROR] (cannot infer type-variable(s) O
[ERROR] (actual and formal argument lists differ in length))
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>...) is not
applicable
[ERROR] (cannot infer type-variable(s) O
[ERROR] (varargs mismatch;
org.apache.commons.collections4.Factory<java.util.List<O>> cannot be
converted to org.apache.commons.collections4.Predicate<? super O>))
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O,R>partition(java.lang.Iterable<?
extends
O>,org.apache.commons.collections4.Factory<R>,org.apache.commons.collections4.Predicate<?
super O>...) is not applicable
[ERROR] (cannot infer type-variable(s) O,R
[ERROR] (varargs mismatch; org.apache.commons.collections4.Predicate<? super
O>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super O>))
[ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
src/src/main/java/org/apache/commons/collections4/IterableUtils.java:
[870,16] no suitable method found for
partition(java.lang.Iterable<capture#41 of ? extends
O>,org.apache.commons.collections4.Factory<java.util.List<O>>,org.apache.commons.collections4.Predicate<?
super O>[])
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>) is not
applicable
[ERROR] (cannot infer type-variable(s) O
[ERROR] (actual and formal argument lists differ in length))
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O>partition(java.lang.Iterable<?
extends O>,org.apache.commons.collections4.Predicate<? super O>...) is not
applicable
[ERROR] (cannot infer type-variable(s) O
[ERROR] (varargs mismatch;
org.apache.commons.collections4.Factory<java.util.List<O>> cannot be
converted to org.apache.commons.collections4.Predicate<? super O>))
[ERROR] method
org.apache.commons.collections4.IterableUtils.<O,R>partition(java.lang.Iterable<?
extends
O>,org.apache.commons.collections4.Factory<R>,org.apache.commons.collections4.Predicate<?
super O>...) is not applicable
[ERROR] (cannot infer type-variable(s) O,R
[ERROR] (varargs mismatch; org.apache.commons.collections4.Predicate<? super
O>[] cannot be converted to org.apache.commons.collections4.Predicate<?
super O>))
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
================================ %< ===================
$ mvn-3.0 -version
Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
14:51:28+0100)
Maven home: /usr/share/maven-bin-3.0
Java version: 1.9.0-ea, vendor: Oracle Corporation
Java home: /opt/oracle-jdk-bin-1.9.0.0_alpha53
Default locale: en_US, platform encoding: UTF-8
OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
================================ %< ===================

-1

Sorry,
Jörg



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
On 11/24/2015 11:30 PM, Jörg Schaible wrote:

> Hi Thomas,
>
> Thomas Neidhart wrote:
>
>> Hi all,
>>
>> we have accumulated enough changes since the last 4.0 release as well as
>> we need to provide a fix for the known remote code exploit via java
>> de-serialization. Therefore, I would like to start a vote to release
>> Commons Collections 4.1 based on RC1.
>>
>> Note:
>>
>> The fix for the security related issue results in Clirr errors as unsafe
>> classes in the functor package do not implement the Serializable
>> interface anymore. This is mentioned in the release notes.
>>
>>
>> Collections 4.1 RC1 is available for review here:
>>     https://dist.apache.org/repos/dist/dev/commons/collections/
>>     (svn revision 11263)
>>
>> Maven artifacts are here:
>>
>>
>>
> https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/
>>
>> Details of changes since 4.0 are in the release notes:
>>
>>
>> https://dist.apache.org/repos/dist/dev/commons/collections/RELEASE-NOTES.txt
>>
>>
>> http://people.apache.org/builds/commons/collections/4.1/RC1/changes-report.html
>>
>> The tag is here:
>>
>>
>>
> https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1
>>     (svn revision 1715703)
>>
>> Site:
>>     http://people.apache.org/builds/commons/collections/4.1/RC1/
>>
>> Clirr Report (compared to 4.0):
>>
>>
>> http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html
>>
>> RAT Report:
>>
>>
>> http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html
>>
>> KEYS:
>>     https://www.apache.org/dist/commons/KEYS
>>
>> Please review the release candidate and vote.
>>
>> This vote will close no sooner that 72 hours from now, i.e. after 2400
>> GMT 25-November 2015
>>
>>   [ ] +1 Release these artifacts
>>   [ ] +0 OK, but...
>>   [ ] -0 OK, but really should fix...
>>   [ ] -1 I oppose this release because...
>>
>> Thanks,
>>
>> Thomas
>
> It fails for IBM JDK 6:
>
> ================================ %< ===================
> Failed tests:
> org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue(org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet)
>   Run 1: PASS
>   Run 2: PASS
>   Run 3: PASS
>   Run 4: PASS
>   Run 5: PASS
>   Run 6: PASS
>   Run 7: PASS
>   Run 8: PASS
>   Run 9: PASS
>   Run 10: PASS
>   Run 11: PASS
>   Run 12: PASS
>   Run 13: PASS
>   Run 14: PASS
>   Run 15: PASS
>   Run 16: PASS
>   Run 17: PASS
>   Run 18: PASS
>   Run 19: PASS
>   Run 20: PASS
>   Run 21: PASS
>   Run 22: PASS
>   Run 23: PASS
>   Run 24: PASS
>   Run 25: PASS
>   Run 26: PASS
>   Run 27: PASS
>   Run 28: PASS
>   Run 29: PASS
>   Run 30: PASS
>   Run 31: PASS
>   Run 32: PASS
>   Run 33: PASS
>   Run 34: PASS
>   Run 35: PASS
>   Run 36: PASS
>   Run 37:
> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
> expected:<true> but was:<false>
>   Run 38: PASS
>   Run 39: PASS
>   Run 40: PASS
>   Run 41: PASS
>   Run 42:
> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
> expected:<true> but was:<false>
>   Run 43: PASS

These test failures exist since the 4.0 release, quoting your vote for
Collection 4.0 based on RC5:

> +1, builds for all but one JDK flawlessly from source. I still have 2
> failing tests for IBM JDK 1.6:
>
> Failed tests:
>   AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
> expected:<true> but was:<false>
>   AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
> expected:<true> but was:<false>
>
> However, since we already blamed that JDK, it does not influence the
> release.

I can not remember anymore why these have not been worked-around though,
but I suspect that it was not so simple in this case.


> ================================ %< ===================
> $ mvn-3.0 -version
> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
> 14:51:28+0100)
> Maven home: /usr/share/maven-bin-3.0
> Java version: 1.6.0, vendor: IBM Corporation
> Java home: /opt/ibm-jdk-bin-1.6.0.9_p2/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
> ================================ %< ===================
>
> It fails to compile with Java 8:
>
> ================================ %< ===================
> [INFO] -------------------------------------------------------------
> [ERROR] COMPILATION ERROR :
> [INFO] -------------------------------------------------------------
> [ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
> src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:
> [242,41] reference to forEach is ambiguous
>   both method forEach(java.util.function.Consumer<? super T>) in
> java.lang.Iterable and method
> forEach(org.apache.commons.collections4.Closure<? super E>) in
> org.apache.commons.collections4.FluentIterable match
> [INFO] 1 error
> [INFO] -------------------------------------------------------------

ok, this error has been already spotted by Oliver and fixed in trunk. It
is only in a test case where the type inference fails when passing a
null value to a method, as you usually do in tests.

> ================================ %< ===================
> $ mvn-3.0 -version
> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
> 14:51:28+0100)
> Maven home: /usr/share/maven-bin-3.0
> Java version: 1.8.0_66, vendor: Oracle Corporation
> Java home: /opt/oracle-jdk-bin-1.8.0.66/jre
> Default locale: en_US, platform encoding: UTF-8
> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
> ================================ %< ===================
>
> nor Java 9:

ok. I have to investigate these errors, but I really wonder what we
should do about it. Java 1.9 is not released yet, and these might be
compiler related bugs that will be fixed, and adding work-arounds for
things that perfectly compile with all previous Java versions does not
sound right.

> -1
>
> Sorry,
> Jörg

Thanks,

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Luc Maisonobe-2
Le 2015-11-25 07:50, Thomas Neidhart a écrit :

> On 11/24/2015 11:30 PM, Jörg Schaible wrote:
>> Hi Thomas,
>>
>> Thomas Neidhart wrote:
>>
>>> Hi all,
>>>
>>> we have accumulated enough changes since the last 4.0 release as well
>>> as
>>> we need to provide a fix for the known remote code exploit via java
>>> de-serialization. Therefore, I would like to start a vote to release
>>> Commons Collections 4.1 based on RC1.
>>>
>>> Note:
>>>
>>> The fix for the security related issue results in Clirr errors as
>>> unsafe
>>> classes in the functor package do not implement the Serializable
>>> interface anymore. This is mentioned in the release notes.
>>>
>>>
>>> Collections 4.1 RC1 is available for review here:
>>>     https://dist.apache.org/repos/dist/dev/commons/collections/
>>>     (svn revision 11263)
>>>
>>> Maven artifacts are here:
>>>
>>>
>>>
>> https://repository.apache.org/content/repositories/orgapachecommons-1122/org/apache/commons/commons-collections4/4.1/
>>>
>>> Details of changes since 4.0 are in the release notes:
>>>
>>>
>>> https://dist.apache.org/repos/dist/dev/commons/collections/RELEASE-NOTES.txt
>>>
>>>
>>> http://people.apache.org/builds/commons/collections/4.1/RC1/changes-report.html
>>>
>>> The tag is here:
>>>
>>>
>>>
>> https://svn.apache.org/repos/asf/commons/proper/collections/tags/COLLECTIONS_4_1_RC1
>>>     (svn revision 1715703)
>>>
>>> Site:
>>>     http://people.apache.org/builds/commons/collections/4.1/RC1/
>>>
>>> Clirr Report (compared to 4.0):
>>>
>>>
>>> http://people.apache.org/builds/commons/collections/4.1/RC1/clirr-report.html
>>>
>>> RAT Report:
>>>
>>>
>>> http://people.apache.org/builds/commons/collections/4.1/RC1/rat-report.html
>>>
>>> KEYS:
>>>     https://www.apache.org/dist/commons/KEYS
>>>
>>> Please review the release candidate and vote.
>>>
>>> This vote will close no sooner that 72 hours from now, i.e. after
>>> 2400
>>> GMT 25-November 2015
>>>
>>>   [ ] +1 Release these artifacts

+1 for the release

Luc

>>>   [ ] +0 OK, but...
>>>   [ ] -0 OK, but really should fix...
>>>   [ ] -1 I oppose this release because...
>>>
>>> Thanks,
>>>
>>> Thomas
>>
>> It fails for IBM JDK 6:
>>
>> ================================ %< ===================
>> Failed tests:
>> org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue(org.apache.commons.collections4.map.AbstractMapTest$TestMapEntrySet)
>>   Run 1: PASS
>>   Run 2: PASS
>>   Run 3: PASS
>>   Run 4: PASS
>>   Run 5: PASS
>>   Run 6: PASS
>>   Run 7: PASS
>>   Run 8: PASS
>>   Run 9: PASS
>>   Run 10: PASS
>>   Run 11: PASS
>>   Run 12: PASS
>>   Run 13: PASS
>>   Run 14: PASS
>>   Run 15: PASS
>>   Run 16: PASS
>>   Run 17: PASS
>>   Run 18: PASS
>>   Run 19: PASS
>>   Run 20: PASS
>>   Run 21: PASS
>>   Run 22: PASS
>>   Run 23: PASS
>>   Run 24: PASS
>>   Run 25: PASS
>>   Run 26: PASS
>>   Run 27: PASS
>>   Run 28: PASS
>>   Run 29: PASS
>>   Run 30: PASS
>>   Run 31: PASS
>>   Run 32: PASS
>>   Run 33: PASS
>>   Run 34: PASS
>>   Run 35: PASS
>>   Run 36: PASS
>>   Run 37:
>> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
>> expected:<true> but was:<false>
>>   Run 38: PASS
>>   Run 39: PASS
>>   Run 40: PASS
>>   Run 41: PASS
>>   Run 42:
>> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1665
>> expected:<true> but was:<false>
>>   Run 43: PASS
>
> These test failures exist since the 4.0 release, quoting your vote for
> Collection 4.0 based on RC5:
>
>> +1, builds for all but one JDK flawlessly from source. I still have 2
>> failing tests for IBM JDK 1.6:
>>
>> Failed tests:
>>  
>> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>> expected:<true> but was:<false>
>>  
>> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>> expected:<true> but was:<false>
>>
>> However, since we already blamed that JDK, it does not influence the
>> release.
>
> I can not remember anymore why these have not been worked-around
> though,
> but I suspect that it was not so simple in this case.
>
>
>> ================================ %< ===================
>> $ mvn-3.0 -version
>> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da;
>> 2013-02-19
>> 14:51:28+0100)
>> Maven home: /usr/share/maven-bin-3.0
>> Java version: 1.6.0, vendor: IBM Corporation
>> Java home: /opt/ibm-jdk-bin-1.6.0.9_p2/jre
>> Default locale: en_US, platform encoding: UTF-8
>> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family:
>> "unix"
>> ================================ %< ===================
>>
>> It fails to compile with Java 8:
>>
>> ================================ %< ===================
>> [INFO] -------------------------------------------------------------
>> [ERROR] COMPILATION ERROR :
>> [INFO] -------------------------------------------------------------
>> [ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
>> src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:
>> [242,41] reference to forEach is ambiguous
>>   both method forEach(java.util.function.Consumer<? super T>) in
>> java.lang.Iterable and method
>> forEach(org.apache.commons.collections4.Closure<? super E>) in
>> org.apache.commons.collections4.FluentIterable match
>> [INFO] 1 error
>> [INFO] -------------------------------------------------------------
>
> ok, this error has been already spotted by Oliver and fixed in trunk.
> It
> is only in a test case where the type inference fails when passing a
> null value to a method, as you usually do in tests.
>
>> ================================ %< ===================
>> $ mvn-3.0 -version
>> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da;
>> 2013-02-19
>> 14:51:28+0100)
>> Maven home: /usr/share/maven-bin-3.0
>> Java version: 1.8.0_66, vendor: Oracle Corporation
>> Java home: /opt/oracle-jdk-bin-1.8.0.66/jre
>> Default locale: en_US, platform encoding: UTF-8
>> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family:
>> "unix"
>> ================================ %< ===================
>>
>> nor Java 9:
>
> ok. I have to investigate these errors, but I really wonder what we
> should do about it. Java 1.9 is not released yet, and these might be
> compiler related bugs that will be fixed, and adding work-arounds for
> things that perfectly compile with all previous Java versions does not
> sound right.
>
>> -1
>>
>> Sorry,
>> Jörg
>
> Thanks,
>
> Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Jörg Schaible
In reply to this post by Thomas Neidhart
Hi Thomas,

Thomas Neidhart wrote:

> On 11/24/2015 11:30 PM, Jörg Schaible wrote:
>> Hi Thomas,
>>
>> Thomas Neidhart wrote:

[snip]

> These test failures exist since the 4.0 release, quoting your vote for
> Collection 4.0 based on RC5:
>
>> +1, builds for all but one JDK flawlessly from source. I still have 2
>> failing tests for IBM JDK 1.6:
>>
>> Failed tests:
>>  
AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>> expected:<true> but was:<false>
>>  
AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>> expected:<true> but was:<false>
>>
>> However, since we already blamed that JDK, it does not influence the
>> release.
>
> I can not remember anymore why these have not been worked-around though,
> but I suspect that it was not so simple in this case.

OK, at least it's no regression.

>> ================================ %< ===================
>> $ mvn-3.0 -version
>> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
>> 14:51:28+0100)
>> Maven home: /usr/share/maven-bin-3.0
>> Java version: 1.6.0, vendor: IBM Corporation
>> Java home: /opt/ibm-jdk-bin-1.6.0.9_p2/jre
>> Default locale: en_US, platform encoding: UTF-8
>> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
>> ================================ %< ===================
>>
>> It fails to compile with Java 8:
>>
>> ================================ %< ===================
>> [INFO] -------------------------------------------------------------
>> [ERROR] COMPILATION ERROR :
>> [INFO] -------------------------------------------------------------
>> [ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
>>
src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:

>> [242,41] reference to forEach is ambiguous
>>   both method forEach(java.util.function.Consumer<? super T>) in
>> java.lang.Iterable and method
>> forEach(org.apache.commons.collections4.Closure<? super E>) in
>> org.apache.commons.collections4.FluentIterable match
>> [INFO] 1 error
>> [INFO] -------------------------------------------------------------
>
> ok, this error has been already spotted by Oliver and fixed in trunk. It
> is only in a test case where the type inference fails when passing a
> null value to a method, as you usually do in tests.

OK, fine with me.

[snip]

>> nor Java 9:
>
> ok. I have to investigate these errors, but I really wonder what we
> should do about it. Java 1.9 is not released yet, and these might be
> compiler related bugs that will be fixed, and adding work-arounds for
> things that perfectly compile with all previous Java versions does not
> sound right.

I've update Java 9 now to the latest available (b93), but the problem stays.
However, we have the same errors with 4.0.0, so it's actually no regression,
but an indication that we need probably collections5 when Java 9 is final.

Therefore +1 for this release.

Cheers,
Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Stefan Bodewig
In reply to this post by Oliver Heger-3

> Please review the release candidate and vote.

> This vote will close no sooner that 72 hours from now, i.e. after 2400
> GMT 25-November 2015

+1

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
In reply to this post by Jörg Schaible
On 11/25/2015 11:30 AM, Jörg Schaible wrote:

> Hi Thomas,
>
> Thomas Neidhart wrote:
>
>> On 11/24/2015 11:30 PM, Jörg Schaible wrote:
>>> Hi Thomas,
>>>
>>> Thomas Neidhart wrote:
>
> [snip]
>
>> These test failures exist since the 4.0 release, quoting your vote for
>> Collection 4.0 based on RC5:
>>
>>> +1, builds for all but one JDK flawlessly from source. I still have 2
>>> failing tests for IBM JDK 1.6:
>>>
>>> Failed tests:
>>>  
> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>>> expected:<true> but was:<false>
>>>  
> AbstractMapTest$TestMapEntrySet.testMapEntrySetIteratorEntrySetValue:1656
>>> expected:<true> but was:<false>
>>>
>>> However, since we already blamed that JDK, it does not influence the
>>> release.
>>
>> I can not remember anymore why these have not been worked-around though,
>> but I suspect that it was not so simple in this case.
>
> OK, at least it's no regression.
>
>>> ================================ %< ===================
>>> $ mvn-3.0 -version
>>> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
>>> 14:51:28+0100)
>>> Maven home: /usr/share/maven-bin-3.0
>>> Java version: 1.6.0, vendor: IBM Corporation
>>> Java home: /opt/ibm-jdk-bin-1.6.0.9_p2/jre
>>> Default locale: en_US, platform encoding: UTF-8
>>> OS name: "linux", version: "4.1.12-gentoo", arch: "amd64", family: "unix"
>>> ================================ %< ===================
>>>
>>> It fails to compile with Java 8:
>>>
>>> ================================ %< ===================
>>> [INFO] -------------------------------------------------------------
>>> [ERROR] COMPILATION ERROR :
>>> [INFO] -------------------------------------------------------------
>>> [ERROR] /home/joehni/tmp/download/commons-collections4-4.1-
>>>
> src/src/test/java/org/apache/commons/collections4/FluentIterableTest.java:
>>> [242,41] reference to forEach is ambiguous
>>>   both method forEach(java.util.function.Consumer<? super T>) in
>>> java.lang.Iterable and method
>>> forEach(org.apache.commons.collections4.Closure<? super E>) in
>>> org.apache.commons.collections4.FluentIterable match
>>> [INFO] 1 error
>>> [INFO] -------------------------------------------------------------
>>
>> ok, this error has been already spotted by Oliver and fixed in trunk. It
>> is only in a test case where the type inference fails when passing a
>> null value to a method, as you usually do in tests.
>
> OK, fine with me.
>
> [snip]
>
>>> nor Java 9:
>>
>> ok. I have to investigate these errors, but I really wonder what we
>> should do about it. Java 1.9 is not released yet, and these might be
>> compiler related bugs that will be fixed, and adding work-arounds for
>> things that perfectly compile with all previous Java versions does not
>> sound right.
>
> I've update Java 9 now to the latest available (b93), but the problem stays.
> However, we have the same errors with 4.0.0, so it's actually no regression,
> but an indication that we need probably collections5 when Java 9 is final.

I did some further investigation into the compile errors with Java 9.

Some errors depend on the source/target version: they disappear for
version 1.8+ (there is at least one bugreport related to that:
https://bugs.openjdk.java.net/browse/JDK-8075793)

Some errors are not understandable at all:

Iterator<? extends E>[] iterators = new Iterator[others.length + 1];
iterators[0] = first.iterator();
for (int i = 0; i < others.length; i++) {
    iterators[i + 1] = others[i].iterator();
}
return IteratorUtils.zippingIterator(iterators);

The signature of IteratorUtils.zippingIterator is as follows:

public static <E> ZippingIterator<E> zippingIterator(final Iterator<?
extends E>... iterators)

it fails with:

[ERROR]
/home/tn/workspace/apache/commons-collections/src/main/java/org/apache/commons/collections4/IterableUtils.java:[554,36]
error: no suitable method found for zippingIterator(Iterator<? extends
E#1>[])


changing the call to

return IteratorUtils.<E>zippingIterator(iterators);

makes it pass.

Anyway, this will require some more time to investigate and fix. For a
4.1 release I will note that the project can not be compiled with Java 9
yet, and the next release (4.2) should improve on that imho.

Thanks for testing,

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

[CANCEL][VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
In reply to this post by Thomas Neidhart
On 11/22/2015 11:26 PM, Thomas Neidhart wrote:
> Hi all,
>
> we have accumulated enough changes since the last 4.0 release as well as
> we need to provide a fix for the known remote code exploit via java
> de-serialization. Therefore, I would like to start a vote to release
> Commons Collections 4.1 based on RC1.

Thanks for all the people that voted.
Some glitches have been found and I also have found myself a few minor
issues that I would like to correct as this will be my last release.

So my plan is to create a new RC and call a new vote that will expire in
24h as no critical issues have been found so far.

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [CANCEL][VOTE] Release Commons Collections 4.1 Based on RC1

garydgregory
On Wed, Nov 25, 2015 at 11:40 AM, Thomas Neidhart <[hidden email]
> wrote:

> On 11/22/2015 11:26 PM, Thomas Neidhart wrote:
> > Hi all,
> >
> > we have accumulated enough changes since the last 4.0 release as well as
> > we need to provide a fix for the known remote code exploit via java
> > de-serialization. Therefore, I would like to start a vote to release
> > Commons Collections 4.1 based on RC1.
>
> Thanks for all the people that voted.
> Some glitches have been found and I also have found myself a few minor
> issues that I would like to correct as this will be my last release.
>

What do you mean by "this will be my last release"?

Gary

>
> So my plan is to create a new RC and call a new vote that will expire in
> 24h as no critical issues have been found so far.
>
> Thomas
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
E-Mail: [hidden email] | [hidden email]
Java Persistence with Hibernate, Second Edition
<http://www.manning.com/bauer3/>
JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
Spring Batch in Action <http://www.manning.com/templier/>
Blog: http://garygregory.wordpress.com
Home: http://garygregory.com/
Tweet! http://twitter.com/GaryGregory
Reply | Threaded
Open this post in threaded view
|

Re: [CANCEL][VOTE] Release Commons Collections 4.1 Based on RC1

Thomas Neidhart
On 11/25/2015 09:04 PM, Gary Gregory wrote:

> On Wed, Nov 25, 2015 at 11:40 AM, Thomas Neidhart <[hidden email]
>> wrote:
>
>> On 11/22/2015 11:26 PM, Thomas Neidhart wrote:
>>> Hi all,
>>>
>>> we have accumulated enough changes since the last 4.0 release as well as
>>> we need to provide a fix for the known remote code exploit via java
>>> de-serialization. Therefore, I would like to start a vote to release
>>> Commons Collections 4.1 based on RC1.
>>
>> Thanks for all the people that voted.
>> Some glitches have been found and I also have found myself a few minor
>> issues that I would like to correct as this will be my last release.
>>
>
> What do you mean by "this will be my last release"?

that means that I will use my evening spare time differently in the
future, but I will send a separate email to the ml after this release.

Thomas

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]