ant, jakarta commons, ftp task, and z/OS

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

ant, jakarta commons, ftp task, and z/OS

blatt, lew
in advance, i apologize if i am in the wrong forum.

two questions:

1)  i've a build system based on ant 1.5.4 and NetComponents.jar.  albeit
outdated, this combo works well enough for us on many platforms.  we can ant
build and launch ftp tasks.  trying to implement same on z/OS (IBM
mainframe) gives:

transfer: com.oroinc.net.MalformedServerReplyException: Could not parse
response
 code.
Server Reply: ▬▬ÉÇ%?─/%╟?╦╚♠%?─/%└?_/╤>ÇπΦ&Ç╦┴╩╬┴╩Çêε┴╩╦╤?>Ç╧═▬♠û♠▬òëÇ╩┴/└`♠
        at
org.apache.tools.ant.taskdefs.optional.net.FTP.execute(FTP.java:1010)
        at org.apache.tools.ant.Task.perform(Task.java:341)
        at org.apache.tools.ant.Target.execute(Target.java:309)
        at org.apache.tools.ant.Target.performTasks(Target.java:336)
        at org.apache.tools.ant.Project.executeTarget(Project.java:1339)
        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:397)


can anyone offer an answer why the error occurs ?

2) anticipating someone would tell me to upgrade to jakarta (or get off this
list :)), i updated to ant 1.6.5 and commons 1.4.0.  launching an ftp task
gives:

java.lang.UnsupportedClassVersionError: org/apache/commons/net/ftp/FTPClient
(Unsupported major.minor version 48.0)

the Java version i am running is 1.3.  i saw a hit associated with the error
message, suggesting the user upgrade to Java 1.4.  is this, in fact, the
ticket ?  

thanks, lew


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: ant, jakarta commons, ftp task, and z/OS

Rick Herrick
blatt, lew said:
> two questions:
> can anyone offer an answer why the error occurs ?

Nope, sorry.  I'd suggest upgrading your ant and commons-net or get off
the list :)

> 2) anticipating someone would tell me to upgrade to jakarta (or get off
> this
> list :)), i updated to ant 1.6.5 and commons 1.4.0.  launching an ftp task
> gives:
>
> java.lang.UnsupportedClassVersionError:
> org/apache/commons/net/ftp/FTPClient
> (Unsupported major.minor version 48.0)
>
> the Java version i am running is 1.3.  i saw a hit associated with the
> error
> message, suggesting the user upgrade to Java 1.4.  is this, in fact, the
> ticket ?

Yes, that is, indeed, the ticket.  You will also need to purge the class
cache (e.g. the Catalina work directory) if you have any of that (sounds
like a shell app though).

--
Rick Herrick
[hidden email]

I haven't got time for inner peace.

Get out of control, but appear under control. It's not bad to alarm other
people, though--it's good for them.--Hunter S. Thompson

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]