[bcel] broken repo?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[bcel] broken repo?

garydgregory
Hi All:

When I try a clean checkout of BCEL I get:

C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
Cloning into 'commons-bcel'...
remote: Counting objects: 21585, done.
remote: Compressing objects: 100% (2646/2646), done.
Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s

Resolving deltas: 100% (14986/14986), done.
warning: remote HEAD refers to nonexistent ref, unable to checkout.

Ideas?

Gary
Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

Rob Tompkins
looking now. -Rob

> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]> wrote:
>
> Hi All:
>
> When I try a clean checkout of BCEL I get:
>
> C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
> Cloning into 'commons-bcel'...
> remote: Counting objects: 21585, done.
> remote: Compressing objects: 100% (2646/2646), done.
> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
>
> Resolving deltas: 100% (14986/14986), done.
> warning: remote HEAD refers to nonexistent ref, unable to checkout.
>
> Ideas?
>
> Gary


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

Rob Tompkins
I wonder if the default branch, “trunk,” no longer exists and that’s what it’s trying to clone down onto. When I run the following it works:

git clone --single-branch --branch master https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git>

-Rob

> On May 6, 2019, at 2:05 PM, Rob Tompkins <[hidden email]> wrote:
>
> looking now. -Rob
>
>> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]> wrote:
>>
>> Hi All:
>>
>> When I try a clean checkout of BCEL I get:
>>
>> C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
>> Cloning into 'commons-bcel'...
>> remote: Counting objects: 21585, done.
>> remote: Compressing objects: 100% (2646/2646), done.
>> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
>> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
>>
>> Resolving deltas: 100% (14986/14986), done.
>> warning: remote HEAD refers to nonexistent ref, unable to checkout.
>>
>> Ideas?
>>
>> Gary
>

Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

sebb-2-2
Same issue applies to commons-net and -daemon.
However commons-io and -lang are OK.

Looks like the default branch has not been set up correctly for some
of the repos (probably the ones that were migrated last).

How does one set the default branch?

On Mon, 6 May 2019 at 19:09, Rob Tompkins <[hidden email]> wrote:

>
> I wonder if the default branch, “trunk,” no longer exists and that’s what it’s trying to clone down onto. When I run the following it works:
>
> git clone --single-branch --branch master https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git>
>
> -Rob
>
> > On May 6, 2019, at 2:05 PM, Rob Tompkins <[hidden email]> wrote:
> >
> > looking now. -Rob
> >
> >> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]> wrote:
> >>
> >> Hi All:
> >>
> >> When I try a clean checkout of BCEL I get:
> >>
> >> C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
> >> Cloning into 'commons-bcel'...
> >> remote: Counting objects: 21585, done.
> >> remote: Compressing objects: 100% (2646/2646), done.
> >> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
> >> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
> >>
> >> Resolving deltas: 100% (14986/14986), done.
> >> warning: remote HEAD refers to nonexistent ref, unable to checkout.
> >>
> >> Ideas?
> >>
> >> Gary
> >
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

Rob Tompkins


> On May 6, 2019, at 2:14 PM, sebb <[hidden email]> wrote:
>
> Same issue applies to commons-net and -daemon.
> However commons-io and -lang are OK.
>
> Looks like the default branch has not been set up correctly for some
> of the repos (probably the ones that were migrated last).
>
> How does one set the default branch?

I had to put in tickets with Infra to do that back in December/Januaray. I would guess that it would have something to do with their puppet automation, but that’s totally a guess.

-Rob

>
> On Mon, 6 May 2019 at 19:09, Rob Tompkins <[hidden email] <mailto:[hidden email]>> wrote:
>>
>> I wonder if the default branch, “trunk,” no longer exists and that’s what it’s trying to clone down onto. When I run the following it works:
>>
>> git clone --single-branch --branch master https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git> <https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git>>
>>
>> -Rob
>>
>>> On May 6, 2019, at 2:05 PM, Rob Tompkins <[hidden email]> wrote:
>>>
>>> looking now. -Rob
>>>
>>>> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]> wrote:
>>>>
>>>> Hi All:
>>>>
>>>> When I try a clean checkout of BCEL I get:
>>>>
>>>> C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
>>>> Cloning into 'commons-bcel'...
>>>> remote: Counting objects: 21585, done.
>>>> remote: Compressing objects: 100% (2646/2646), done.
>>>> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
>>>> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
>>>>
>>>> Resolving deltas: 100% (14986/14986), done.
>>>> warning: remote HEAD refers to nonexistent ref, unable to checkout.
>>>>
>>>> Ideas?
>>>>
>>>> Gary
>>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
> For additional commands, e-mail: [hidden email] <mailto:[hidden email]>
Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

sebb-2-2
https://issues.apache.org/jira/browse/INFRA-18339

On Mon, 6 May 2019 at 19:24, Rob Tompkins <[hidden email]> wrote:

>
>
>
> > On May 6, 2019, at 2:14 PM, sebb <[hidden email]> wrote:
> >
> > Same issue applies to commons-net and -daemon.
> > However commons-io and -lang are OK.
> >
> > Looks like the default branch has not been set up correctly for some
> > of the repos (probably the ones that were migrated last).
> >
> > How does one set the default branch?
>
> I had to put in tickets with Infra to do that back in December/Januaray. I would guess that it would have something to do with their puppet automation, but that’s totally a guess.
>
> -Rob
>
> >
> > On Mon, 6 May 2019 at 19:09, Rob Tompkins <[hidden email] <mailto:[hidden email]>> wrote:
> >>
> >> I wonder if the default branch, “trunk,” no longer exists and that’s what it’s trying to clone down onto. When I run the following it works:
> >>
> >> git clone --single-branch --branch master https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git> <https://gitbox.apache.org/repos/asf/commons-bcel.git <https://gitbox.apache.org/repos/asf/commons-bcel.git>>
> >>
> >> -Rob
> >>
> >>> On May 6, 2019, at 2:05 PM, Rob Tompkins <[hidden email]> wrote:
> >>>
> >>> looking now. -Rob
> >>>
> >>>> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]> wrote:
> >>>>
> >>>> Hi All:
> >>>>
> >>>> When I try a clean checkout of BCEL I get:
> >>>>
> >>>> C:\git>git clone https://gitbox.apache.org/repos/asf/commons-bcel.git
> >>>> Cloning into 'commons-bcel'...
> >>>> remote: Counting objects: 21585, done.
> >>>> remote: Compressing objects: 100% (2646/2646), done.
> >>>> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s, done.ing
> >>>> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
> >>>>
> >>>> Resolving deltas: 100% (14986/14986), done.
> >>>> warning: remote HEAD refers to nonexistent ref, unable to checkout.
> >>>>
> >>>> Ideas?
> >>>>
> >>>> Gary
> >>>
> >>
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email] <mailto:[hidden email]>
> > For additional commands, e-mail: [hidden email] <mailto:[hidden email]>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [bcel] broken repo?

garydgregory
Thank you Sebb! Watching the tix...

Gary

On Mon, May 6, 2019 at 3:36 PM sebb <[hidden email]> wrote:

> https://issues.apache.org/jira/browse/INFRA-18339
>
> On Mon, 6 May 2019 at 19:24, Rob Tompkins <[hidden email]> wrote:
> >
> >
> >
> > > On May 6, 2019, at 2:14 PM, sebb <[hidden email]> wrote:
> > >
> > > Same issue applies to commons-net and -daemon.
> > > However commons-io and -lang are OK.
> > >
> > > Looks like the default branch has not been set up correctly for some
> > > of the repos (probably the ones that were migrated last).
> > >
> > > How does one set the default branch?
> >
> > I had to put in tickets with Infra to do that back in December/Januaray.
> I would guess that it would have something to do with their puppet
> automation, but that’s totally a guess.
> >
> > -Rob
> >
> > >
> > > On Mon, 6 May 2019 at 19:09, Rob Tompkins <[hidden email] <mailto:
> [hidden email]>> wrote:
> > >>
> > >> I wonder if the default branch, “trunk,” no longer exists and that’s
> what it’s trying to clone down onto. When I run the following it works:
> > >>
> > >> git clone --single-branch --branch master
> https://gitbox.apache.org/repos/asf/commons-bcel.git <
> https://gitbox.apache.org/repos/asf/commons-bcel.git> <
> https://gitbox.apache.org/repos/asf/commons-bcel.git <
> https://gitbox.apache.org/repos/asf/commons-bcel.git>>
> > >>
> > >> -Rob
> > >>
> > >>> On May 6, 2019, at 2:05 PM, Rob Tompkins <[hidden email]> wrote:
> > >>>
> > >>> looking now. -Rob
> > >>>
> > >>>> On May 6, 2019, at 1:23 PM, Gary Gregory <[hidden email]>
> wrote:
> > >>>>
> > >>>> Hi All:
> > >>>>
> > >>>> When I try a clean checkout of BCEL I get:
> > >>>>
> > >>>> C:\git>git clone
> https://gitbox.apache.org/repos/asf/commons-bcel.git
> > >>>> Cloning into 'commons-bcel'...
> > >>>> remote: Counting objects: 21585, done.
> > >>>> remote: Compressing objects: 100% (2646/2646), done.
> > >>>> Receiving objects: 100% (21585/21585), 3.83 MiB | 4.36 MiB/s,
> done.ing
> > >>>> objects: 100% (21585/21585), 1.25 MiB | 2.46 MiB/s
> > >>>>
> > >>>> Resolving deltas: 100% (14986/14986), done.
> > >>>> warning: remote HEAD refers to nonexistent ref, unable to checkout.
> > >>>>
> > >>>> Ideas?
> > >>>>
> > >>>> Gary
> > >>>
> > >>
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email] <mailto:
> [hidden email]>
> > > For additional commands, e-mail: [hidden email] <mailto:
> [hidden email]>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>