[beanutils] 1.6.1 breaks backward compatibility?!?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[beanutils] 1.6.1 breaks backward compatibility?!?

Laurie Harper
I just upgraded from BeanUtils 1.6 to 1.6.1 and my project no longer
compiles :-( BeanUtilsBean and ConvertUtilsBean are no longer in the
distribution.

WTF? There's nothing about this in the release notes. Shouldn't a minor
point release be a drop-in replacement??

L.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [beanutils] 1.6.1 breaks backward compatibility?!?

Simon Kitching
On Tue, 2005-06-07 at 23:22 -0400, Laurie Harper wrote:
> I just upgraded from BeanUtils 1.6 to 1.6.1 and my project no longer
> compiles :-( BeanUtilsBean and ConvertUtilsBean are no longer in the
> distribution.
>
> WTF? There's nothing about this in the release notes. Shouldn't a minor
> point release be a drop-in replacement??

I think you may have got mixed up.

As far as I know, the commons-beanutils 1.6 series never had
BeanUtilsBean or ConvertUtilsBean. These were first introduced in 1.7.

Regards,

Simon



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [beanutils] 1.6.1 breaks backward compatibility?!?

Laurie Harper
Not according to my build:

[laurie@Lauries-Computer]$ jar xf ../commons-beanutils.jar
[laurie@Lauries-Computer]$ cat META-INF/MANIFEST.MF
Manifest-Version: 1.0
Ant-Version: Apache Ant 1.5.3
Created-By: 1.4.1_01-b01 (Sun Microsystems Inc.)
Extension-Name: org.apache.commons.beanutils
Specification-Title: Jakarta Commons Beanutils
Specification-Vendor: Apache Software Foundation
Specification-Version: 1.6
Implementation-Title: org.apache.commons.beanutils
Implementation-Vendor: Apache Software Foundation
Implementation-Version: 1.6

[laurie@Lauries-Computer]$ ls org/apache/commons/beanutils/*UtilsBean*
org/apache/commons/beanutils/BeanUtilsBean$1.class
org/apache/commons/beanutils/BeanUtilsBean.class
org/apache/commons/beanutils/ConvertUtilsBean.class
org/apache/commons/beanutils/PropertyUtilsBean.class


However, trying to trace through the 1.6 code in my debugger, it doesn't
appear to match up with the code that's executing. I'm guessing the 1.7
(pre)release has an incorrect manifest?

L.

Simon Kitching wrote:

> On Tue, 2005-06-07 at 23:22 -0400, Laurie Harper wrote:
>
>>I just upgraded from BeanUtils 1.6 to 1.6.1 and my project no longer
>>compiles :-( BeanUtilsBean and ConvertUtilsBean are no longer in the
>>distribution.
>>
>>WTF? There's nothing about this in the release notes. Shouldn't a minor
>>point release be a drop-in replacement??
>
>
> I think you may have got mixed up.
>
> As far as I know, the commons-beanutils 1.6 series never had
> BeanUtilsBean or ConvertUtilsBean. These were first introduced in 1.7.
>
> Regards,
>
> Simon


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [beanutils] 1.6.1 breaks backward compatibility?!?

Simon Kitching
On Tue, 2005-06-07 at 23:56 -0400, Laurie Harper wrote:
> However, trying to trace through the 1.6 code in my debugger, it doesn't
> appear to match up with the code that's executing. I'm guessing the 1.7
> (pre)release has an incorrect manifest?

That's right. It's a known issue - and in the 1.7 release, not just the
pre-release. You're almost certainly running 1.7 already, despite what
the manifest says.

Regards,

Simon


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [beanutils] 1.6.1 breaks backward compatibility?!?

Laurie Harper
Simon Kitching wrote:
> On Tue, 2005-06-07 at 23:56 -0400, Laurie Harper wrote:
>>However, trying to trace through the 1.6 code in my debugger, it doesn't
>>appear to match up with the code that's executing. I'm guessing the 1.7
>>(pre)release has an incorrect manifest?
>
> That's right. It's a known issue - and in the 1.7 release, not just the
> pre-release. You're almost certainly running 1.7 already, despite what
> the manifest says.

Yup, that turned out to be it. Sorry for the FUD (and a big slap upside
the head for whoever build the release ;-) Now to get back to tracking
down this NullPointerException. It's only twelve, the night is young!

Thanks for the speedy responses.

L.


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]