commons-crypto JDK 11 compatibility

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

commons-crypto JDK 11 compatibility

Dinesh J
Hello community,

Is there a plan for releasing a JDK 11 compatible version of commons-crypto.

Appreciate your help.

--
Thanks,
Dinesh
Reply | Threaded
Open this post in threaded view
|

Re: commons-crypto JDK 11 compatibility

garydgregory
How is it not compatible ATM?

Gary

On Sat, May 25, 2019, 05:15 Dinesh J <[hidden email]> wrote:

> Hello community,
>
> Is there a plan for releasing a JDK 11 compatible version of
> commons-crypto.
>
> Appreciate your help.
>
> --
> Thanks,
> Dinesh
>
Reply | Threaded
Open this post in threaded view
|

Re: commons-crypto JDK 11 compatibility

Alex Remily
It won't *build* on JDK 11 because the build script uses "javah" as opposed
to "javac -h", and Java 8 was the last JDK to support javah.  I can't speak
to binary compatibility because I haven't tested it on anything other than
Java 8.  I don't know of any specific reason why it wouldn't be binary
compatible with 11; the best advice I can give is to pull it out of the
Maven repo and try it.

The question of full support for JDK 11 is something I've recently posed to
the community in my pending pull request.

https://github.com/apache/commons-crypto/pull/94

Alex

On Sat, May 25, 2019 at 8:29 AM Gary Gregory <[hidden email]> wrote:

> How is it not compatible ATM?
>
> Gary
>
> On Sat, May 25, 2019, 05:15 Dinesh J <[hidden email]> wrote:
>
> > Hello community,
> >
> > Is there a plan for releasing a JDK 11 compatible version of
> > commons-crypto.
> >
> > Appreciate your help.
> >
> > --
> > Thanks,
> > Dinesh
> >
>