[compress] HasCharset is a bad name

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[compress] HasCharset is a bad name

garydgregory
Hi All,

The new interface name HasCharset is pretty bad IMO.

CharsetProvider is the obvious (to me) better name even though there
already is a class called java.nio.charset.spi.CharsetProvider.

Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?

Gary
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Jeremy Gustie
CharsetSupplier?

-Jeremy

> On Jul 5, 2017, at 1:14 PM, Gary Gregory <[hidden email]> wrote:
>
> Hi All,
>
> The new interface name HasCharset is pretty bad IMO.
>
> CharsetProvider is the obvious (to me) better name even though there
> already is a class called java.nio.charset.spi.CharsetProvider.
>
> Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?
>
> Gary


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

garydgregory
Supplied and Provider are both good.

Gary

On Wed, Jul 5, 2017 at 10:22 AM, Jeremy Gustie <
[hidden email]> wrote:

> CharsetSupplier?
>
> -Jeremy
>
> > On Jul 5, 2017, at 1:14 PM, Gary Gregory <[hidden email]> wrote:
> >
> > Hi All,
> >
> > The new interface name HasCharset is pretty bad IMO.
> >
> > CharsetProvider is the obvious (to me) better name even though there
> > already is a class called java.nio.charset.spi.CharsetProvider.
> >
> > Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?
> >
> > Gary
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Stefan Bodewig
In reply to this post by garydgregory
On 2017-07-05, Gary Gregory wrote:

> The new interface name HasCharset is pretty bad IMO.

fair enough.

> CharsetProvider is the obvious (to me) better name even though there
> already is a class called java.nio.charset.spi.CharsetProvider.

I don't think so, this really is a marker interface for classes also
implementing ZipEncoding (Simon didn't want to extend the existing
interface).

Hmm, maybe we could make it extend ZipEncoding and call it something
like ZipEncodingWithCharset?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

garydgregory
I renamed HasCharset to CharsetAccessor (until someone comes up with a
better name before 1.15.)

Gary

On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]> wrote:

> On 2017-07-05, Gary Gregory wrote:
>
> > The new interface name HasCharset is pretty bad IMO.
>
> fair enough.
>
> > CharsetProvider is the obvious (to me) better name even though there
> > already is a class called java.nio.charset.spi.CharsetProvider.
>
> I don't think so, this really is a marker interface for classes also
> implementing ZipEncoding (Simon didn't want to extend the existing
> interface).
>
> Hmm, maybe we could make it extend ZipEncoding and call it something
> like ZipEncodingWithCharset?
>
> Stefan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Matt Sicker
Charsetable? CharsetAware? ;P

On 10 July 2017 at 17:03, Gary Gregory <[hidden email]> wrote:

> I renamed HasCharset to CharsetAccessor (until someone comes up with a
> better name before 1.15.)
>
> Gary
>
> On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]>
> wrote:
>
> > On 2017-07-05, Gary Gregory wrote:
> >
> > > The new interface name HasCharset is pretty bad IMO.
> >
> > fair enough.
> >
> > > CharsetProvider is the obvious (to me) better name even though there
> > > already is a class called java.nio.charset.spi.CharsetProvider.
> >
> > I don't think so, this really is a marker interface for classes also
> > implementing ZipEncoding (Simon didn't want to extend the existing
> > interface).
> >
> > Hmm, maybe we could make it extend ZipEncoding and call it something
> > like ZipEncodingWithCharset?
> >
> > Stefan
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>



--
Matt Sicker <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

garydgregory
On Mon, Jul 10, 2017 at 3:04 PM, Matt Sicker <[hidden email]> wrote:

> Charsetable? CharsetAware? ;P
>

Chartreuse? ChartreuseDeParme?

Gary


>
> On 10 July 2017 at 17:03, Gary Gregory <[hidden email]> wrote:
>
> > I renamed HasCharset to CharsetAccessor (until someone comes up with a
> > better name before 1.15.)
> >
> > Gary
> >
> > On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]>
> > wrote:
> >
> > > On 2017-07-05, Gary Gregory wrote:
> > >
> > > > The new interface name HasCharset is pretty bad IMO.
> > >
> > > fair enough.
> > >
> > > > CharsetProvider is the obvious (to me) better name even though there
> > > > already is a class called java.nio.charset.spi.CharsetProvider.
> > >
> > > I don't think so, this really is a marker interface for classes also
> > > implementing ZipEncoding (Simon didn't want to extend the existing
> > > interface).
> > >
> > > Hmm, maybe we could make it extend ZipEncoding and call it something
> > > like ZipEncodingWithCharset?
> > >
> > > Stefan
> > >
> > > ---------------------------------------------------------------------
> > > To unsubscribe, e-mail: [hidden email]
> > > For additional commands, e-mail: [hidden email]
> > >
> > >
> >
>
>
>
> --
> Matt Sicker <[hidden email]>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Matt Sicker
The colour, dish, or liqueur? Or mountains apparently.

On 10 July 2017 at 17:53, Gary Gregory <[hidden email]> wrote:

> On Mon, Jul 10, 2017 at 3:04 PM, Matt Sicker <[hidden email]> wrote:
>
> > Charsetable? CharsetAware? ;P
> >
>
> Chartreuse? ChartreuseDeParme?
>
> Gary
>
>
> >
> > On 10 July 2017 at 17:03, Gary Gregory <[hidden email]> wrote:
> >
> > > I renamed HasCharset to CharsetAccessor (until someone comes up with a
> > > better name before 1.15.)
> > >
> > > Gary
> > >
> > > On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]>
> > > wrote:
> > >
> > > > On 2017-07-05, Gary Gregory wrote:
> > > >
> > > > > The new interface name HasCharset is pretty bad IMO.
> > > >
> > > > fair enough.
> > > >
> > > > > CharsetProvider is the obvious (to me) better name even though
> there
> > > > > already is a class called java.nio.charset.spi.CharsetProvider.
> > > >
> > > > I don't think so, this really is a marker interface for classes also
> > > > implementing ZipEncoding (Simon didn't want to extend the existing
> > > > interface).
> > > >
> > > > Hmm, maybe we could make it extend ZipEncoding and call it something
> > > > like ZipEncodingWithCharset?
> > > >
> > > > Stefan
> > > >
> > > > ------------------------------------------------------------
> ---------
> > > > To unsubscribe, e-mail: [hidden email]
> > > > For additional commands, e-mail: [hidden email]
> > > >
> > > >
> > >
> >
> >
> >
> > --
> > Matt Sicker <[hidden email]>
> >
>



--
Matt Sicker <[hidden email]>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

garydgregory
the book! ;-)

On Mon, Jul 10, 2017 at 5:29 PM, Matt Sicker <[hidden email]> wrote:

> The colour, dish, or liqueur? Or mountains apparently.
>
> On 10 July 2017 at 17:53, Gary Gregory <[hidden email]> wrote:
>
> > On Mon, Jul 10, 2017 at 3:04 PM, Matt Sicker <[hidden email]> wrote:
> >
> > > Charsetable? CharsetAware? ;P
> > >
> >
> > Chartreuse? ChartreuseDeParme?
> >
> > Gary
> >
> >
> > >
> > > On 10 July 2017 at 17:03, Gary Gregory <[hidden email]> wrote:
> > >
> > > > I renamed HasCharset to CharsetAccessor (until someone comes up with
> a
> > > > better name before 1.15.)
> > > >
> > > > Gary
> > > >
> > > > On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]>
> > > > wrote:
> > > >
> > > > > On 2017-07-05, Gary Gregory wrote:
> > > > >
> > > > > > The new interface name HasCharset is pretty bad IMO.
> > > > >
> > > > > fair enough.
> > > > >
> > > > > > CharsetProvider is the obvious (to me) better name even though
> > there
> > > > > > already is a class called java.nio.charset.spi.CharsetProvider.
> > > > >
> > > > > I don't think so, this really is a marker interface for classes
> also
> > > > > implementing ZipEncoding (Simon didn't want to extend the existing
> > > > > interface).
> > > > >
> > > > > Hmm, maybe we could make it extend ZipEncoding and call it
> something
> > > > > like ZipEncodingWithCharset?
> > > > >
> > > > > Stefan
> > > > >
> > > > > ------------------------------------------------------------
> > ---------
> > > > > To unsubscribe, e-mail: [hidden email]
> > > > > For additional commands, e-mail: [hidden email]
> > > > >
> > > > >
> > > >
> > >
> > >
> > >
> > > --
> > > Matt Sicker <[hidden email]>
> > >
> >
>
>
>
> --
> Matt Sicker <[hidden email]>
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Simon Spero
In reply to this post by garydgregory
Since it's an interface, I could change it to IHasACharset?

Or If you prefer I  could rename it to YouGiveLove?  (Lucky Millenials- you
aren't headsonged)

The name follows a pattern for interfaces of this sort, which are basically
retrofit markers for the presence of property, (with associated getters).
I've seen it used in other projects, but it might be bleed through from
some  OWL / RDF patterns.

I'm not in love with the pattern but it required the least thought :)

(java 8 makes this sort of interface moot, as the accessor can be added as
a default method. It is even be a candidate for the proper use of Optional.
)

On Jul 5, 2017 1:14 PM, "Gary Gregory" <[hidden email]> wrote:

Hi All,

The new interface name HasCharset is pretty bad IMO.

CharsetProvider is the obvious (to me) better name even though there
already is a class called java.nio.charset.spi.CharsetProvider.

Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?

Gary
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Amey Jadiye
In reply to this post by garydgregory
HasCharset is certainly bad and also CharsetAccessor sounds like class name
not as Interface , I think Charsetable CharsetAccesable or CharsetAware Is
better as Interface name.

Regards,
Amey

On Tue, Jul 11, 2017, 3:33 AM Gary Gregory <[hidden email]> wrote:

> I renamed HasCharset to CharsetAccessor (until someone comes up with a
> better name before 1.15.)
>
> Gary
>
> On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <[hidden email]>
> wrote:
>
> > On 2017-07-05, Gary Gregory wrote:
> >
> > > The new interface name HasCharset is pretty bad IMO.
> >
> > fair enough.
> >
> > > CharsetProvider is the obvious (to me) better name even though there
> > > already is a class called java.nio.charset.spi.CharsetProvider.
> >
> > I don't think so, this really is a marker interface for classes also
> > implementing ZipEncoding (Simon didn't want to extend the existing
> > interface).
> >
> > Hmm, maybe we could make it extend ZipEncoding and call it something
> > like ZipEncodingWithCharset?
> >
> > Stefan
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: [hidden email]
> > For additional commands, e-mail: [hidden email]
> >
> >
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

Benedikt Ritter-4
In reply to this post by Simon Spero
Hello,

> Am 11.07.2017 um 06:55 schrieb Simon Spero <[hidden email]>:
>
> Since it's an interface, I could change it to IHasACharset?
>
> Or If you prefer I  could rename it to YouGiveLove?  (Lucky Millenials- you
> aren't headsonged)

I recommend to leave this kind of irony out of mailing list communication. This is probably your personal style of communicating, but it is hard to understand in remote communication with people from other cultural backgrounds. It makes communication more boring to remove this kind of sugar, but it helps to avoid misunderstandings.

Cheers,
Benedikt

>
> The name follows a pattern for interfaces of this sort, which are basically
> retrofit markers for the presence of property, (with associated getters).
> I've seen it used in other projects, but it might be bleed through from
> some  OWL / RDF patterns.
>
> I'm not in love with the pattern but it required the least thought :)
>
> (java 8 makes this sort of interface moot, as the accessor can be added as
> a default method. It is even be a candidate for the proper use of Optional.
> )
>
> On Jul 5, 2017 1:14 PM, "Gary Gregory" <[hidden email]> wrote:
>
> Hi All,
>
> The new interface name HasCharset is pretty bad IMO.
>
> CharsetProvider is the obvious (to me) better name even though there
> already is a class called java.nio.charset.spi.CharsetProvider.
>
> Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?
>
> Gary


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [compress] HasCharset is a bad name

garydgregory
On Wed, Jul 12, 2017 at 6:32 AM, Benedikt Ritter <[hidden email]> wrote:

> Hello,
>
> > Am 11.07.2017 um 06:55 schrieb Simon Spero <[hidden email]>:
> >
> > Since it's an interface, I could change it to IHasACharset?
> >
> > Or If you prefer I  could rename it to YouGiveLove?  (Lucky Millenials-
> you
> > aren't headsonged)
>
> I recommend to leave this kind of irony out of mailing list communication.
> This is probably your personal style of communicating, but it is hard to
> understand in remote communication with people from other cultural
> backgrounds. It makes communication more boring to remove this kind of
> sugar, but it helps to avoid misunderstandings.
>

I suppose Slack would work...

G

>
> Cheers,
> Benedikt
>
> >
> > The name follows a pattern for interfaces of this sort, which are
> basically
> > retrofit markers for the presence of property, (with associated getters).
> > I've seen it used in other projects, but it might be bleed through from
> > some  OWL / RDF patterns.
> >
> > I'm not in love with the pattern but it required the least thought :)
> >
> > (java 8 makes this sort of interface moot, as the accessor can be added
> as
> > a default method. It is even be a candidate for the proper use of
> Optional.
> > )
> >
> > On Jul 5, 2017 1:14 PM, "Gary Gregory" <[hidden email]> wrote:
> >
> > Hi All,
> >
> > The new interface name HasCharset is pretty bad IMO.
> >
> > CharsetProvider is the obvious (to me) better name even though there
> > already is a class called java.nio.charset.spi.CharsetProvider.
> >
> > Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?
> >
> > Gary
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
Loading...