[compress] Towards a 1.20 Release

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[compress] Towards a 1.20 Release

Stefan Bodewig
Hi all

I'm trying to make the builds work on Jenkins and intend to cut a new
COmpress release soon. Right now I don't see any chance of understanding
COMPRESS-494 or COMPRESS-500 and would address 501 and 502 after the
release.

Also I'd like to postpone the pack200 issue and mention that Compress
1.20 will not build on Java 14 and we we'd be discussing how to deal
with it for 1.21.

Anything that must go into the next release? Any other reason why I
should not proceeed?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [compress] Towards a 1.20 Release

garydgregory
I say go for it.

There is only one Javadoc warning building with Java 7 which would be nice
to fix:

[WARNING]
C:\git\commons-compress\src\main\java\org\apache\commons\compress\archivers\tar\TarArchiveInputStream.java:678:
warning - @return tag has no arguments.

Gary


On Sat, Jan 25, 2020 at 9:09 AM Stefan Bodewig <[hidden email]> wrote:

> Hi all
>
> I'm trying to make the builds work on Jenkins and intend to cut a new
> COmpress release soon. Right now I don't see any chance of understanding
> COMPRESS-494 or COMPRESS-500 and would address 501 and 502 after the
> release.
>
> Also I'd like to postpone the pack200 issue and mention that Compress
> 1.20 will not build on Java 14 and we we'd be discussing how to deal
> with it for 1.21.
>
> Anything that must go into the next release? Any other reason why I
> should not proceeed?
>
> Stefan
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>