Quantcast

[daemon]

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[daemon]

Vadym Slavov
Hello,

I have a question regarding jsvc daemon:

I have installed successfully the server apache-tomcat-9.0.0.M11 on my «macOS Sierra» and It works, I can start and stop it.
I also installed your jsvc daemon and tried to start the tomcat server as suggested in http://tomcat.apache.org/tomcat-9.0-doc/setup.html with it but unfortunately I get error messages. It doesn’t find neither VM nor JVM library file although the $JAVA_HOME path is correct.

I have libraries in /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../MacOS/libjli.dylib
but not how required in /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../Libraries/libserver.dylib
Can you please help if I am wrong or there is a bug in jsvc?

I send you my run-script and error-messages.  


Best regards,

Vadym Slavov



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [daemon]

Benedikt Ritter-4
Hello Vadym,

> Am 18.05.2017 um 17:50 schrieb Vadym Slavov <[hidden email]>:
>
> Hello,
>
> I have a question regarding jsvc daemon:
>
> I have installed successfully the server apache-tomcat-9.0.0.M11 on my «macOS Sierra» and It works, I can start and stop it.
> I also installed your jsvc daemon and tried to start the tomcat server as suggested in http://tomcat.apache.org/tomcat-9.0-doc/setup.html with it but unfortunately I get error messages. It doesn’t find neither VM nor JVM library file although the $JAVA_HOME path is correct.
>
> I have libraries in /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../MacOS/libjli.dylib
> but not how required in /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../Libraries/libserver.dylib
> Can you please help if I am wrong or there is a bug in jsvc?
>
> I send you my run-script and error-messages.  

This mailing list does not accept file attachments. Can you please provide the relevant files for example via pastbin?

Thank you!
Benedikt

>
>
> Best regards,
>
> Vadym Slavov
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: [daemon]

Ian Emmons-2
In reply to this post by Vadym Slavov
On 2017-05-18 17:50, Vadym Slavov wrote:

> Hello,
>
> I have a question regarding jsvc daemon:
>
> I have installed successfully the server apache-tomcat-9.0.0.M11 on my
> «macOS Sierra» and It works, I can start and stop it.
> I also installed your jsvc daemon and tried to start the tomcat server
> as suggested in http://tomcat.apache.org/tomcat-9.0-doc/setup.html
> with it but unfortunately I get error messages. It doesn’t find
> neither VM nor JVM library file although the $JAVA_HOME path is
> correct.
>
> I have libraries in
> /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../MacOS/libjli.dylib
> but not how required in
> /Library/Java/JavaVirtualMachines/jdk1.8.0_131.jdk/Contents/Home/../Libraries/libserver.dylib
> Can you please help if I am wrong or there is a bug in jsvc?
>
> I send you my run-script and error-messages.
>
>
> Best regards,
>
> Vadym Slavov

Vadym,

The current binaries for [daemon] are version 1.0.15, which is quite
old.  They contain a bug [1] that prevents jsvc from finding the correct
JVM on MacOS.  I submitted a patch for this some time ago, and I believe
that it has been merged into the code base.  However, new binaries have
not been released since then.  If you download the latest source and
build it yourself, it should work with Java 8.

Cheers,

Ian Emmons

[1] https://issues.apache.org/jira/browse/DAEMON-281

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Loading...