[jira] [Commented] (CHAIN-83) Rename o.a.c.chain.generic package to o.a.c.chain.common

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

[jira] [Commented] (CHAIN-83) Rename o.a.c.chain.generic package to o.a.c.chain.common

ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/CHAIN-83?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13683735#comment-13683735 ]

Simone Tripodi commented on CHAIN-83:

_core_ and _base_ sound better to me.

_common_ sounds a "must to include", when users could decide to use different chain/commands implementations, _util_ sounds a utility package, so I wouldn't take these names in consideration for the that APIs set.

It is also important that there is coherence between the module directory name, the {{artifactId}} in the pom and the java package, i.e.

 * core : commons-chain2-core : o.a.c.chain2.core


 * base : commons-chain2-base : o.a.c.chain2.base

> Rename o.a.c.chain.generic package to o.a.c.chain.common
> --------------------------------------------------------
>                 Key: CHAIN-83
>                 URL: https://issues.apache.org/jira/browse/CHAIN-83
>             Project: Commons Chain
>          Issue Type: Improvement
>    Affects Versions: 2.0
>            Reporter: Benedikt Ritter
>            Assignee: Benedikt Ritter
>            Priority: Minor
>             Fix For: 2.0
> As discussed on the ML, the name generic is a bit confusing given that fact that chain makes extensive use of Java Generics. The package o.a.c.chain.generic should therefore be renamed to o.a.c.chain.common

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira