[jira] [Commented] (GEOMETRY-25) Class "Geometry"

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view

[jira] [Commented] (GEOMETRY-25) Class "Geometry"

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/GEOMETRY-25?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16764373#comment-16764373 ]

Gilles commented on GEOMETRY-25:

* {{ZERO_PI}} is redundant (0 is "0" in source code). :-)
* {{MINUS_PI}} is used once (in {{QuaternionRotation}}) and in unit tests
* {{MINUS_PI}}, {{MINUS_TWO_PI}} are only used in unit tests of class {{Geometry}}
* {{TWO_PI}} is only used in a few classes of module {{commons-geometry-spherical}} and in unit tests
* {{HALF_PI}}, {{THREE_HALVES_PI}} are only used in unit tests

IMO, the balance is not favorable to keeping them.

bq. find myself writing them frequently

Others might prefer a different syntax (e.g. "PI_3_2")...
I doubt that the {{Geometry}} class would become a standard place for accessing these values.

> Class "Geometry"
> ----------------
>                 Key: GEOMETRY-25
>                 URL: https://issues.apache.org/jira/browse/GEOMETRY-25
>             Project: Apache Commons Geometry
>          Issue Type: Task
>          Components: core
>            Reporter: Gilles
>            Priority: Major
>             Fix For: 1.0
> Class only holds trivial constants.
> Better move to an "internal" package.

This message was sent by Atlassian JIRA