[jira] [Created] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

ASF GitHub Bot (Jira)
Remove "getData" in "RealVector" (package "o.a.c.m.linear")
-----------------------------------------------------------

                 Key: MATH-663
                 URL: https://issues.apache.org/jira/browse/MATH-663
             Project: Commons Math
          Issue Type: Task
            Reporter: Gilles
            Assignee: Gilles
            Priority: Trivial
             Fix For: 3.0


"getData()" is redundant with "toArray()".


--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13100232#comment-13100232 ]

Gilles commented on MATH-663:
-----------------------------

"getData()" removed in revision 1166629.

Note: The same change should perhaps be performed for the "FieldVector" family.

> Remove "getData" in "RealVector" (package "o.a.c.m.linear")
> -----------------------------------------------------------
>
>                 Key: MATH-663
>                 URL: https://issues.apache.org/jira/browse/MATH-663
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> "getData()" is redundant with "toArray()".

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13100241#comment-13100241 ]

S├ębastien Brisard commented on MATH-663:
----------------------------------------

And also to {{RealMatrix}} and {{FieldMatrix}} (?)

> Remove "getData" in "RealVector" (package "o.a.c.m.linear")
> -----------------------------------------------------------
>
>                 Key: MATH-663
>                 URL: https://issues.apache.org/jira/browse/MATH-663
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> "getData()" is redundant with "toArray()".

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-663?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13100288#comment-13100288 ]

Gilles commented on MATH-663:
-----------------------------

Maybe, maybe not. Keeping "toArray" (in preference to "getData") was to increase similarity with standard Java classes. As there is no such pull for matrix classes, we might keep the existing method.


> Remove "getData" in "RealVector" (package "o.a.c.m.linear")
> -----------------------------------------------------------
>
>                 Key: MATH-663
>                 URL: https://issues.apache.org/jira/browse/MATH-663
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> "getData()" is redundant with "toArray()".

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (MATH-663) Remove "getData" in "RealVector" (package "o.a.c.m.linear")

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

     [ https://issues.apache.org/jira/browse/MATH-663?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gilles resolved MATH-663.
-------------------------

    Resolution: Fixed

> Remove "getData" in "RealVector" (package "o.a.c.m.linear")
> -----------------------------------------------------------
>
>                 Key: MATH-663
>                 URL: https://issues.apache.org/jira/browse/MATH-663
>             Project: Commons Math
>          Issue Type: Task
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.0
>
>
> "getData()" is redundant with "toArray()".

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira