[jira] [Created] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing

Gilles Sadowski (Jira)
Sébastien Brisard created MATH-791:
--------------------------------------

             Summary: GammaDistribution.getAlpha() and getBeta() are confusing
                 Key: MATH-791
                 URL: https://issues.apache.org/jira/browse/MATH-791
             Project: Commons Math
          Issue Type: Improvement
    Affects Versions: 3.1, 4.0
            Reporter: Sébastien Brisard
            Assignee: Sébastien Brisard
            Priority: Minor


As discussed on the mailing list
{quote}
Some methods in {{o.a.c.m3.distribution.GammaDistribution}} are ill-named. Indeed, the class javadoc explicitly refers to the Wikipedia page. In this page, the shape parameter is named alpha and the scale parameter is 1 / beta
(inverse of beta), while in the current implementation, the shape parameter is named alpha, and the scale parameter is named beta (not 1 / beta !!!). This might be confusing. Looking at other web pages, I see there is apparently no consensus on the naming of shape and scale
parameters. The problem lies with the accessors, which are
{{double getAlpha()}}
{{double getBeta()}}

I think these accessors can lead to confusion. I would therefore propose to deprecate them, and replace them with
{{double getShape()}}
{{double getScale()}}
{quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing

Gilles Sadowski (Jira)

    [ https://issues.apache.org/jira/browse/MATH-791?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13280754#comment-13280754 ]

Sébastien Brisard commented on MATH-791:
----------------------------------------

Renamed class variables {{alpha}} and {{beta}} in {{r1341318}}.
               

> GammaDistribution.getAlpha() and getBeta() are confusing
> --------------------------------------------------------
>
>                 Key: MATH-791
>                 URL: https://issues.apache.org/jira/browse/MATH-791
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.1, 4.0
>            Reporter: Sébastien Brisard
>            Assignee: Sébastien Brisard
>            Priority: Minor
>
> As discussed on the mailing list
> {quote}
> Some methods in {{o.a.c.m3.distribution.GammaDistribution}} are ill-named. Indeed, the class javadoc explicitly refers to the Wikipedia page. In this page, the shape parameter is named alpha and the scale parameter is 1 / beta
> (inverse of beta), while in the current implementation, the shape parameter is named alpha, and the scale parameter is named beta (not 1 / beta !!!). This might be confusing. Looking at other web pages, I see there is apparently no consensus on the naming of shape and scale
> parameters. The problem lies with the accessors, which are
> {{double getAlpha()}}
> {{double getBeta()}}
> I think these accessors can lead to confusion. I would therefore propose to deprecate them, and replace them with
> {{double getShape()}}
> {{double getScale()}}
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing

Gilles Sadowski (Jira)
In reply to this post by Gilles Sadowski (Jira)

    [ https://issues.apache.org/jira/browse/MATH-791?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13282883#comment-13282883 ]

Sébastien Brisard commented on MATH-791:
----------------------------------------

New accessors have been defined in {{r1342404}}.
               

> GammaDistribution.getAlpha() and getBeta() are confusing
> --------------------------------------------------------
>
>                 Key: MATH-791
>                 URL: https://issues.apache.org/jira/browse/MATH-791
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.1, 4.0
>            Reporter: Sébastien Brisard
>            Assignee: Sébastien Brisard
>            Priority: Minor
>
> As discussed on the mailing list
> {quote}
> Some methods in {{o.a.c.m3.distribution.GammaDistribution}} are ill-named. Indeed, the class javadoc explicitly refers to the Wikipedia page. In this page, the shape parameter is named alpha and the scale parameter is 1 / beta
> (inverse of beta), while in the current implementation, the shape parameter is named alpha, and the scale parameter is named beta (not 1 / beta !!!). This might be confusing. Looking at other web pages, I see there is apparently no consensus on the naming of shape and scale
> parameters. The problem lies with the accessors, which are
> {{double getAlpha()}}
> {{double getBeta()}}
> I think these accessors can lead to confusion. I would therefore propose to deprecate them, and replace them with
> {{double getShape()}}
> {{double getScale()}}
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (MATH-791) GammaDistribution.getAlpha() and getBeta() are confusing

Gilles Sadowski (Jira)
In reply to this post by Gilles Sadowski (Jira)

     [ https://issues.apache.org/jira/browse/MATH-791?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Sébastien Brisard resolved MATH-791.
------------------------------------

       Resolution: Fixed
    Fix Version/s: 3.1

Fixed. See also MATH-796.
               

> GammaDistribution.getAlpha() and getBeta() are confusing
> --------------------------------------------------------
>
>                 Key: MATH-791
>                 URL: https://issues.apache.org/jira/browse/MATH-791
>             Project: Commons Math
>          Issue Type: Improvement
>    Affects Versions: 3.1, 4.0
>            Reporter: Sébastien Brisard
>            Assignee: Sébastien Brisard
>            Priority: Minor
>             Fix For: 3.1
>
>
> As discussed on the mailing list
> {quote}
> Some methods in {{o.a.c.m3.distribution.GammaDistribution}} are ill-named. Indeed, the class javadoc explicitly refers to the Wikipedia page. In this page, the shape parameter is named alpha and the scale parameter is 1 / beta
> (inverse of beta), while in the current implementation, the shape parameter is named alpha, and the scale parameter is named beta (not 1 / beta !!!). This might be confusing. Looking at other web pages, I see there is apparently no consensus on the naming of shape and scale
> parameters. The problem lies with the accessors, which are
> {{double getAlpha()}}
> {{double getBeta()}}
> I think these accessors can lead to confusion. I would therefore propose to deprecate them, and replace them with
> {{double getShape()}}
> {{double getScale()}}
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira