[jira] [Created] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Created] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
Gilles created MATH-839:
---------------------------

             Summary: In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
                 Key: MATH-839
                 URL: https://issues.apache.org/jira/browse/MATH-839
             Project: Commons Math
          Issue Type: Task
    Affects Versions: 3.0
            Reporter: Gilles
            Assignee: Gilles
            Priority: Trivial
             Fix For: 3.1, 4.0


Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
Cf. http://en.wikipedia.org/wiki/Probability_density_function

The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428655#comment-13428655 ]

Gilles commented on MATH-839:
-----------------------------

Deprecated "cumulativeProbability(double,double)" in revision 1369381.

               

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428665#comment-13428665 ]

Dennis Hendriks commented on MATH-839:
--------------------------------------

This change has been discussed on the dev list, see http://apache-commons.680414.n4.nabble.com/Math-Package-quot-o-a-c-m-distribution-quot-td4637374.html#none

Steps to take are:
(x) add new method (3.1)
(/) deprecate old method (3.1) done in rev 1369381
(x) move impl to new method (3.1)
(x) redirect old method to new method (3.1)
(x) remove old method (4.0)

That is, we can do all the work for 3.1, except remove the old/deprecated 'cumulativeProbability' method.
               

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428664#comment-13428664 ]

Gilles commented on MATH-839:
-----------------------------

Modified {{NormalDistribution}} and {{LogNormalDistribution}} in revision 1369415.
               

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428668#comment-13428668 ]

Gilles commented on MATH-839:
-----------------------------

bq. we can do all the work for 3.1

No. The new method cannot be added to the {{RealDistribution}} interface as it would break backwards compatibility.
For this reason, some unit tests also cannot be updated to not use the deprecated method (see revision 1369420).

What can be done for 3.1, has been done:
(/) Add new method to {{AbstractRealDistribution}} and to the implementations that override it.
(/) Redirect deprecated method to the new method.

               

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

    [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13428991#comment-13428991 ]

Dennis Hendriks commented on MATH-839:
--------------------------------------

bq. The new method cannot be added to the RealDistribution interface as it would break backwards compatibility.

Yes, you're right.
               

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 3.1, 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (MATH-839) In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

ASF GitHub Bot (Jira)
In reply to this post by ASF GitHub Bot (Jira)

     [ https://issues.apache.org/jira/browse/MATH-839?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Gilles updated MATH-839:
------------------------

    Fix Version/s:     (was: 3.1)
   

> In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"
> ---------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MATH-839
>                 URL: https://issues.apache.org/jira/browse/MATH-839
>             Project: Commons Math
>          Issue Type: Task
>    Affects Versions: 3.0
>            Reporter: Gilles
>            Assignee: Gilles
>            Priority: Trivial
>              Labels: api-change
>             Fix For: 4.0
>
>
> Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
> Cf. http://en.wikipedia.org/wiki/Probability_density_function
> The method currently named "cumulativeProbability(double,double)" in fact provides the _probability_ of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira