[jira] [Resolved] (MATH-381) inconsistency for methods names within StepInterpolator and StepInterpolatorWithJacobians

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (MATH-381) inconsistency for methods names within StepInterpolator and StepInterpolatorWithJacobians

Gilles (Jira)

     [ https://issues.apache.org/jira/browse/MATH-381?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Luc Maisonobe resolved MATH-381.
--------------------------------

    Resolution: Fixed

Fixed in subversion repository as of r1176745
               

> inconsistency for methods names within StepInterpolator and StepInterpolatorWithJacobians
> -----------------------------------------------------------------------------------------
>
>                 Key: MATH-381
>                 URL: https://issues.apache.org/jira/browse/MATH-381
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 2.1
>            Reporter: Pascal Parraud
>            Priority: Trivial
>             Fix For: 3.0
>
>
> There is some inconstency in methods naming :
> getInterpolatedY and getInterpolatedYDot in StepInterpolatorWithJacobians do the same as getInterpolatedState and getInterpolatedDerivatives in StepInterpolator, so it will be better if they would have the same name.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira