[lang] Ready for 3.9???

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[lang] Ready for 3.9???

Rob Tompkins
Just curious if we want to send 3.9 out? Build on java 11 targeting java 8?

-Rob

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [lang] Ready for 3.9???

Bernd Eckenfels
I know that the new release flag is supposed to be better in keeping runtime API versions separate, do we know it works?

It was a risk in the past to not use the target Java version (or at least the boot classpath), do you think it’s needed? As far as I know we don’t have Multi-Release magic in Java-lang and the 9+ Profile would skip coverage checks, so using Java 8 looks like the optimal build environment.

BTW the Source Link on the site is broken.

Gruss
Bernd

Gruss
Bernd
--
http://bernd.eckenfels.net

________________________________
Von: Rob Tompkins <[hidden email]>
Gesendet: Samstag, Februar 2, 2019 9:49 PM
An: Commons Developers List
Betreff: [lang] Ready for 3.9???

Just curious if we want to send 3.9 out? Build on java 11 targeting java 8?

-Rob

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [lang] Ready for 3.9???

Pascal Schumacher
In reply to this post by Rob Tompkins
No sure if it worth it, as there are very few new features and no
bugfixes, see:

https://github.com/apache/commons-lang/blob/master/src/changes/changes.xml

Also the function class addition:

https://github.com/apache/commons-lang/commit/11d9eb47a40359e74a5e24daf681beacd71b35f0 


https://github.com/apache/commons-lang/commit/2ebc17ba3f244ae44aae46273aeef7e321f9542a 


broke the build, because:

- FunctionsTest is missing the apache license header

- Functions and FunctionsTest contain check-style violation

Am 02.02.2019 um 21:49 schrieb Rob Tompkins:
> Just curious if we want to send 3.9 out? Build on java 11 targeting java 8?
>
> -Rob
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [lang] Ready for 3.9???

Rob Tompkins
Ok. I’ll hold off.

-Rob

> On Feb 3, 2019, at 8:16 AM, Pascal Schumacher <[hidden email]> wrote:
>
> No sure if it worth it, as there are very few new features and no bugfixes, see:
>
> https://github.com/apache/commons-lang/blob/master/src/changes/changes.xml
>
> Also the function class addition:
>
> https://github.com/apache/commons-lang/commit/11d9eb47a40359e74a5e24daf681beacd71b35f0 
>
> https://github.com/apache/commons-lang/commit/2ebc17ba3f244ae44aae46273aeef7e321f9542a 
>
> broke the build, because:
>
> - FunctionsTest is missing the apache license header
>
> - Functions and FunctionsTest contain check-style violation
>
>> Am 02.02.2019 um 21:49 schrieb Rob Tompkins:
>> Just curious if we want to send 3.9 out? Build on java 11 targeting java 8?
>>
>> -Rob
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [lang] Ready for 3.9???

garydgregory
In reply to this post by Rob Tompkins
If the target is Java 8, it feels safe to build on Java 8. Testing on Java
11 is a must these days IMO.

Gary

On Sat, Feb 2, 2019 at 3:49 PM Rob Tompkins <[hidden email]> wrote:

> Just curious if we want to send 3.9 out? Build on java 11 targeting java 8?
>
> -Rob
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>