still trying to get ant, jakarta commons, ftp task, on z/OS to play (Upgrade to J1.4 does not solve problem)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

still trying to get ant, jakarta commons, ftp task, on z/OS to play (Upgrade to J1.4 does not solve problem)

blatt, lew
some friendly list folk advised me to upgrade to J1.4, which eliminated the
error message "Unsupported major.minor version 48.0", when trying to launch
an ftp task from ant.   however, i continue to see the problem below, where
the Server Reply is not understood by client (with ant 1.6.5, commons 1.4.0,
and java 1.4).

advice please, thanks,
lew

>_____________________________________________
>From: blatt, lew  
>Sent: Tuesday, July 19, 2005 5:20 PM
>To: 'Jakarta Commons Users List'
>Subject: ant, jakarta commons,  ftp task, and z/OS
>
>in advance, i apologize if i am in the wrong forum.
>
>two questions:
>
>1)  i've a build system based on ant 1.5.4 and NetComponents.jar.  albeit
>outdated, this combo works well enough for us on many platforms.  we can
>ant build and launch ftp tasks.  trying to implement same on z/OS (IBM
>mainframe) gives:
>
>transfer: com.oroinc.net.MalformedServerReplyException: Could not parse
>response
> code.
>Server Reply:
>▬▬ÉÇ%?─/%╟?╦╚♠%?─/%└?_/╤>ÇπΦ&Ç╦┴╩╬┴╩Çêε┴╩╦╤?>Ç╧═▬♠û♠▬òëÇ╩┴/└`♠
>        at
>org.apache.tools.ant.taskdefs.optional.net.FTP.execute(FTP.java:1010)
>        at org.apache.tools.ant.Task.perform(Task.java:341)
>        at org.apache.tools.ant.Target.execute(Target.java:309)
>        at org.apache.tools.ant.Target.performTasks(Target.java:336)
>        at org.apache.tools.ant.Project.executeTarget(Project.java:1339)
>        at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:397)
>
>
>can anyone offer an answer why the error occurs ?
>
>2) anticipating someone would tell me to upgrade to jakarta (or get off
>this list :)), i updated to ant 1.6.5 and commons 1.4.0.  launching an ftp
>task gives:
>
>java.lang.UnsupportedClassVersionError:
>org/apache/commons/net/ftp/FTPClient (Unsupported major.minor version 48.0)
>
>the Java version i am running is 1.3.  i saw a hit associated with the
>error message, suggesting the user upgrade to Java 1.4.  is this, in fact,
>the ticket ?  
>
>thanks, lew
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]