[vote][net] Release commons-net 1.4.1?

classic Classic list List threaded Threaded
150 messages Options
1234 ... 8
Reply | Threaded
Open this post in threaded view
|

[vote][net] Release commons-net 1.4.1?

Steve Cohen
It has been discovered that 1.4.0 is inadvertently incompatible with jdk
1.3.  Please vote on a release of a fixed version.

I'll start it off
+1

I will also volunteer to do the release but it won't be until next week
at the earliest.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Dion Gillard-2
+1

On 11/22/05, Steve Cohen <[hidden email]> wrote:

> It has been discovered that 1.4.0 is inadvertently incompatible with jdk
> 1.3.  Please vote on a release of a fixed version.
>
> I'll start it off
> +1
>
> I will also volunteer to do the release but it won't be until next week
> at the earliest.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
http://www.multitask.com.au/people/dion/
"You are going to let the fear of poverty govern your life and your
reward will be that you will eat, but you will not live." - George
Bernard Shaw

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Jeffrey Brekke-2
In reply to this post by Steve Cohen
+1

Steve Cohen wrote:

> It has been discovered that 1.4.0 is inadvertently incompatible with jdk
> 1.3.  Please vote on a release of a fixed version.
>
> I'll start it off
> +1
>
> I will also volunteer to do the release but it won't be until next week
> at the earliest.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>


--
=====================================================================
Jeffrey D. Brekke                                   [hidden email]
Wisconsin,  USA                                     [hidden email]
                                                     [hidden email]
http://www.bloglines.com/blog/jbrekke               [hidden email]


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

robert burrell donkin
In reply to this post by Steve Cohen
On Mon, 2005-11-21 at 21:24 -0600, Steve Cohen wrote:
> It has been discovered that 1.4.0 is inadvertently incompatible with jdk
> 1.3.  Please vote on a release of a fixed version.

+1

- robert


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Mario Ivankovits
In reply to this post by Steve Cohen
Steve Cohen wrote:
> It has been discovered that 1.4.0 is inadvertently incompatible with
> jdk 1.3.  Please vote on a release of a fixed version.
Checked VFS using "net svn head" and it works.

So here is my +1


BTW: maven builds a 1.5.0 version instead of 1.4.1. Do you plan to
release svn head or a patched/rebuild 1.4.0?

---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Steve Cohen
Mario Ivankovits wrote:

> Steve Cohen wrote:
>
>> It has been discovered that 1.4.0 is inadvertently incompatible with
>> jdk 1.3.  Please vote on a release of a fixed version.
>
> Checked VFS using "net svn head" and it works.
>
> So here is my +1
>
>
> BTW: maven builds a 1.5.0 version instead of 1.4.1. Do you plan to
> release svn head or a patched/rebuild 1.4.0?
>
> ---
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
I suppose a head release.  There are a few bugs fixed.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Steve Cohen
In reply to this post by Mario Ivankovits
Mario Ivankovits wrote:

> Steve Cohen wrote:
>
>> It has been discovered that 1.4.0 is inadvertently incompatible with
>> jdk 1.3.  Please vote on a release of a fixed version.
>
> Checked VFS using "net svn head" and it works.
>
> So here is my +1
>
>
> BTW: maven builds a 1.5.0 version instead of 1.4.1. Do you plan to
> release svn head or a patched/rebuild 1.4.0?
>
> ---
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
Please disregard my earlier reply.  I realize that I misunderstood you.
  You are, I presume, talking about the version number of net that maven
currently builds.  This will have to be changed of course.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Steve Cohen
Steve Cohen wrote:

> Mario Ivankovits wrote:
>
>> Steve Cohen wrote:
>>
>>> It has been discovered that 1.4.0 is inadvertently incompatible with
>>> jdk 1.3.  Please vote on a release of a fixed version.
>>
>>
>> Checked VFS using "net svn head" and it works.
>>
>> So here is my +1
>>
>>
>> BTW: maven builds a 1.5.0 version instead of 1.4.1. Do you plan to
>> release svn head or a patched/rebuild 1.4.0?
>>
>> ---
>> Mario
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>>
> Please disregard my earlier reply.  I realize that I misunderstood you.
>  You are, I presume, talking about the version number of net that maven
> currently builds.  This will have to be changed of course.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
As I have little time now, I propose the following.  1.4.1 will be just
1.4.0 with whatever changes are needed to reverse the dependency on jdk
1.4.x.  No other bug fixes will be included.

Re-vote

+1 [yes]
-1 [no]

I vote +1.

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Stefan Bodewig
On Wed, 30 Nov 2005, Steve Cohen <[hidden email]> wrote:

> As I have little time now, I propose the following.  1.4.1 will be
> just 1.4.0 with whatever changes are needed to reverse the
> dependency on jdk 1.4.x.  No other bug fixes will be included.
>
> Re-vote
>
> +1 [yes]
> -1 [no]

+1

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Dion Gillard-2
In reply to this post by Steve Cohen
[snip]
> As I have little time now, I propose the following.  1.4.1 will be just
> 1.4.0 with whatever changes are needed to reverse the dependency on jdk
> 1.4.x.  No other bug fixes will be included.
>
> Re-vote
>
> +1 [yes]
> -1 [no]

+1.
--
http://www.multitask.com.au/people/dion/
"You are going to let the fear of poverty govern your life and your
reward will be that you will eat, but you will not live." - George
Bernard Shaw

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Mario Ivankovits
In reply to this post by Steve Cohen
Steve Cohen wrote:
> As I have little time now, I propose the following.  1.4.1 will be
> just 1.4.0 with whatever changes are needed to reverse the dependency
> on jdk 1.4.x.  No other bug fixes will be included.
>
> Re-vote
>
> +1 [yes]
> -1 [no]
+1

---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

rdonkin
-1 to any commons-net new release. see pmc thread for details (if any
committers aren't on the pmc please shout and i'll nominate you)

- robert

On Thu, 2005-12-01 at 07:47 +0100, Mario Ivankovits wrote:

> Steve Cohen wrote:
> > As I have little time now, I propose the following.  1.4.1 will be
> > just 1.4.0 with whatever changes are needed to reverse the dependency
> > on jdk 1.4.x.  No other bug fixes will be included.
> >
> > Re-vote
> >
> > +1 [yes]
> > -1 [no]
> +1
>
> ---
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

signature.asc (196 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Stephen Colebourne
robert burrell donkin wrote:
> -1 to any commons-net new release. see pmc thread for details (if any
> committers aren't on the pmc please shout and i'll nominate you)

I am on the PMC but haven't got mails for a long time :-/

Stephen

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Rory Winston-3
In reply to this post by rdonkin
Can you just summarize what your objections are instead of referencing
some location that most people don't have access to?

robert burrell donkin wrote:

> -1 to any commons-net new release. see pmc thread for details (if any
> committers aren't on the pmc please shout and i'll nominate you)
>
> - robert
>
> On Thu, 2005-12-01 at 07:47 +0100, Mario Ivankovits wrote:
>  
>> Steve Cohen wrote:
>>    
>>> As I have little time now, I propose the following.  1.4.1 will be
>>> just 1.4.0 with whatever changes are needed to reverse the dependency
>>> on jdk 1.4.x.  No other bug fixes will be included.
>>>
>>> Re-vote
>>>
>>> +1 [yes]
>>> -1 [no]
>>>      
>> +1
>>
>> ---
>> Mario
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: [hidden email]
>> For additional commands, e-mail: [hidden email]
>>
>>
>>    



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Steve Cohen
In reply to this post by rdonkin
robert burrell donkin wrote:

> -1 to any commons-net new release. see pmc thread for details (if any
> committers aren't on the pmc please shout and i'll nominate you)
>
> - robert
>
> On Thu, 2005-12-01 at 07:47 +0100, Mario Ivankovits wrote:
>
>>Steve Cohen wrote:
>>
>>>As I have little time now, I propose the following.  1.4.1 will be
>>>just 1.4.0 with whatever changes are needed to reverse the dependency
>>>on jdk 1.4.x.  No other bug fixes will be included.
>>>
>>>Re-vote
>>>
>>>+1 [yes]
>>>-1 [no]
>>
>>+1
>>
>>---
>>Mario
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: [hidden email]
>>For additional commands, e-mail: [hidden email]
>>
>>
OK.  Robert is referring to a serious issue here.  It's prudent to wait.
  There are questions about copyright on one of our classes.

The thread Robert refers to has the subject

"Re: Does Apache have agreement to use other open source code outside of
Apache?"

and it's all in the last couple of days.

So we have to wait.

Which is just as well.  Because I have another issue.  I don't
understand the maven.compile.target property.  Working from the net
1.4.0 tag, I change only project.properties to set maven.compile.target
back to 1.2.  Since there are a few places in 1.4.0 that depend on jdk
1.4, my expectation was that changing the project properties would cause
the compile to break on those places.  But it did not.  It compiled
successfully.

Why wouldn't it break?

Can someone explain how this works?







---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Henri Yandell
In reply to this post by Rory Winston-3
For the thread's info; Robert's cc'd Rory on the pmc email.

This is legal shit and irritatingly it seems there are increased
liability issues when you talk publically.

Any active committer should be on the PMC, unless they've only
recently joined, so if you're active kick away and one of us will
gladly nominate you.

--

Stephen: I'm guessing you didn't get my reply when you asked about not
getting mail from the list a while back. [hidden email] is
subscribed, which forwards to [hidden email]. Is that still
active?

Hen

On 12/1/05, Rory Winston <[hidden email]> wrote:

> Can you just summarize what your objections are instead of referencing
> some location that most people don't have access to?
>
> robert burrell donkin wrote:
> > -1 to any commons-net new release. see pmc thread for details (if any
> > committers aren't on the pmc please shout and i'll nominate you)
> >
> > - robert
> >
> > On Thu, 2005-12-01 at 07:47 +0100, Mario Ivankovits wrote:
> >
> >> Steve Cohen wrote:
> >>
> >>> As I have little time now, I propose the following.  1.4.1 will be
> >>> just 1.4.0 with whatever changes are needed to reverse the dependency
> >>> on jdk 1.4.x.  No other bug fixes will be included.
> >>>
> >>> Re-vote
> >>>
> >>> +1 [yes]
> >>> -1 [no]
> >>>
> >> +1
> >>
> >> ---
> >> Mario
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: [hidden email]
> >> For additional commands, e-mail: [hidden email]
> >>
> >>
> >>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Mario Ivankovits
In reply to this post by Steve Cohen
Steve Cohen wrote:
>
> The thread Robert refers to has the subject
>
> "Re: Does Apache have agreement to use other open source code outside
> of Apache?"
Has this something to do with an email from IBM in the last few days
asking me if I am really was the creator of my contributions?
Not that I made any mistake (I guess this was a mail to all commons-net
developers), but I was a little bit irritated.

> Which is just as well.  Because I have another issue.  I don't
> understand the maven.compile.target property.  Working from the net
> 1.4.0 tag, I change only project.properties to set
> maven.compile.target back to 1.2.  Since there are a few places in
> 1.4.0 that depend on jdk 1.4, my expectation was that changing the
> project properties would cause the compile to break on those places.  
> But it did not.  It compiled successfully.
The jdk1.4 compiler creates a class file suitable to run under an
earlier JVM, this works as long as you do not use any new api. Then
you'll get the NoSuchMethod Exception.
This is the reason why we should use the least possible compiler and not
only the target attribute. You didnt notice if you use any new api call
at compile time.


---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Dion Gillard-2
On 12/2/05, Mario Ivankovits <[hidden email]> wrote:

> Steve Cohen wrote:
> >
> > The thread Robert refers to has the subject
> >
> > "Re: Does Apache have agreement to use other open source code outside
> > of Apache?"
> Has this something to do with an email from IBM in the last few days
> asking me if I am really was the creator of my contributions?
> Not that I made any mistake (I guess this was a mail to all commons-net
> developers), but I was a little bit irritated.

Probably. The commons-net copyright question was raised by an IBM email.

If you do get those questions, please make sure they get copied to
[hidden email]. The PMC should be the one responsible for
answering questions about our code.

> > Which is just as well.  Because I have another issue.  I don't
> > understand the maven.compile.target property.  Working from the net
> > 1.4.0 tag, I change only project.properties to set
> > maven.compile.target back to 1.2.  Since there are a few places in
> > 1.4.0 that depend on jdk 1.4, my expectation was that changing the
> > project properties would cause the compile to break on those places.
> > But it did not.  It compiled successfully.
> The jdk1.4 compiler creates a class file suitable to run under an
> earlier JVM, this works as long as you do not use any new api. Then
> you'll get the NoSuchMethod Exception.
> This is the reason why we should use the least possible compiler and not
> only the target attribute. You didnt notice if you use any new api call
> at compile time.
>
>
> ---
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>


--
http://www.multitask.com.au/people/dion/
"You are going to let the fear of poverty govern your life and your
reward will be that you will eat, but you will not live." - George
Bernard Shaw

---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Mario Ivankovits
In reply to this post by Henri Yandell
Hi!
> Any active committer should be on the PMC, unless they've only
> recently joined, so if you're active kick away and one of us will
> gladly nominate you.
>  
I wasnt aware that we (the committers) are allowed to be on the PMC list.
I thought it need some time until a committer can become a PMC.

Though, if possible I would like to join the mailinglist!

---
Mario


---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: [vote][net] Release commons-net 1.4.1?

Rory Winston-3
Me too, if possible.

I havent received the CC: yet, so if someone who is on the PMC can
forward a copy of the email to me, I would appreciate it.

Mario Ivankovits wrote:

> Hi!
>> Any active committer should be on the PMC, unless they've only
>> recently joined, so if you're active kick away and one of us will
>> gladly nominate you.
>>  
> I wasnt aware that we (the committers) are allowed to be on the PMC list.
> I thought it need some time until a committer can become a PMC.
>
> Though, if possible I would like to join the mailinglist!
>
> ---
> Mario
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: [hidden email]
> For additional commands, e-mail: [hidden email]
>
>
>
>



---------------------------------------------------------------------
To unsubscribe, e-mail: [hidden email]
For additional commands, e-mail: [hidden email]

1234 ... 8